Bug Hunting Session
Bug 43526 - Impress functionality request: Exporting a Presentation containing audio narration to FLASH
Summary: Impress functionality request: Exporting a Presentation containing audio narr...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86-64 (AMD64) All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-04 21:25 UTC by George Masters
Modified: 2017-08-13 10:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description George Masters 2011-12-04 21:25:34 UTC
I insert recorded narration in slides I create for training modules. I have tried inserting .mp3 and .wav audio into the presentation. When doing the slide show kiosk style within Impress, the sound plays as I would expect it. However, when I export the presentation as a Macromedia flash file, the audio does not export to the flash version. This is a _real_ show-stooper (pun intended) for me. Currently the only way to create training material from Impress is to export the .jpgs and .mp3 audio to Macromedia flash and write ActionScript to create an interactive training presentation with audio.

The ideal is to fix this gotcha. I have tried it under both Ubuntu 10.10 and Windows 7 with similar silent results. Being able to produce Flash presentation with audio using Impress will be useful to the world's educators who develop training materials of all kinds.
Comment 1 sasha.libreoffice 2012-03-22 10:34:06 UTC
Thanks for bugreport
But SWF format is now obsolete. IMHO no sense to improve exporting to it.
It would be much useful to add exporting to video format
Comment 2 George Masters 2012-03-22 22:43:33 UTC
Sasha, I do understand the concern about the perceived obsolescence of SWF, the technology used in Flash. The reality of the matter is that educational institutions worldwide still use it for courseware preparation and most likely will to do so continue until HTML 5 multimedia standards become ratified by the W3C and the browsers catch up. Currently, a great deal of courseware is designed with tools like Captivate and Articulate as well as Poto mention two industry-standard development tools. These tools can be difficult for some classroom teachers to learn and most already know how to use MS PowerPoint. Some then take the PowerPoint or Impress Presentation and use third-party tools to get Flash with audio. Courseware without audio is very old-school and not in vogue. If Impress could do that as advertised, it would be a big coup.

I think that we as users in the open-source community need to look at what's in demand rather than just what's hot development technology. I do understand the need to research and develop the new technologies and for our developers to continue extend the technology envelope. The open-source community has made great strides not only with Libre Office/OpenOffice.org, but with improving the usability of Linux for the masses. History in my opinion has shown us that had the Unix gurus of the 70's and 80's not been so cavalier in their attitude that Unix was for engineers and windows for the masses, Microsoft may not have become the giant near monopoly it has become.
 
George Masters

<b><i>The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender immediately and delete the material from any computer.

</b></i>



________________________________
 From: "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org>
To: gmasters2@yahoo.com 
Sent: Thursday, March 22, 2012 10:34 AM
Subject: [Bug 43526] Exporting a Presentation containing audio narration to FLASH has no audio
 
https://bugs.freedesktop.org/show_bug.cgi?id=43526

sasha.libreoffice@gmail.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |sasha.libreoffice@gmail.com

--- Comment #1 from sasha.libreoffice@gmail.com 2012-03-22 10:34:06 PDT ---
Thanks for bugreport
But SWF format is now obsolete. IMHO no sense to improve exporting to it.
It would be much useful to add exporting to video format
Comment 3 sasha.libreoffice 2012-03-23 02:14:47 UTC
Thanks for reply
I'm trying to hint that exporting to SWF is experimental functionality. We have no developer who maintains this and can add exporting audio to SWF. This bug may never be fixed or years will pass until fix.

I retain status to Unconfirmed for attract more testers to this bugreport. I hope that somebody can help in this problem. Sorry for can not help much.
Comment 4 sasha.libreoffice 2012-04-30 02:06:06 UTC
Improving of exporting to swf and pdf is among tasks for GSoC 2012 from LibreOffice. So, we have some hope that this problem will be fixed in this year if someone will choose this task.
Comment 5 Joel Madero 2012-07-15 20:13:23 UTC
If this is a confirmed issue we should move it out of UNCONFIRMED status. But, two points:

1. This is not a critical bug, please see this chart to get a sense of prioritizing bugs: https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg


2. In terms of fixing the bug and in response to your last post:

Without any other commenter over the course of 8 months, it seems apparent that this is not in demand (no offense) but we have to look at thousands of bugs and decide what is in demand and what isn't. LO most definitely takes our user base's desires as it's #1 priority

Sasha, if this is confirmed can you move it to NEW, prioritize it correctly and then next time we do a bug cleanup we can discuss if we want to close this as WONTFIX. Thanks!
Comment 6 Harri Kiiskinen 2012-08-28 12:44:33 UTC
I tried to do exactly what Mr. Masters, the original reporter of the bug, had done, and was disappointed when the resulting obsolete-but-still-in-use-by-everyone flash format presentation had no narrators' voice at all.

So I do CONFIRM this bug on version 3.5.4.2 (from Debian stable backports). I guess the developers have a lot to do besides this – at least that is obvious from the comments above...

Won't touch the status things, but this was on 3.5.4.2, 32-bit, Debian Stable from backports.
Comment 7 Joel Madero 2013-06-21 18:56:34 UTC
Requesting additional input as I'm not sure if this is feasible given flash is quickly going away and HTML5 will be the standard shortly - or so I've been told :)
Comment 8 Thorsten Behrens (CIB) 2013-06-26 17:04:17 UTC
Adjusting prio, setting to confirmed. Next stop: interested parties to go hunting for a developer to implement this.
Comment 9 Robinson Tryon (qubit) 2013-11-18 18:31:53 UTC
Bug is NEW
Whiteboard: Removing 'Need_Advice'
Comment 10 Adolfo Jayme 2017-08-13 10:01:58 UTC
The Flash technology is now deader than it was when comment 1 was posted. Adobe has killed it officially now. Now, if we had some sort of modern Web export, as an extension… to one of the many frameworks in existence (https://github.com/search?utf8=%E2%9C%93&q=slides&type=)… But I digress.