Download it now!
Bug 43546 - ACCESSIBILITY: Images lose title and description (alternative text) on exporting ODT to DOC or DOCX [accessibility]
Summary: ACCESSIBILITY: Images lose title and description (alternative text) on export...
Status: RESOLVED DUPLICATE of bug 43547
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 67137 (view as bug list)
Depends on:
Blocks: a11y-Windows
  Show dependency treegraph
 
Reported: 2011-12-06 03:28 UTC by Christophe Strobbe
Modified: 2016-09-07 03:29 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT file containing pictures with different types of text alternatives (42.98 KB, application/vnd.oasis.opendocument.text)
2011-12-06 03:28 UTC, Christophe Strobbe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe Strobbe 2011-12-06 03:28:24 UTC
Created attachment 54146 [details]
ODT file containing pictures with different types of text alternatives

When exporting ODT from Writer to the Microsoft Word formats DOC and DOCX both the title and the description (two types of text alternatives for accessibility) are lost.

Steps to reproduced the issue:
1. Create a new document in Writer.
2. Add an image and give it only a title (right-click, choose "Description" from the context menu and fill in "Title").
3. Add an image and give it only a description (right-click, choose "Description" and fill in "Description").
4. Add an image and give it both a title and a description (right-click, choose "Description" and fill in both fields in the dialog window).
5. Save the file as "Microsoft Word 97/2000/XP/2003 (.doc)".
6. Open the original ODT file again and save it as "Microsoft Word 2007/2010 (.docx)".
7. Open the DOCX file in Microsoft Word 2010 (or an older version that supports DOCX), right-click on each image, choose "Format picture", then "Alt text": the Title field is empty, while the Description field contains the string "A description".
8. Open the DOCX file in Microsoft Word 2010 (or an older version), right-click on each image, choose "Format picture", then "Alt text": the "Alternative text" field is empty.

Desired behaviour:
1. When exporting to DOCX, ODF's title and description should be mapped to DOCX's title and description.
2. When exporting to DOC, ODF's title and description, at least the title should be mapped to alt text (and ideally the description should be appended to it).
Comment 1 Christophe Strobbe 2012-01-27 05:57:19 UTC
Version info was previously LibO 3.4.3. I confirm that this bug is still
present in LibreOffice 3.5.0 RC1 (this can be checked by importing the exported DOC and DOCX files into Writer). Note that the default title on an image in an exported DOCX is now "A description..." (not only when exporting an English document from Writer with the English UI but also when exporting a German document from Writer with the German UI). 
Changing status from UNCONFIRMED to NEW.
Comment 2 sasha.libreoffice 2012-02-13 07:33:10 UTC
@ Christophe
Thanks for reporting and maintaining this bug. 
But "Version" is most old version of Libreoffice, where this bug was found, not current version.
Comment 3 Jorendc 2015-05-29 18:49:07 UTC
*** Bug 67137 has been marked as a duplicate of this bug. ***
Comment 4 Erkan 2015-08-17 08:50:12 UTC
Here is same problem. 4.4.2.2 Release. It isn't still fix
Comment 5 Andrey Skvortsov 2016-06-28 09:58:17 UTC
Issue exists in 5.1.4. 

To reproduce the issue MS Office is not needed. Just open saved doc or docx document in Writer. LO can import title and description, but has problems to write they back.

Export to DOCX: description is exported successfully, but title is NOT. 

Export to DOC: title is not exported. description is empty too, but as I understand from comment above. Descriptions are not supported by doc format. 

So I'd say that part of the issue is already fixed. But saving title to DOCX and DOC is not working yet.
Comment 6 Yousuf Philips (jay) (retired) 2016-09-07 03:29:44 UTC
Marking this a duplicate of bug 43547 for ooxml and bug 43548 for the old binary ms office format.

*** This bug has been marked as a duplicate of bug 43547 ***