Download it now!
Bug 43567 - Crash when editing formcontrol properties in XML-Form-Document
Summary: Crash when editing formcontrol properties in XML-Form-Document
Status: RESOLVED DUPLICATE of bug 40261
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: high blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-12-07 01:12 UTC by Christoph Lutz
Modified: 2012-02-25 05:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
log file (113.13 KB, text/x-log)
2012-02-09 10:32 UTC, Alex Thurgood
Details
bt with symbols on master (8.99 KB, text/plain)
2012-02-09 12:24 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Lutz 2011-12-07 01:12:00 UTC
There is a crash if you perform the following steps:

1) Start LibreOffice-Writer
2) File->New->XML-Formdocument
3) If FormControl-Toolbar not already visible: View->Toolbars->FormControls
4) Select a Textfield-FormControl in the toolbar and create one textfield-object in the document
5) Doubleklick the border of the textfield-object (to edit the formcontrols properties) --> CRASH
Comment 1 Alex Thurgood 2012-02-09 10:19:04 UTC
Confirming in Master

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x07444a22, pid=4914, tid=3063744496
#
# JRE version: 6.0_26-b03
# Java VM: Java HotSpot(TM) Client VM (20.1-b02 mixed mode, sharing linux-x86 )
# Problematic frame:
# C  [libpcrlo.so+0x37a22]  _init+0xbb56
#
# An error report file with more information is saved as:
# /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/hs_err_pid4914.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp



Alex
Comment 2 Alex Thurgood 2012-02-09 10:20:32 UTC
As it is in current master, it will also be in 3.5RC3, but need to test that on another machine.


Alex
Comment 3 Alex Thurgood 2012-02-09 10:21:25 UTC
I will nominate this as a blocker for 3.5.


Alex
Comment 4 Alex Thurgood 2012-02-09 10:22:45 UTC
(In reply to comment #0)
> There is a crash if you perform the following steps:
> 
> 1) Start LibreOffice-Writer
> 2) File->New->XML-Formdocument
> 3) If FormControl-Toolbar not already visible: View->Toolbars->FormControls
> 4) Select a Textfield-FormControl in the toolbar and create one
> textfield-object in the document
> 5) Doubleklick the border of the textfield-object (to edit the formcontrols
> properties) --> CRASH

A right mouse button click to bring up the context menu will do the same thing.

Alex
Comment 5 Alex Thurgood 2012-02-09 10:23:24 UTC
Setting to ALL platforms as I experienced crash on Linux
Comment 6 Alex Thurgood 2012-02-09 10:30:30 UTC
Hmm I have a 186Mb core file, where to put it ?

Alex
Comment 7 Alex Thurgood 2012-02-09 10:32:02 UTC
Created attachment 56828 [details]
log file
Comment 8 Alex Thurgood 2012-02-09 10:53:55 UTC
gdb says :

Core was generated by `/home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/soffice.bin'.
Program terminated with signal 4, Illegal instruction.
#0  0x0294a5d8 in FactoryImpl (this=0x294a5d8)
    at /home/alex/LODEV/core/stoc/source/proxy_factory/proxyfac.cxx:412
412	FactoryImpl::FactoryImpl()
Comment 9 Alex Thurgood 2012-02-09 10:58:45 UTC
bt
#0  0x0294a5d8 in FactoryImpl (this=0x294a5d8)
    at /home/alex/LODEV/core/stoc/source/proxy_factory/proxyfac.cxx:412
#1  (anonymous namespace)::proxyfac_create ()
    at /home/alex/LODEV/core/stoc/source/proxy_factory/proxyfac.cxx:495
#2  0xad172357 in VMError::report_and_die() ()
   from /usr/lib/jvm/java-6-sun-1.6.0.26/jre/lib/i386/client/libjvm.so
#3  0xad09924c in JVM_handle_linux_signal ()
   from /usr/lib/jvm/java-6-sun-1.6.0.26/jre/lib/i386/client/libjvm.so
#4  0xad094f34 in signalHandler(int, siginfo*, void*) ()
   from /usr/lib/jvm/java-6-sun-1.6.0.26/jre/lib/i386/client/libjvm.so
#5  <signal handler called>
#6  0x07444a22 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libpcrlo.so
#7  0x074a3f8c in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libpcrlo.so
#8  0x07496a05 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libpcrlo.so
#9  0x0744f07e in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libpcrlo.so
#10 0x0744fcfe in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libpcrlo.so
#11 0x074500f6 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libpcrlo.so
#12 0x07498673 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libpcrlo.so
#13 0x0749aed7 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libpcrlo.so
#14 0x0749b2b2 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libpcrlo.so
#15 0x0749b42b in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libpcrlo.so
#16 0x03916021 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libsvxlo.so
#17 0x03917922 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libsvxlo.so
#18 0x00f9d7d1 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libsfxlo.so
#19 0x00f8d3c4 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libsfxlo.so
#20 0x00f8dee2 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libsfxlo.so
#21 0x00f903ab in SfxBindings::Update(unsigned short) ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libsfxlo.so
#22 0x04700041 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libsvxcorelo.so
#23 0x047000ca in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libsvxcorelo.so
#24 0x04700bd1 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libsvxcorelo.so
#25 0x04700c16 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/../program/libsvxcorelo.so
#26 0x04e36452 in Timer::Timeout() ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libvcllo.so
#27 0x04e36501 in Timer::ImplTimerCallbackProc() ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libvcllo.so
#28 0x013dc1ed in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libvclplug_gtklo.so
#29 0x018d725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0x018d7990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0x018d7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0x013dbe3b in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libvclplug_gtklo.so
#33 0x013dcad9 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libvclplug_gtklo.so
#34 0x04e31b5d in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libvcllo.so
#35 0x04e2f906 in Application::Yield(bool) ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libvcllo.so
#36 0x04e2f937 in Application::Execute() ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libvcllo.so
#37 0x00249056 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libsofficeapp.so
#38 0x04e35ea1 in ?? ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libvcllo.so
#39 0x04e35fd4 in SVMain() ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libvcllo.so
#40 0x002620a4 in soffice_main ()
   from /home/alex/LODEV/core/solver/unxlngi6.pro/installation/opt/program/libsofficeapp.so
#41 0x0804850c in ?? ()
#42 0x0037a113 in __libc_start_main (main=0x80484e0, argc=2, ubp_av=0xbff38d74, init=0x80485e0, fini=
    0x8048650, rtld_fini=0x9d4bc0, stack_end=0xbff38d6c) at libc-start.c:226
#43 0x08048545 in ?? ()
Backtrace stopped: Not enough registers or memory available to unwind further
Comment 10 Julien Nabet 2012-02-09 12:24:45 UTC
Created attachment 56832 [details]
bt with symbols on master

I reproduced the pb on master pc Debian x86-64.
I got the same bt as fdo#44842 (duplicate ?)
Comment 11 Alex Thurgood 2012-02-09 12:40:30 UTC
This seems to be a dup of 40261, sigh.

Alex

*** This bug has been marked as a duplicate of bug 40261 ***
Comment 12 Alex Thurgood 2012-02-09 12:47:57 UTC
(In reply to comment #10)
> Created attachment 56832 [details]
> bt with symbols on master
> 
> I reproduced the pb on master pc Debian x86-64.
> I got the same bt as fdo#44842 (duplicate ?)

Hi Julien,

Looks like it, I'll mark it as such, but even this bug is a dup of 40261.

Alex