Bug Hunting Session
Bug 43620 - LibreOffice doesn't recognize keys F17 to F20
Summary: LibreOffice doesn't recognize keys F17 to F20
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2011-12-08 00:33 UTC by bda
Modified: 2018-10-13 19:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Customize->Keyboard window (in french) (60.85 KB, image/jpeg)
2012-06-17 23:40 UTC, bda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bda 2011-12-08 00:33:30 UTC
I have a SUN keyboard configured with function keys F12 to F20 at left keypad. Functions keys F12 to F16 are available for keyboard shorcuts but F17 to F20 are not in the list of keys.

These keys was available in OpenOffice 3.3
Comment 1 Joel Madero 2012-06-07 21:37:30 UTC
Is this still a problem for current version? I don't have those keys but will look into the issue further if you can confirm it's still an issue.
Comment 2 bda 2012-06-08 05:01:07 UTC
Yes, the problem remains at release 3.5.4.
Comment 3 Joel Madero 2012-06-12 09:37:21 UTC
I'll assign it to myself for now and see what I can do.
Comment 4 Joel Madero 2012-06-12 10:48:56 UTC
Just want to check, do these buttons work in other software within Linux? Want to make sure it's our bug, a quick glance through the code shows them still being mapped. If they work in other software that will convince me it's not the keybinding software of your distro that's causing the issue.
Comment 5 bda 2012-06-14 07:30:59 UTC
Thank you for your help.
Yes, they keys are bind and works in others software. For example, F16, F18 and F20 are "Copy", "Paste" and "Cut" keys in KDE kate and jedit editors and firefox.
Comment 6 Joel Madero 2012-06-15 11:40:43 UTC
I'm trying to track this one down and I'm having a bit of a problem because I'm only seeing up to F12 in my Customize->Keyboard list, does yours actually show up to F16? If so can you provide a screenshot just so that I can see what you see. I think I've tracked it down but I'm confused how I only see to F12 but you're able to get up to F16.

I'll have this bug solved in not too long if you can bare with me and provide the info. 

Thanks for keeping up with this bug, appreciate it
Comment 7 bda 2012-06-17 23:40:42 UTC
Created attachment 63157 [details]
Customize->Keyboard window (in french)
Comment 8 bda 2012-06-18 00:01:34 UTC
I have Customize->Keyboard window (Personnaliser->Clavier in french)

I have tried to save layout, to modify file saved in order to use keys F18 and F20, then reload modified file but keys F18 and F20 didn't work and didn't appear in list.
Comment 9 Joel Madero 2012-06-19 09:13:50 UTC
Thanks, I can't find where the trigger is to determine if F13-F16 is included, I even see yours is missing F15 which is strange in of itself. This one is a bit trickier than I anticipated but I'm working on it. Will post when I get it solved and committed
Comment 10 Joel Madero 2012-07-24 20:05:39 UTC
Unfortunately I'm going to un-assign myself because I can't get any key beyond F12 to show. LO has a check to see if you have the keys and my keyboard doesn't have anything higher than 12. Going to try to get someone else to pick it up
Comment 11 Robinson Tryon (qubit) 2014-12-30 17:15:06 UTC
(In reply to bda from comment #0)
> I have a SUN keyboard configured with function keys F12 to F20 at left
> keypad. Functions keys F12 to F16 are available for keyboard shorcuts but
> F17 to F20 are not in the list of keys.
> 
> These keys was available in OpenOffice 3.3

Whiteboard -> possibleRegression
Comment 12 Joel Madero 2015-01-26 02:56:54 UTC
I just tested 3.3 (first branch from AOO) and F13-F16 are not available. Not a regression at least that we caused. Removing possible Regression.
Comment 13 QA Administrators 2016-02-21 08:38:12 UTC Comment hidden (obsolete)
Comment 14 bda 2016-03-22 08:24:59 UTC
I can't do these tests because unfortunately, I didn't anymore have Sun keyboards.
Comment 15 QA Administrators 2017-05-22 13:20:19 UTC Comment hidden (obsolete)
Comment 16 Thomas Lendo 2018-10-13 19:28:44 UTC
Bug exists since 2011. The bug opener has no Sun keyboard anymore and others haven't registered. I think this bug won't fixed anytime. Therefore I close it as WONTFIX.

If there is someone with such keyboard and want to have this feature, please reopen as NEW.