Bug Hunting Session
Bug 43693 - Goal Seek: reproducable crash using "target value search"
Summary: Goal Seek: reproducable crash using "target value search"
Status: RESOLVED DUPLICATE of bug 37341
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86 (IA32) Windows (All)
: high blocker
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: GoalSeek
  Show dependency treegraph
 
Reported: 2011-12-10 06:44 UTC by Klaus Werner
Modified: 2018-06-20 19:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
simple spreedsheat (34.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-12-10 06:44 UTC, Klaus Werner
Details
Screenshot (2.25 MB, image/png)
2011-12-10 09:12 UTC, Rainer Bielefeld Retired
Details
Zielwertsuche (214.42 KB, image/png)
2011-12-10 11:13 UTC, Klaus Werner
Details
Screenshoot (188.72 KB, image/png)
2011-12-10 12:25 UTC, Klaus Werner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Klaus Werner 2011-12-10 06:44:21 UTC
Created attachment 54291 [details]
simple spreedsheat

Giving the task foran target value search 
with formula cell $K$248 to get a target value of zero
with changeable cell $H$5

leads reproducable to a blocking crash of libre office calc 3.4.4
(OOO340m1 (Build 402)
Comment 1 Klaus Werner 2011-12-10 06:51:24 UTC
Comment on attachment 54291 [details]
simple spreedsheat

Libre Office 3.4.4 (Build 402) crashes using
target value search on cell $K$248 aimed value of zero
with changeable cell $h$5
Comment 2 Rainer Bielefeld Retired 2011-12-10 09:04:31 UTC
NOT reproducible with reporter's sample and "LibreOffice 3.4.4  - WIN7 Home Premium (64bit) English UI [Build ID: OOO340m1 (Build:402)]" using SCO Evolutionary Aslorithm, DEPS and Linear for details see attached screenshots. May be I'm doing a little detail different to reporter?

Might be related to Bug 43388 Crash (Runtime error) when using SCO (or DEPS) Evolutionary Algorithm Solver

@reporter:
please:
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (and if possible how to created a 
  sample document from the scratch)
- add information 
  -- What algorithm you use
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind
Comment 3 Rainer Bielefeld Retired 2011-12-10 09:12:40 UTC
Created attachment 54295 [details]
Screenshot

Showing my results
Comment 4 Klaus Werner 2011-12-10 11:13:36 UTC
Created attachment 54305 [details]
Zielwertsuche
Comment 5 Klaus Werner 2011-12-10 11:20:01 UTC
Comment on attachment 54305 [details]
Zielwertsuche

Lade ich die Tabelle in Excel erhalte ich 
problemlos als Zielwert 3,73922738630465%
Comment 6 Klaus Werner 2011-12-10 12:25:59 UTC
Created attachment 54306 [details]
Screenshoot

Ändere ich die Bedingungen für Solve minimal ab
(in $K$247 den Wert 260 erzielen bei änderbarem $H$5)

zeigt der Solver nach ca 30 Sekunden den Lösungswert 260,
rechnet aber weiter bis nach 3 Minuten das Programm nicht mehr ansprechbar ist.
Comment 7 Rainer Bielefeld Retired 2011-12-19 22:02:55 UTC
With "Goal Seek" [Reproducible] with "LibreOffice 3.4.5 RC1  - WIN7 Home Premium (64bit) English UI [Build ID: OOO340m1 (Build:501)]", also with 
Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta1 - WIN7 Home Premium (64bit) German UI [Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4] Windows_Release_Configuration  11-Dec-2011 06:51" 

Currently I see this one as a DUP of "Bug 37341 - Goal Seek hangs indefinitely for too many calculation steps (Formula Cell $F$110)"

@reporter:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here.

*** This bug has been marked as a duplicate of bug 37341 ***
Comment 8 Commit Notification 2018-06-20 19:38:29 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1b4c09401053ff6df8de9e839299ac26efa28b37

uitest Calc/Goal seek; tdf#37341 ; tdf#43693

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.