Download it now!
Bug 43705 - UI: Switching landscape <-> portrait leaves ugly fragments in page pane
Summary: UI: Switching landscape <-> portrait leaves ugly fragments in page pane
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: All All
: medium normal
Assignee: Ivan Timofeev (retired)
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-12-11 00:44 UTC by Rainer Bielefeld Retired
Modified: 2012-01-24 10:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (156.96 KB, application/x-download)
2011-12-11 01:24 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-12-11 00:44:00 UTC
Steps how to reproduce with Server Installation of  "LibreOffice 3.5.0 - WIN7 Home Premium (64bit) English UI [Build ID: 35c8573-95bcc5e-4c1bcb] Win-x86@6-fast  pull time 2011-12-09 12:44:50":

1. Start LibO
   > LibO Start Center appears
2. New Drawing
   > Nes single portrait orientated single a4 page document appears
3. Menu 'Format -> Page -> Landscape'
   As expected orientation switches to landscape
   Unexpected: ugly portraitfragment remains in Page Pane

Was OK in 3.4.4, so regression

Also no problem in MinGW Build 2111-11-25 and Beta0, first visible with Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID:  a286353-090bcba-3bf3b94]" Win-x86@6 – 2011-12-02_22:36:35)

The problem disappears when I modify page size to "letter" in report version, I did not check this for other versions.
Comment 1 Rainer Bielefeld Retired 2011-12-11 01:24:47 UTC
Created attachment 54313 [details]
Screenshot

See original report!
Comment 2 Christina Rossmanith 2012-01-20 12:22:36 UTC
Behaviour could be reproduced. 

Additional observation: If you switch back to portrait and then again to landscape a second time the page pane look like expected.

LibreOffice 3.5.0rc1 
Build-ID: b6c8ba5-8c0b455-0b5e650-d7f0dd3-b100c87
Linux 2.6.38-13-generic (Ubuntu)
Comment 3 Florian Reisinger 2012-01-21 03:33:36 UTC
Additional observation:
It also works, when you open the Page Dialog and then just press ok. (After setting a different landscape)
It is the other way round too...
LibO 3.5RC1 + Win7 x64
Comment 4 Rainer Bielefeld Retired 2012-01-22 00:03:00 UTC
Modify OS due to comment 2

@Ivan:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 5 Ivan Timofeev (retired) 2012-01-22 03:39:18 UTC
(In reply to comment #1)
> Created attachment 54313 [details]
> Screenshot

Horrible!!!

Fixed in the master branch:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=799f2de5d1085d845ec498af0a7932965c42ed68
Comment 6 Ivan Timofeev (retired) 2012-01-24 10:52:13 UTC
Pushed to the libreoffice-3-5 branch (will be in RC2):
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=57aa683d40108b9133a2cd9cfd7b09a4a212a2e4