Bug 43707 - FILEOPEN PDF brings up (ASCII) filter selector instead of opening document
Summary: FILEOPEN PDF brings up (ASCII) filter selector instead of opening document
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Windows (All)
: medium major
Assignee: Michael Stahl
QA Contact:
URL:
Whiteboard:
Keywords: regression
: 43738 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-12-11 01:42 UTC by Rainer Bielefeld Retired
Modified: 2012-04-26 03:43 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-12-11 01:42:08 UTC
Steps how to reproduce with Server Installation of  "LibreOffice 3.5.0 - WIN7 Home Premium (64bit) English UI [Build ID: 35c8573-95bcc5e-4c1bcb] Win-x86@6-fast  pull time 2011-12-09 12:44:50" :
1. Start LibO
   > Start center appears
2. Menu 'file -> Open -> Arbitrary.PDF'
   Expected: document will be opened
   Actual: Filter list  (other Master versions: ASCII filter) appears

Extension is installed, but does not work.

Latest version I tested and see it working: Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [(Build ID:  d38713d-5d03837-ca7e6f5-c4bb9bd-ce71330)]" (Voreppe_Win32_Tinderbox 111115)

New User Profile die not help.

I see this as a major one
Comment 1 Rainer Bielefeld Retired 2011-12-13 23:31:58 UTC
Also in 3.5.0 Beta1 MinGW and MSVC, so NEW
Comment 2 Cor Nouws 2011-12-14 00:24:48 UTC
I do not have the problem in my 'pre-beta1' 
   Build ID: 202fca9-7f15fca-1f1fd1a-ca8e46d-5bcbce4
on Ubuntu.
Comment 3 Roman Eisele 2011-12-14 03:00:57 UTC
NOT reproducible on MacOS X 10.6.8 German,
neither with 3.5.0 beta 1:

LOdev 3.5.0 [should be: LibreOffice 3.5.0 beta 1]
Build-ID: 1ce7995-7f15fca-1f1fd1a-ca8e46d-5bcbce4
Installation file name: libreoffice-3-5~2011-12-13_04.48.06_LibO-Dev_3.5.0beta1_MacOS_x86_install_en-US

nor with master:

LOdev 3.6.0 
Build ID: bedebfc-b204871-3e50423-4c1bcb5
Build date: 2011-12-13
Installation file name: master~2011-12-13_04.31.10_LibO-Dev_3.6.0beta0_MacOS_x86_install_en-US.dmg

neither when opening a simple LibreOffice-generated 'Hello world!' document nor when opening a more complex PDF file (e.g., some sheet music generated by LilyPond).

Maybe yet another Windows-only bug?
Comment 4 Caolán McNamara 2011-12-15 04:38:17 UTC
This is similar to fdo#43422 missing component_getFactory symbol

$ dumpbin /exports wntmsci12.pro/bin/pdfimport.uno.dll
Microsoft (R) COFF/PE Dumper Version 9.00.30729.01
Copyright (C) Microsoft Corporation.  All rights reserved.


Dump of file wntmsci12.pro/bin/pdfimport.uno.dll

File Type: DLL

  Section contains the following exports for pdfimport.uno.dll

    00000000 characteristics
    4EE869F0 time date stamp Wed Dec 14 09:18:40 2011
        0.00 version
           1 ordinal base
           1 number of functions
           1 number of names

    ordinal hint RVA      name

          1    0 00001000 GetVersionInfo = _GetVersionInfo

  Summary

        1000 .data
        1000 .rdata
        1000 .reloc
        1000 .rsrc
        1000 .text
Comment 5 Caolán McNamara 2011-12-15 04:51:15 UTC
If I revert http://cgit.freedesktop.org/libreoffice/core/commit/?id=3fbedc3e8f65c91999dcee42daa8312e387dcf40 I get the symbols back
Comment 6 Caolán McNamara 2011-12-15 04:53:17 UTC
Sorry, wrong cut-and-paste, http://cgit.freedesktop.org/libreoffice/core/commit/?id=1fb5eb2162d79a44f5bb90627c1ca340d1322129 is the offender
Comment 7 Michael Stahl 2011-12-15 08:38:56 UTC
the problem potentially affects language guessing, mozilla address book, presenter console, pdf import, CMIS ucp.

hopefully fixed on master with:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=6fd2d815174df8274153ddb7e99eab26ab7e563c

hopefully fixed on libreoffice-3-5 with:
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=7eaf07eea371fadbc48c4d59c8b49bf8daf2eb6a
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=deb6451f3bbc44afe4a798e0fd28ab395bea840a

but i don't have windows here, so please test it...
Comment 8 Caolán McNamara 2011-12-19 12:46:01 UTC
*** Bug 43738 has been marked as a duplicate of this bug. ***
Comment 9 Rainer Bielefeld Retired 2011-12-21 03:22:50 UTC
Works fine with Server installation of  Master "LOdev 3.5.0beta2+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 22905fb-b605e4f-4c1bcb5]" Win-x86@6 - pull time 2011-12-20 20:59:59)
Comment 10 Owen Genat (retired) 2012-04-22 20:39:37 UTC
This bug appears to have regressed. Under Ubuntu 10.04 x64, 350m1 (Build:202) when attempting to open a PDF from within LO Draw the ASCII Filter Options dialog is again initiated. Same problem is being reported under Ubuntu 12.04, 350m1 (Build:202). Performing the same action under MacOS 10.6.8, 340m1 (Build:502) opens the PDF directly.
Comment 11 Jean-Baptiste Faure 2012-04-22 21:50:19 UTC
(In reply to comment #10)
> This bug appears to have regressed. Under Ubuntu 10.04 x64, 350m1 (Build:202)
> when attempting to open a PDF from within LO Draw the ASCII Filter Options
> dialog is again initiated. Same problem is being reported under Ubuntu 12.04,
> 350m1 (Build:202). Performing the same action under MacOS 10.6.8, 340m1
> (Build:502) opens the PDF directly.

Did you install pdfimport package? It seems it is not installed by default in Ubuntu versions.

Best regards. JBF
Comment 12 Caolán McNamara 2012-04-26 03:43:55 UTC
We'll assume that pdfimport isn't installed for the case of comment #10, if the problem persists please open a new bug rather than reopening this one as this one was for a very specific windows-only problem which is definitely fixed, even if your problem appears similar