Download it now!
Bug 43742 - EDITING: Auto-complete logic does not help editing
Summary: EDITING: Auto-complete logic does not help editing
Status: RESOLVED DUPLICATE of bug 142214
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2011-12-12 03:14 UTC by fasiellon
Modified: 2021-06-07 23:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
calc example (227.08 KB, image/png)
2021-06-03 20:57 UTC, paulo g.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fasiellon 2011-12-12 03:14:35 UTC
Problem description: 
auto complete logic simply suggest the first possible item in alphabetical order.
This means that, if in the same column i have "aztec" (100 time inserted) and "albert" (only 1 time inserted), if i press "a", Calc will suggest "albert" for auto-complete instead of "aztec". Off course, if i've inserted aztec 100 times and albert only one time, there are chance that i want to insert another "aztec" item instead of "albert"...

Steps to reproduce:
1. write n time aztec in a column (n>1)
2. write 1 time albert in the same column
3. press a

Current behavior: Calc suggest albert

Expected behavior: Calc suggest aztec (the most used item)

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Comment 1 sasha.libreoffice 2012-04-28 02:10:47 UTC
Thanks for new idea
In 3.5.2 not implemented yet.

IMHO in described situation will useful even just remember last variant, selected by user for this column and propose it again next time. It will hit more often than miss.

for disable this functionality use Tools->Cell contents->Autoinput
Comment 2 Jeffery Seiffert 2012-08-24 22:15:15 UTC
LibreOffice 3.5.5.3 for windows. 

In the help it says you can use the Tab key to scroll through the auto-complete entries and Shift-Tab to go backwards through the entries. I've tried it several times but just leaves what is selected in auto-complete in the cell and moves to the next cell over.

Jeffery
Comment 3 sasha.libreoffice 2012-08-27 09:17:01 UTC
> In the help it says
May be there written about Writer
Comment 4 Buovjaga 2018-06-07 14:30:17 UTC
*** Bug 117344 has been marked as a duplicate of this bug. ***
Comment 5 Buovjaga 2018-06-07 14:33:00 UTC
*** Bug 78545 has been marked as a duplicate of this bug. ***
Comment 6 Buovjaga 2018-06-07 14:33:45 UTC
See bug 78545 for another idea
Comment 7 bear 2018-11-29 09:43:05 UTC Comment hidden (obsolete)
Comment 8 paulo g. 2021-06-03 20:57:49 UTC
Created attachment 172600 [details]
calc example
Comment 9 paulo g. 2021-06-03 20:59:48 UTC
Calc choose not the most used word, but it choose the near alphabetic letter.
Comment 10 Buovjaga 2021-06-04 06:35:27 UTC
There was a commit for bug 142214, https://git.libreoffice.org/core/commit/f8039c6d645acb015a6c4e45000bbfd1311bfea3
It changed the behaviour, so the result in the description of this report no longer occurs.

Quoting from the commit message:

show autocompletion only if there is exactly one match

Picking one from many matches by any logic requires the user to pay
attention to the auto completed match and see if it the one they wanted.
Instead show autocomplete only when there is exactly one match with what
the user has already typed.

*** This bug has been marked as a duplicate of bug 142214 ***
Comment 11 Richard Neill 2021-06-07 23:57:28 UTC
That makes some sense from the cognitive perspective, but it's not very helpful if you have a long string that is unique at the end. For example,

Barclays,Barclays,Barclays,Barclaycard,Barclays ....

I think the more intelligent approach would be to look for the matches, finding the nearest-proximity one in the same column.