Bug 43767 - Writer FORMATTING: Impossible numbering with small Roman numbers of list with capital letters
Summary: Writer FORMATTING: Impossible numbering with small Roman numbers of list with...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 60331 (view as bug list)
Depends on:
Blocks: Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2011-12-12 15:57 UTC by kaesezeh
Modified: 2021-05-19 18:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test case (9.74 KB, application/vnd.oasis.opendocument.text)
2012-02-14 00:46 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaesezeh 2011-12-12 15:57:10 UTC
When you have a numbered list in Writer that starts with a word in small caps then that small caps formatting also applies to the numbering. This means, for instance, you can't have a small Roman numbering with, say, small caps words like this,

(i)   GRAMMATICALITY
(ii)  ASPECT

which is just plain illogical and annoying.
Comment 1 sasha.libreoffice 2012-02-14 00:46:26 UTC
Created attachment 57015 [details]
test case

But my be so should be? Please, see in another offices, how there is this situation.
Meanwhile start list items with space and leave this space unformatted.
Comment 2 kaesezeh 2012-02-18 09:18:49 UTC
what kind of a stupid comment is that?? So, I leave a space and then once the bullet point text goes into the next line this destroys the hanging indent!? This is nonsense. In Word, you can double-click on the paragraph mark and format the paragraph separately from the text and don't have to leave a space there that kills the alignment of the indent, and that's how this SHOULD work.
Comment 3 sasha.libreoffice 2012-03-07 03:15:23 UTC
Sorry for stupid comment. Meanwhile try this:

To force list to be with specific format in Writer do following:
1. Place mouse cursor on any item and left click it. All items becomes in grey
squares
2. Change format of character to desired (for example:font size, bold, italic,
red color)
3. If format appears already desired, then change to wrong format and then back
to desired (we want font size 12 and it is already 12, then change to 14 and
than back to 12)

In Impress all list items are independent form each other, so to change format
of all list, select explicitly ALL list.
Comment 4 kaesezeh 2012-03-10 09:02:28 UTC
Thanks for the tip. However, it doesn't work on my machine even in your file. For instance,

1 I loaded your test case document;
2 I triple-click into the first line and press CTRL-B to make it all bold;
3 I click once onto the "i." and the grey highlighting appears;
4a What DOES work is then right-click and "Clear direct formatting";
4b What does NOT work is then changing the format to anything. For instance, when I change the color to green, nothing happens, neither to the numbering nor to the "Asdfz".

Strange ...
Comment 5 sasha.libreoffice 2012-03-12 07:23:53 UTC
Thanks for additional testing. It is because used Roman numbers. With Arabic numbers it works. But with Roman numbers not works and even if change to Arabic, it still not works.
IMHO it is a bug. When I select list with Roman numbers, change attributes and see on "undo" button, I see that attributes changed. But nothing changed.
In msWord 2003 formatting of list works as described in comment 3.
Comment 6 ign_christian 2014-06-24 03:57:26 UTC
*** Bug 60331 has been marked as a duplicate of this bug. ***
Comment 7 QA Administrators 2015-07-18 17:44:46 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-10-23 17:32:52 UTC
Still repro.

Format>>Character>>Tab: Font Effects and under Effects select. Small Capitals 

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: fcc2415ade6ae93710bbbda9f7e163045e323105
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-21_16:55:13
Locale: fi-FI (fi_FI)
Comment 9 QA Administrators 2017-03-06 16:13:32 UTC Comment hidden (obsolete, obstolete)
Comment 10 Thomas Lendo 2018-10-09 09:50:31 UTC
Still reproducible.

Version: 6.2.0.0.alpha0+ (x64)
Build ID: e46f8a9a4e3c5b0542c0813b476b449f3af8d607
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-07_23:36:50
Locale: de-AT (de_AT); Calc: CL

The bad thing with this issue is, that you even can't correct the capitalization with a character style that has a font effect 'Without' or 'Lowercase'.
Comment 11 QA Administrators 2019-10-10 02:39:53 UTC Comment hidden (obsolete, spam)
Comment 12 Justin L 2021-05-01 12:17:44 UTC
Seems to be a different rendition of bug 97005, bug 136718, bug 136536, and bug 131785
Comment 13 Justin L 2021-05-19 13:38:51 UTC
Note: footnotes have the same problem...

I think https://cgit.freedesktop.org/libreoffice/core/commit/?id=478f9ad06412c910d0264f76962a6d5e1a01aaa2 is probably a good code pointer. It added overlines as a similar exception to underlines. But it is a BIG commit, and I don't know for sure if it handled ignoring overlines on numbering right away or if that was added later...


If you add this line to txtfld.cxx
     // i18463:
     // Underline style of paragraph font should not be considered
     pNumFnt->SetUnderline( LINESTYLE_NONE );
     // Overline style of paragraph font should not be considered
     pNumFnt->SetOverline( LINESTYLE_NONE );
+    pNumFnt->SetCaseMap(SvxCaseMap::NotMapped);

then any line with an underline or overline also fixes the case mapping. But what triggers the font to be used (or repainted)???
Comment 14 Justin L 2021-05-19 18:53:23 UTC
Sometimes Writer delays loading the document, and then it doesn't convert to smallCaps. But normally you can see it load OK, then within seconds shift to smallCaps.

I tried adding SvxCaseMap::NotMapped != GetCaseMap() everywhere I saw a similar comparison to GetOverline() and GetStrikeout(), but that didn't work. I'm lost.