Bug Hunting Session
Bug 43831 - Advanced FILTER incompatible with 3.4.4 documents
Summary: Advanced FILTER incompatible with 3.4.4 documents
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium major
Assignee: Eike Rathke
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-12-14 07:39 UTC by Rainer Bielefeld Retired
Modified: 2011-12-15 12:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (57.90 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-12-14 07:39 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-12-14 07:39:56 UTC
Created attachment 54423 [details]
Sample document

[Reproducible] with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta1 - WIN7 Home Premium (64bit) English UI [Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4] Windows_Release_Configuration  11-Dec-2011 06:51" :

First a test with 3.4.4
0. open attached "sample1.ods" with 3.4.4
1. Check 'Data -> Filter -> Remove Filter': should be greyed 
   out
2. on sheet "ProjStat": Menu 'Data -> Filter -> 
   Acvanced Filter - select "r"'
   > Filter shows only rows with "R" in column "Zuständ"
3. Close document without changing

10. open "sample1.ods" with 3.5.0 Beta1
11. Check 'Data -> Filter -> Remove Filter': should be greyed 
   out
12. on sheet "ProjStat": Menu 'Data -> Filter -> 
    Acvanced Filter - select "r"'
    Expected: as in 2. many rows shown
    Actual: no row with contents shown

Using Auto Filter to open the standard filter shows a quite normal filter, but further examination shows that there is a leading space before the date number. So Standard filter only will work deleting leading blank in filter criteria.

I hoped that I would be able to fix the problem deleting the blanks in the filter criteria in sheet "Filter", but that does not work, Filter will not work. I will have to delete and to type the date representing manually before I get the Standard Filter working 


Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0.1) Gecko/20111121 Firefox/8.0.1 SeaMonkey/2.5
Comment 1 Rainer Bielefeld Retired 2011-12-14 07:55:00 UTC
Already broken in Master from November, so not a particular Beta1 bug.
Comment 2 Roman Eisele 2011-12-15 01:16:58 UTC
Confirmed: easily reproducible using the steps given by Rainer Bielefeld with
LibreOffice 3.5.0 beta 1
Build-ID: 1ce7995-7f15fca-1f1fd1a-ca8e46d-5bcbce4
[libreoffice-3-5~2011-12-13_04.48.06_LibO-Dev_3.5.0beta1_MacOS_x86_install_en-US]
German langpack installed
running on MacOS X 10.6.8 German.

-> Changing Status to 'New', as the problem is confirmed now.
-> Changing Platform from 'Window' to 'All', because the problem also occurs on MacOS X.
Comment 3 Rainer Bielefeld Retired 2011-12-15 03:52:34 UTC
@Muthu:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 4 Eike Rathke 2011-12-15 07:33:27 UTC
Grabbing this to investigate.