Bug 43866 - FILESAVE/FILEOPEN: Wrong bullet symbol in lists after .doc/.docx file export/import
Summary: FILESAVE/FILEOPEN: Wrong bullet symbol in lists after .doc/.docx file export/...
Status: RESOLVED DUPLICATE of bug 34814
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-15 12:05 UTC by OfficeUser
Modified: 2012-05-09 07:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
How the DOC file looks like when I open it again (LO 3.4.4, MacOS X) (116.00 KB, image/png)
2011-12-21 02:23 UTC, Roman Eisele
Details
How the DOC file looks like when I open it again (LO 3.5beta1, MacOS X) (72.57 KB, image/png)
2011-12-21 02:37 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2011-12-15 12:05:36 UTC
Please...

- Open Writer
- Enter the word "Test"
- Press the bullet button
- Save as "Microsoft Word 97/200/XP/2003 (.doc)"
- Close and Reopen the document.

Note: There is a nojn-standard special bullet. Opening in Word gives the same result which indicates that this is a bug of the export filter.

I can reproduce this bug with "LibreOffice 3.4.4 Portable MultilingualNormal".

But I CANNOT reproduce it with "LibO_3.4.4_Linux_x86_install-deb_en-US".

Thus I don't know if it is a general bug of the windows build or only a bug of the portable build.
Comment 1 Roman Eisele 2011-12-21 02:20:58 UTC
[Reproducible] with LibreOffice 3.4.4, German langpack installed, running on MacOS X 10.6.8 German.

Following the steps given in Description, the test document shows, after opening it again, star-shaped bullets. I will attach a screenshot showing the results.

-- Changing Status to New because bug is confirmed now.
-- Changing Platform from Windows to All because the bug is also present on MacOS X.
Comment 2 Roman Eisele 2011-12-21 02:23:39 UTC
Created attachment 54630 [details]
How the DOC file looks like when I open it again (LO 3.4.4, MacOS X)
Comment 3 Roman Eisele 2011-12-21 02:37:08 UTC
Created attachment 54631 [details]
How the DOC file looks like when I open it again (LO 3.5beta1, MacOS X)

1) The problem is also present in LibreOffice 3.5beta1 (again German langpack installed, again running on MacOS X 10.6.8) -- see the attached screenshot: instead of the star-like bullet, the DOC file now shows a placeholder glyph for the bullet. This placeholder glyph, looking like a square with round corners and something like a W in its centre, is used by MacOS X when it can’t find a matching glyph for a given Unicode character.

2) The problem is also present in Master:
LOdev 3.6.0 
Build ID: 0f44079-d46295c-6e20485-4c1bcb5-libreoffice-3-5-branch-point
2011-12-15
Build Date: 2011-12-15
Installation file name: master~2011-12-15_05.20.12_LibO-Dev_3.6.0beta0_MacOS_x86_install_en-US.dmg
with US langpack installed (I will try a newer Master build later, if necessary).
The DOC file looks like in 3.5 beta 1: the same placeholder glyph instead of the bullet.
Comment 4 Roman Eisele 2011-12-21 02:54:45 UTC
Additional hint:
the problem is not visible when I save the test document as RTF file -- in this case, the bullet is fine after opening the file again, both with LibreOffice 3.4.4 and 3.5 beta 1.
Comment 5 hannsp 2012-02-15 01:19:32 UTC
I have seen the problem with wrong glyphs in bulleted lists for a very long time (possibly since OpenOffice 1) on MacOS X (10.4 to 10.6) with the German Language Pack.

I think it is also a problem concerning the .doc/.docx _import_ filters because it happens when you open Word documents from a Windows platform in OOo/LO on a Mac.

The type of wrong glyph differs. Beside the star shaped glyph and the placeholder glypgh mentioned by Roman, I have often seen a square with an X in it. Possibly depends on the .doc/.docx version.
Comment 6 Roman Eisele 2012-05-07 00:47:57 UTC
Still reproducible with LibreOffice 3.5.3.2.

Updated Summary according to comment #5 and own experience:
-- not a regression
-- FILESAVE and/or FILEOPEN is affected
-- not only .doc, also .docx affected.
Comment 7 Roman Eisele 2012-05-09 07:16:13 UTC
This is the same issue as bug 34814, which should be fixed now. The fix should be available in the upcoming versions LibreOffice 3.5.4 and 3.6.0.

*** This bug has been marked as a duplicate of bug 34814 ***