Download it now!
Bug 43874 - Writer showing tables as text.
Summary: Writer showing tables as text.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta0
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: (target:4.0.2)
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-12-15 21:13 UTC by Jaise James
Modified: 2013-04-04 05:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
scrennshots (252.87 KB, image/jpeg)
2011-12-15 21:13 UTC, Jaise James
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaise James 2011-12-15 21:13:47 UTC
Created attachment 54481 [details]
scrennshots

Writer shows the file with tables display as normal text paragraph. This happens for doc received. The screenshot are attached[libreoffice 3.5 beta]. The document open correctly in libreoffice 3.4.3.
Comment 1 Rainer Bielefeld Retired 2011-12-15 22:30:21 UTC
Has to be checked with 3.5.0 Beta2

@Mike Van Wormer II:
Please do not submit Bug reports concerning 3.5 Beta0. Some bad luck, that
version "3.5 Beta0" was terrible buggy. I believe it's not useful to do tests
with tat version, please wait for Beta1 (just uploading to mirrors) ad do your
tests with that version (or with Master from
<http://dev-builds.libreoffice.org/>, of course).

Tests with Beta0 are wasted time. 

Thank you for your attention, please excuse that we did not remove download
information timely

Please attach a sample document!
Comment 2 Jaise James 2011-12-18 21:43:02 UTC
(In reply to comment #1)
> Has to be checked with 3.5.0 Beta2
> 
> @Mike Van Wormer II:
> Please do not submit Bug reports concerning 3.5 Beta0. Some bad luck, that
> version "3.5 Beta0" was terrible buggy. I believe it's not useful to do tests
> with tat version, please wait for Beta1 (just uploading to mirrors) ad do your
> tests with that version (or with Master from
> <http://dev-builds.libreoffice.org/>, of course).
> 
> Tests with Beta0 are wasted time. 
> 
> Thank you for your attention, please excuse that we did not remove download
> information timely
> 
> Please attach a sample document!

The problem is exist for 3.5.0beta1. Document is produced by word[ mailed by outside person]& document Tested  in Abiword, it is showing correctly as table. If I save it from libreoffice as odt using libo3.4.3, no problem afterwards.
Comment 3 Rainer Bielefeld Retired 2011-12-18 23:18:35 UTC
@Jaise James
Please attach a sample document! If it's confidential please send it to me by mail, I will try to create a new sample that can be published.
Please do not cite!
Comment 4 Rainer Bielefeld Retired 2011-12-26 08:56:35 UTC
No response, so closed!

@reporter:
Please feel free to reopen you can contribute requested additional information due to <http://wiki.documentfoundation.org/BugReport> (also see BugReport Details)!
Comment 5 Rainer Bielefeld Retired 2012-01-08 01:10:51 UTC
My mistake, I got the confidential document by PM. The effect is reproducible, but reporter and I only see the effect only with the original document. Every little modification, even only save the document will heal the problem. So the problem seems to be document related.
Comment 6 Matthew Francis 2012-02-14 18:45:33 UTC
I receive documents with this issue on a weekly basis.

The documents are created (or rather reassembled from a source .doc and translated text) using Wordfast (http://www.wordfast.net/).

Whether it achieves this using Word in some fashion, or natively, I'm not sure, but the files it creates for one particular frequently recurring kind of source file - probably all created from the same template - all have this problem.

Unfortunately, due to the files' confidentiality I cannot disclose them, nor provide additional screenshots, but the problem appears to be identical to the attached screenshot. The containing table originally present in the files is missing when loaded, and all its content (text and embedded images) is rendered jammed together.

Word, and OSX's file preview, manage to reliably render the tables, so whether or not there is some problem with the files I would suggest that from a compatibility viewpoint there is a general issue involved.

This issue has persisted across a number of different LO versions (and in OOo before that) up to and including 3.5.0 final
Comment 8 Jaise James 2012-02-14 20:57:58 UTC
(In reply to comment #6)
> I receive documents with this issue on a weekly basis.
> 
> The documents are created (or rather reassembled from a source .doc and translated text) using Wordfast (http://www.wordfast.net/).
> 
> Whether it achieves this using Word in some fashion, or natively, I'm not sure, but the files it creates for one particular frequently recurring kind of source
> file - probably all created from the same template - all have this problem.
> 
> Unfortunately, due to the files' confidentiality I cannot disclose them, nor provide additional screenshots, but the problem appears to be identical to the
> attached screenshot. The containing table originally present in the files is missing when loaded, and all its content (text and embedded images) is rendered
> jammed together.
> 
> Word, and OSX's file preview, manage to reliably render the tables, so whether or not there is some problem with the files I would suggest that from a
> compatibility viewpoint there is a general issue involved.
> 
> This issue has persisted across a number of different LO versions (and in OOo before that) up to and including 3.5.0 final

Please check this build given below. My problem is rectified below given 3.5.1 build.

http://dev-builds.libreoffice.org/daily/Win-x86@6-fast/libreoffice-3-5/2012-02-13_10.18.55/libreoffice-3-5~2012-02-13_10.18.55_LibO-Dev_3.5.1rc0_Win_x86_install_en-US.msi.
Comment 9 Matthew Francis 2012-02-14 21:08:30 UTC
(In reply to comment #8)

> Please check this build given below. My problem is rectified below given 3.5.1 build.
> 
> http://dev-builds.libreoffice.org/daily/Win-x86@6-fast/libreoffice-3-5/2012-02-13_10.18.55/libreoffice-3-5~2012-02-13_10.18.55_LibO-Dev_3.5.1rc0_Win_x86_install_en-US.msi.

There doesn't appear to be a daily build there for OSX, or one that's equally up to date for Linux. I'll have to wait for one of those to turn up, or the next beta

Thanks
Comment 10 Matthew Francis 2012-03-15 20:47:45 UTC
Problem still occurs in 3.5.1 final

I still can't publicly release the problematic files. Please get in touch if I can assist further in debugging this.
Comment 11 Matthew Francis 2012-04-27 20:24:15 UTC
Problem still occurs in 3.5.2.2
Comment 12 Miklos Vajna 2013-04-03 15:45:04 UTC
Rainer, Matthew: any details about the document? What format it is, ODF, DOC, DOCX, RTF, something else?
Comment 13 Rainer Bielefeld Retired 2013-04-03 15:50:12 UTC
@Jaise James
Please send a document to developer Miklos Vajna so that he can do his own tests
Comment 14 Matthew Francis 2013-04-03 17:57:40 UTC
I dug up a set of files that still exhibit this behaviour in 4.0.0.3, so the bug is still present. Unfortunately I can't provide the files as is, but I will see if I can find a copy of MS office to sanitise them with within the next few days (although who knows if the bug will still present itself after they've been edited)

The files are all .doc
Comment 15 Jaise James 2013-04-04 04:20:12 UTC
Now for me, Docu file opening perfectly & is showing each tables perfectly. Libreoffice used 4.0.2 in Ubuntu 13.04.

Thanks for fixing bug.
Comment 16 Rainer Bielefeld Retired 2013-04-04 05:10:43 UTC
So closing due to comment above as WFM for now.