Download it now!
Bug 43919 - "[" breaks vlookup
Summary: "[" breaks vlookup
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-17 23:44 UTC by Dereck Wonnacott
Modified: 2015-01-19 12:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Simple Problematic file (9.25 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-12-17 23:44 UTC, Dereck Wonnacott
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dereck Wonnacott 2011-12-17 23:44:13 UTC
Created attachment 54532 [details]
Simple Problematic file

If I have a "[" in my criteria in a vlookup funtion, it fails to find the item in the list.... "]" works fine tho, and M$ Excel works as expected.

Total blocker for my project.... :(
Comment 1 GerardF 2011-12-18 00:54:42 UTC
Hi,

[ is a special character.
If you want to use VLOOKUP with cells containing special characters :

1. If you don't need to use them in other formulae in the same file :
Turn of "enable regular expressions in formulas" in the menu Tools > Options > LO Calc > Calculate.

2. If you used them in other cells :
Place the escape character \ (backslash) before with the SUBSTITUTE function.
=VLOOKUP(SUBSTITUTE(C6;"[";"\[");C4:D9;2;0)

The special characters are . ^ $ * + ? \ [ ( { | 

Regular expressions in Calc functions : http://wiki.services.openoffice.org/wiki/Documentation/How_Tos/Regular_Expressions_in_Calc#Regular_expressions_in_Calc_functions

Closed "Not a bug"