Download it now!
Bug 43937 - UI: Conditional formatting dialog scroll slider function partial broken
Summary: UI: Conditional formatting dialog scroll slider function partial broken
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:3.6.0.0.beta2 3.7.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-18 12:59 UTC by OfficeUser
Modified: 2012-08-03 09:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot (33.25 KB, image/png)
2011-12-18 12:59 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2011-12-18 12:59:32 UTC
Created attachment 54549 [details]
screen shot

See screen shot.
Comment 1 Markus Mohrhard 2011-12-18 17:02:21 UTC
And where is the bug?
Comment 2 Rainer Bielefeld Retired 2011-12-18 23:01:36 UTC
[Reproducible] with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta1 - WIN7 Home Premium (64bit) German UI [Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4] Windows_Release_Configuration  11-Dec-2011 06:51" 

Scroll bar behavior is not plausible:

Steps to reproduce:
1. Open new Calc document
2. Select / Highlight A1:A10
3. Menu 'Format -> Contitional Formatting'
   > Shows scroll bar and scroll slider for conditions
   Expected: Scroll slider can be used for something useful
   Actual: slider does nothing before Condition 4 has been checked
4. close dialog, document, 

10. open new Calc document
11. Type 1 .... 10 To A1 ... A10
12. Select / Highlight A1:A10
13. Menu 'Format -> Contitional Formatting'
14. for Contition 1 ... 5
    each condition "Cell value equal 1" to "Cell value equal 5"
     with different selected formattings
15. Expected: after condition 3 you can use slider to scroll to condition 4
    Actual: Scroll only possible with scroll button down in scroll bar 
            (scroll slider up works as expected)
            When last condition unchecked scroll slider flashes black 
            after scroll, no Idea whether intended or not
            Scroll slider fills more or less complete scroll bar
16. Close dialog with <ok>
17. reopen dialog
    > now slider has expected size and works in both directions
 
@Markus:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 3 Rainer Bielefeld Retired 2011-12-18 23:04:25 UTC
Not a new Beta1 problem, already broken in Master in July
Comment 4 Markus Mohrhard 2012-02-04 05:09:11 UTC
I looked into it and the problem is that the code is really ugly.

ATM we are using the position of objects to get the conditional entries. It is a wonder that it did not yet crash but to fix the slider problem I have to rework that and separate view and model.
Comment 5 Markus Mohrhard 2012-02-06 13:57:16 UTC
I'm sorry but after looking at the code this bug will only be fixed for 3.6. The code needs some major rework to get in a shape where I can fix this bug report.

I will also ask ux-advise if they want to see any changes in this dialog.
Comment 6 OfficeUser 2012-02-08 13:18:16 UTC
@Markus: Thank you very much for your work on LibreOffice and this bug!
Comment 7 Markus Mohrhard 2012-06-13 20:28:25 UTC
New dialog is in master and will be merged into the 3-6 branch.
Comment 8 Rainer Bielefeld Retired 2012-08-03 09:13:07 UTC
We need exact and correct target information for automated lists in Wiki and LibO Web Site.