Download it now!
Bug 43938 - UI: Default area color without name in Impress/Draw
Summary: UI: Default area color without name in Impress/Draw
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: difficultyBeginner, easyHack, regression, topicUI
: 67357 74950 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-18 13:02 UTC by OfficeUser
Modified: 2015-12-16 05:24 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot (30.46 KB, image/png)
2011-12-18 13:02 UTC, OfficeUser
Details
Print screen from 4.1.0 (70.11 KB, image/png)
2012-12-17 11:22 UTC, Radu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2011-12-18 13:02:37 UTC
Created attachment 54550 [details]
screen shot

See screen shot: "[]"
Comment 1 Rainer Bielefeld Retired 2011-12-18 22:14:51 UTC
[Reproducible] with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta1 - WIN7 Home Premium (64bit) German UI [Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4] Windows_Release_Configuration  11-Dec-2011 06:51" and some Master versions before.

Oldest Version showing that problem was Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 485138f-e92bf75-4c1bcb5]" Win-x86@6 – 2011-12-06_21:37:02), where the default color is no longer "Blue 9"

Was ok with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [(Build ID:  d38713d-5d03837-ca7e6f5-c4bb9bd-ce71330)]" (Voreppe_Win32_Tinderbox 111115), where default color was "blue 9", also ok with Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID:  a286353-090bcba-3bf3b94]" Win-x86@6 – 2011-12-02_22:36:35)
Comment 2 OfficeUser 2012-01-21 00:11:10 UTC
Cannot reproduce any more with:
LibreOffice 3.5.0rc1 
Build-ID: b6c8ba5-8c0b455-0b5e650-d7f0dd3-b100c87

-> resolved fixed
Comment 3 Rainer Bielefeld Retired 2012-01-21 01:40:17 UTC
Still [Reproducible] with "LibreOffice 3.5.0 RC1 German UI/Locale [Build-ID: b6c8ba5-8c0b455-0b5e650-d7f0dd3-b100c87] on German WIN7 Home Premium (64bit), so REOPENED. 

@OfficeUser
Please use FIXED only for known fixes, the one would have been WORKSFORME.
What's your Operating System?
Comment 4 OfficeUser 2012-01-21 02:02:10 UTC
Linux
Comment 5 Rainer Bielefeld Retired 2012-01-22 21:23:10 UTC
I tested with "Rectangle" and "Isosceles Triangle" in Presentation and still saw the problem (Comment 3) 

Not only Presentation is affected

@OfficeUser:
Please
- add information
  -- how exactly your tested
  -- concerning your Linux (Version, Distribution, Language)
Comment 6 OfficeUser 2012-01-23 12:33:17 UTC
Ubuntu 11.10 64bit german

I open Draw and draw some objects. I cannot see the problem anymore. I don't remember that I did so "special" things as I reported this bug with an older build.

For me it looks fixed. Have you tried using a fresh profile?
Comment 7 Gerry 2012-06-26 13:12:13 UTC
Isn't this really easy to fix?

I can reproduce this trivial bug in Ubuntu 11.10 with LibreOffice 3.5.4.2 
Build ID: 350m1(Build:2) from the PPA.

I open Writer. I draw a rectangle. The light blue colour has in fact no name, just [], like in the screen shot.
Comment 8 Caolán McNamara 2012-10-30 12:13:28 UTC
*** Bug 56430 has been marked as a duplicate of this bug. ***
Comment 9 Radu 2012-12-17 01:39:22 UTC
Some code hints? I determined color under [] is Tango Sky Blue 1 (#729fcf)
Comment 10 Rainer Bielefeld Retired 2012-12-17 05:37:21 UTC
No  longer reproducible with "LibreOffice 3.6.4.3" German UI/ German Locale [Build-ID: 2ef5aff] {pull date 2012-11-28} on German WIN7 Home Premium (64bit)?
I see "Blau 9"
Comment 11 Radu 2012-12-17 11:22:28 UTC
Created attachment 71645 [details]
Print screen from 4.1.0

Problem still exists.
Comment 12 Jorendc 2013-03-20 16:04:00 UTC
I also can not reproduce this, with Linux Mint 14 x64 and LibreOffice Version 4.1.0.0.alpha0+ (Build ID: b4966ea69ff0ad6944bd16d8a09ecb27a1704c1). Also same behavior using LibreOffice Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c).

The default entry is "Tango: Sky Blue 1" over here.

Kind regards,
Joren
Comment 13 Radu 2013-04-02 20:15:17 UTC
Problem still exists.
I'm using Kubuntu with the latest patches.
Comment 14 Prashant 2013-04-03 17:15:11 UTC
Hi, 

I can very well reproduce it on my 64-bit Ubuntu 12.10 machine. Can I get some pointers for the same?

Thanks and Regards,
Prashant
Comment 15 Jorendc 2013-07-26 19:00:26 UTC
*** Bug 67357 has been marked as a duplicate of this bug. ***
Comment 16 crxssi 2013-07-26 19:16:48 UTC
The problem is far worse than just the area color, it is also the line color AND the line color is inappropriate....

Starting in LO 4 (I think) something was changed in Draw such that the default fill color for objects is now an undefined shade of dark blue and the default line color is an undefined shade of lighter blue for newly create objects.  The fill color is listed as "[]" and the line color is just blank.

Regardless of their being invalid/undefined colors, any line color that is not black is completely inappropriate as a default!!!

Our only workaround for this was to create a default template for all new Draw documents that correctly sets the default fill color to "Blue 8" and line color as "Black" as defined in all versions of OpenOffice and presumably older versions of LibreOffice.
Comment 17 crxssi 2013-10-07 14:29:49 UTC
Still broken in LO 4.1.2.3 as tested under RHEL 6 and plain vanilla 64bit LO.

It is marked as a regression but I would like to know which parts of the bug are planned to be fixed- there are two.  One is that the line color is unnamed/invalid.  But the other part is that it is blue instead of black.  I would hate to see someone fix it so that the color selected is a named color, but remains blue.

In all old versions of OO and LO, the default Draw line color is black, and I think it should remain that way.  Why would someone want to draw lines in blue?  It seems like an unreasonable default.
Comment 18 Andras Timar 2013-11-26 20:58:23 UTC
(In reply to comment #9)
> Some code hints? I determined color under [] is Tango Sky Blue 1 (#729fcf)

Did you try 'git grep 729fcf'? There are many matches, but one looks extremely suspicious:

include/svx/xdef.hxx

#define COL_DEFAULT_SHAPE_FILLING 0x729fcf
#define COL_DEFAULT_SHAPE_STROKE  0x3465a4

I bet this is what you need to change (to a color that is part of the standard palette -- extras/source/palettes/standard.soc).
Comment 19 Jorendc 2014-02-13 21:07:13 UTC
*** Bug 74950 has been marked as a duplicate of this bug. ***
Comment 20 Joshua O'Leary 2014-02-23 17:10:00 UTC
Shouldn't the default option be set to just no fill / invisible?
Comment 21 crxssi 2014-02-23 18:45:27 UTC
(In reply to comment #20)
> Shouldn't the default option be set to just no fill / invisible?

For the default fill?  That is a design preference.  Personally, I agree with you that objects should be unfilled (and always with a black [out]line).

If they do choose to fill it by default, it should at least be with a reasonable AND defined color.  Blue seems reasonable... but an undefined one is just wrong...  it would be like making the default font in Writer be something undefined and unavailable.

It is incredible this is still "broken"!  Isn't it a trivial code/template change to fix the color to something defined for fill and change the line color to black?
Comment 22 Jan Holesovsky 2014-03-19 10:20:32 UTC
Looks like this is resolved by:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8c59320fe391ac98ad344623f803583c26a9b93c
Comment 23 crxssi 2014-03-19 11:45:44 UTC
(In reply to comment #22)
> Looks like this is resolved by:
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=8c59320fe391ac98ad344623f803583c26a9b93c

If the code does not reassign the outline color back to black, I still consider the bug half unfixed.  Do you think that should be yet another bug report?  I fail to understand why anyone would want a default outline color to be anything other than black.....  which is what it has ALWAYS been in OpenOffice until it was changed in LO for no apparent reason.
Comment 24 Robinson Tryon (qubit) 2015-12-16 05:24:42 UTC
Migrating Whiteboard tags to Keywords: (EasyHack  DifficultyBeginner  TopicUI )
[NinjaEdit]