Bug Hunting Session
Bug 44011 - SLIDESHOW with linked video CRASHes
Summary: SLIDESHOW with linked video CRASHes
Status: RESOLVED DUPLICATE of bug 45081
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-21 05:24 UTC by Eliot the Cougar
Modified: 2012-03-18 08:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eliot the Cougar 2011-12-21 05:24:32 UTC
To reproduce:
1. Create new presentation
2. Insert - Movie and Sound...
3. Make sure you checked "Link" option
4. Select any video encoded with any codec or even some uncompressed video
5. (optional) Save presentation
6. Start Presentation (F5)
CRASH!

Video plays fine in the built-in "Active Movie Window" if you click "Play" on the "Movie and Sound" panel...

If you insert the video with "Link" option unchecked, the program does NOT crash, but the video itself does not play or make sound in presentation mode... However it DOES play in the "Active Movie Window"...

Video plays fine in the LibreOffice 3.4.4 in presentations made with LODev 3.5 with "Link" option enabled... If you disable the "Link" option, video does not play in LibreOffice 3.4.4 either...

Codec does not matter, I tried x264, DivX, XviD and Uncompressed video with the same results...
Comment 1 Christian Lohmaier 2011-12-28 08:57:50 UTC
not reproducible on linux, no problem with linked videos in 3.5.0beta2 or 3.4.4 (but 3.4.4 doesn't offer to link the video, so not really relevant here)
Comment 2 Juan Jose Pablos 2011-12-28 09:52:07 UTC
ok,
I have download the quicktime trailer from http://www.bigbuckbunny.org/index.php/trailer-page/
and follow the steps (except saving presentation) and I can confirm that it crash as well. 
using  3.5.0beta2 windows xp SP3 32Bit.
Comment 3 Florian Seiler 2012-02-20 09:39:56 UTC
Hi,
same problem here with *.avi and *.flv files. I use LibO 3.5 final on Windows 7 64bit. I can play the files with the embedded media player, but as soon as I start the presentation LibO crashes.
Comment 4 David Hersh 2012-03-17 20:25:41 UTC
I've had this problem with every supported file type I've tried. The error hasn't been fixed in 3.5.1. Whether it's audio or video, it crashes the second the slideshow is started.  

I've tried it with the "Link" option checked and unchecked, different types of media files, and different presentation file formats, but the bug is the same every time. It still plays fine using the "Movie and Sound" panel.

I have not tried it on Linux, only in Windows, but I've tried it on Windows 32 and 64 bit machines.
Comment 5 Rainer Bielefeld Retired 2012-03-18 08:06:35 UTC
I can not reproduce the problem's exact wording, for me a self created presentation runs without problem until it reaches the slide with the movie.

We have several similar crash reports, I will mark all as DUP of ""Bug 45081 - SLIDESHOW CRASH at slide with embedded / linked video" where we have most information an a strace log

@all:
of course you report such bugs for Project "HarfBuzz" and mention Libreoffice in the Subject line, but it's hard to find ismilar bugs if everybody proceeds that way. Please read <https://wiki.documentfoundation.org/BugReport> :-/
Careful bug reporting will speed up the process better than multi nomination in Bug 37361

*** This bug has been marked as a duplicate of bug 45081 ***