Bug Hunting Session
Bug 44065 - FILEOPEN: Thunderbird assistant leads to wrong address birthday (year-day) fields
Summary: FILEOPEN: Thunderbird assistant leads to wrong address birthday (year-day) fi...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 44064 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-22 08:33 UTC by Geldhauser
Modified: 2012-01-07 09:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geldhauser 2011-12-22 08:33:28 UTC
Problem description: 

Steps to reproduce:
1. enter a birth date in thunderbird adress book
2. use assistant to use this addressbook
3. look for birthday year (month appears here), birthday month (day appears here) and birthday day (nothing appears here)

Current behavior:
birthday year (month appears here), birthday month (day appears here) and birthday day (nothing appears here)

Expected behavior:
birthday year shows year, month shows month and and day shows day (like in e.g. OpenOffice 2.4.2)

Platform (if different from the browser): 
Win XP
Comment 1 Julien Nabet 2012-01-07 01:57:14 UTC
I reproduced this bug on Debian x86-64 with 3.4.4, 3.5 branch and master branch (future 3.6)
birthday year : day appears here -> KO
birthday month : month appears -> OK
birthday day : nothing -> KO

In console, I've got these traces (I added a temporary OSL_FAIL to know what was the problematic alias) : 
warn:legacy.osl:7901:10:/home/julien/compile-libreoffice/libo/connectivity/source/drivers/mozab/MColumnAlias.cxx:175: OColumnAlias::getProgrammaticNameOrFallbackToUTF8Alias: no programmatic name for this alias!
warn:legacy.osl:7901:10:/home/julien/compile-libreoffice/libo/connectivity/source/drivers/mozab/MColumnAlias.cxx:176: card:nsIAbCard
Comment 2 Julien Nabet 2012-01-07 09:11:24 UTC
*** Bug 44064 has been marked as a duplicate of this bug. ***
Comment 3 Julien Nabet 2012-01-07 09:14:03 UTC
Resolved in master.
Asked on dev mailing list if the fix could be cherry picked for 3.5 branch (3.4 too ?)
Here is the bugfix commit : http://cgit.freedesktop.org/libreoffice/core/commit/?id=948f57e74dda7e64b7c72208eaec00eac1bb96ba
Comment 4 Julien Nabet 2012-01-07 09:32:31 UTC
link to dev mailing list post for cherry pick :
http://nabble.documentfoundation.org/REVIEW-Cherry-pick-in-3-5-3-4-for-fdo-44065-td3640531.html