Download it now!
Bug 44093 - Forms open in printer view. They should open in web-view.
Summary: Forms open in printer view. They should open in web-view.
Status: RESOLVED DUPLICATE of bug 37024
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.0 Beta0
Hardware: x86 (IA32) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 44401 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-12-23 04:15 UTC by Boudi
Modified: 2012-01-04 08:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Forms view as from 3.4. (66.95 KB, image/png)
2011-12-23 04:15 UTC, Boudi
Details
Same file in 3.3.4 (91.22 KB, image/png)
2011-12-23 04:16 UTC, Boudi
Details
test 33/35 db (10.67 KB, application/vnd.sun.xml.base)
2011-12-27 07:37 UTC, Boudi
Details
form only file (8.17 KB, application/vnd.oasis.opendocument.text)
2011-12-27 07:38 UTC, Boudi
Details
33 made saved in webview incl. form object (9.48 KB, application/vnd.oasis.opendocument.text)
2012-01-03 23:38 UTC, Boudi
Details
33 made saved in webview excl. form object (8.78 KB, application/vnd.oasis.opendocument.text)
2012-01-03 23:40 UTC, Boudi
Details
White margin arround forms - whole database created in LO 3.5.0 Beta2 (73.77 KB, image/png)
2012-01-04 07:14 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Boudi 2011-12-23 04:15:04 UTC
Created attachment 54745 [details]
Forms view as from 3.4.

In Base Forms should always open in Web View.
Comment 1 Boudi 2011-12-23 04:16:55 UTC
Created attachment 54746 [details]
Same file in 3.3.4
Comment 2 Julien Nabet 2011-12-26 14:58:17 UTC
I tried to reproduced it on 3.5 branch and master branch (future branch).
Except if I missed something, it worked for both of them.
It was on a PC Debian testing x64.
Could you please try to reproduce it with 3.5.0 beta 2 ?
Comment 3 Boudi 2011-12-27 00:24:56 UTC
I re-tested with a 3.5 made form and all works fine.
I will re-test with 3.3 made forms and report back.
Thanks.
Comment 4 Boudi 2011-12-27 06:59:52 UTC
Test Win 7(32) LO3.5

Forms odb made in 3.3 and OO 3.3 open in Lo 3.5 in print mode.
Also if saved as text (odt) outside .odb forms made in OO 3.3 and LO 3.3 open in print mode.

What parameter in the setting.xml is controlling this? If it is.

Than I can compare files and report where possible difference in interpretation of settings take place.

Kind regards,
Boudi.
Comment 5 Julien Nabet 2011-12-27 07:27:06 UTC
Have you tried these 2 things :?
- to create another brand new form just to see if it's the same behaviour
- to edit the form which has the pb and change view of it

Also could you attached the database file ?
Comment 6 Boudi 2011-12-27 07:34:39 UTC
Yes I did create a brand new odb and odt(form) as wel in 3.3 and 3.5.

3.5 to 3.3 works fine, 3.3 to 3.5 gives a print view.

I also tried to fors to open the file with sweb.exe. Than even it opens in print-view!

Attachments follow.
Comment 7 Boudi 2011-12-27 07:37:40 UTC
Created attachment 54856 [details]
test 33/35 db
Comment 8 Boudi 2011-12-27 07:38:29 UTC
Created attachment 54857 [details]
form only file
Comment 9 Julien Nabet 2012-01-03 12:17:06 UTC
*** Bug 44401 has been marked as a duplicate of this bug. ***
Comment 10 Robert Großkopf 2012-01-03 12:38:56 UTC
Its the same problem with OpenSuSE 11.4 32bit and OpenSuSE 12.1 64bit and LibreOffice 3.5.0 Beta2.
I had created a database unter 3.3.4. Created also a form. Then opend it with a netbook and OpenSuSE 12.1 64bit / LO 3.5.0 Beta2. Forms werde shown in printview. Edited the form with 3.5.0 Beta2, saved it. Form is shown in webview. Opend it next day at work with my netbook and LO 3.5.0 Beta2 - again it shows the form in printview.
So I could not change a form created in 3.3.4 to a form with webview for a longer time.
Comment 11 Robert Großkopf 2012-01-03 12:47:15 UTC
Had just tested it only with LO 3.5 Beta2. Ist the same behaviour. There was no form in the database. I created the first form. It's been created in webview. Saw this when I tried to put data into the form. Closed the database and LO 3.5.0 Beta2. Opend LO 3.5.0 Beta2 again. Opened database and the form - form is shon in printview.
It isn't a bug between 3.3.4 an 3.4 or 3.5. It's a bug of 3.4 and 3.5.
Comment 12 Julien Nabet 2012-01-03 13:34:27 UTC
I did almost the same test as you with 3.5 branch (so not exactly 3.5 beta2).
- created a new database (this point is different)
- created a new table
- created a form
it opened in webview by default
- closed form and database
- opened database then form
it opened in webview too.

I'm on Debian testing x86-64.

robert: Could you test again with a database created with 3.5 beta2 to see if form open in print view too ?
Comment 13 Boudi 2012-01-03 23:32:41 UTC
the form file in odb is in fact an embedded odt file. So I tested the odt file outside the odb.
These are my findings (with two attached examples)
All on Win7/32. (rebuilding my Linux 2.6/32 env.)

Web view documents created in older versions that behave correctly in LO33/OO33, do not behave correctly in LO35.

What did I do. I created two files. (odt) one with and one without a form object in it. Both files are saved in webview.

When opened in LO33/OO33 they both open in webview.
But when opened in LO34 or LO35, the file without form object opens in webview, but the file with a form object opens in printview!! I believe the first versions of OO33 had the same problem.

Somehow the form object in the file seems to cause the prinview=0 setting to be skipped.
Comment 14 Boudi 2012-01-03 23:38:40 UTC
Created attachment 55102 [details]
33 made saved in webview incl. form object
Comment 15 Boudi 2012-01-03 23:40:32 UTC
Created attachment 55103 [details]
33 made saved in webview excl. form object
Comment 16 Robert Großkopf 2012-01-04 07:12:39 UTC
I tried it with a new database, only opened and closed in LO 3.5.0 Beta2. The form opens in webview. It shows no background-colors. With the formwizzard changing of color is impossible. When changing the color without the formwizzard I see a white margin (about 1cm) at the left and at the top. The whole formelements moved the same way to the right and to the bottom.
When opening and closing in LO 3.3.4 and creating a form with the wizzard the colors werde shown.
When opening the form of LO 3.5 Beta2 the form is corrctly shown - wizhout the big white margins.
For users of LO 3.5.0 Beta2 it seems to be no problem. Could be that they do not notice the greater margin, because the whole form is only white?
Comment 17 Robert Großkopf 2012-01-04 07:14:21 UTC
Created attachment 55112 [details]
White margin arround forms - whole database created in LO 3.5.0 Beta2
Comment 18 Petr Mladek 2012-01-04 08:12:11 UTC
I agree that it is pretty annoying, so I added this to the most annoying bugs. On the other hand, there exists workaround, it took long time to report it => it can't block the release => lovering the severity a bit.
Comment 19 Alex Thurgood 2012-01-04 08:50:04 UTC
Hi Petr,

(In reply to comment #18)
> I agree that it is pretty annoying, so I added this to the most annoying bugs.
> On the other hand, there exists workaround, it took long time to report it =>
> it can't block the release => lovering the severity a bit.


Sorry, but it hasn't just been discovered, at least, by my reckoning, this is the same problem as :

https://bugs.freedesktop.org/show_bug.cgi?id=37024

which was raised in May 2011. And it should block the release because it was already slated as a "3.4 most annoying bug".

I would be inclined to set this report as a duplicate of 37024.


Alex
Comment 20 Alex Thurgood 2012-01-04 08:52:07 UTC

*** This bug has been marked as a duplicate of bug 37024 ***