Download it now!
Bug 44110 - New Math symbols poorly rendered in Windows
Summary: New Math symbols poorly rendered in Windows
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.5.0 Beta3
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-12-23 17:44 UTC by Olivier Hallot
Modified: 2012-01-24 02:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
image of the flaw (113.57 KB, image/png)
2011-12-23 17:44 UTC, Olivier Hallot
Details
image of the issued fixed by the patch (123.14 KB, image/png)
2011-12-23 17:49 UTC, Olivier Hallot
Details
patch to fix fdo 44110 - opensymbol.ttf (1.47 MB, patch)
2011-12-23 18:09 UTC, Olivier Hallot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2011-12-23 17:44:58 UTC
Created attachment 54767 [details]
image of the flaw

The new math symbols introduced in 3.5 sare poorly redered in Windows. See image attached, the symbols precsim and succsim are truncated in the lower part.
Comment 1 Olivier Hallot 2011-12-23 17:47:55 UTC
The issue is in the drawing of the nw symbols inside the OpenSymbol truetype font. Just lift the symbols a bit and adjust it with precurlyeq and succurlyeq.
Comment 2 Olivier Hallot 2011-12-23 17:49:33 UTC
Created attachment 54769 [details]
image of the issued fixed by the patch
Comment 3 Olivier Hallot 2011-12-23 18:09:36 UTC
Created attachment 54771 [details]
patch to fix fdo 44110 - opensymbol.ttf

This patch should be cherry-picked to branch 3.5
Comment 4 Korrawit Pruegsanusak 2012-01-11 03:52:23 UTC
Olivier, I see that you have commit a new fix for this bug, at
http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e7d38fe5b8115fe4860fe3e8a77d298cf67391b

So, shall we mark this bug as fixed?
Comment 5 Olivier Hallot 2012-01-11 06:12:33 UTC
I need it to get cherry picked in 3.5.
Comment 6 Michael Meeks 2012-01-24 02:44:45 UTC
reviewed & cherry-picked to libreoffice-3-5 - thanks Olivier ! :-)