Bug 44115 - Sound effects / music don't work when added to custom animation
Summary: Sound effects / music don't work when added to custom animation
Status: RESOLVED DUPLICATE of bug 40780
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-24 01:50 UTC by Joshua O'Leary
Modified: 2012-05-05 07:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Attachment demonstrates the problem (13.63 KB, application/vnd.oasis.opendocument.presentation)
2011-12-24 01:50 UTC, Joshua O'Leary
Details
Works Fine in this sample (11.77 KB, application/vnd.oasis.opendocument.presentation)
2012-01-06 08:25 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua O'Leary 2011-12-24 01:50:01 UTC
Created attachment 54783 [details]
Attachment demonstrates the problem

As in previous release, sound effects / music added in custom animation still don't work in the latest version of LibreOffice. Errors such as 'Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so' are shown in terminal, even though the gstreamer ffmpeg package is installed.
Comment 1 Rainer Bielefeld Retired 2012-01-06 08:25:48 UTC
Created attachment 55216 [details]
Works Fine in this sample

Joshua O'Leary:
I can reproduce the problem with your sample and all my LibO / OOo versions, but it's not reproducible with a presentation I created "from the scratch" with l Dev-Installation of  "LibreOffice 3.5.0 Beta2- WIN7 Home Premium (64bit) German UI [Build-ID : 8589e48-760cc4d-f39cf3d-1b2857e-60db978] or  "LibreOffice 3.4.5 RC1  - WIN7 Home Premium (64bit) German UI [Build ID: OOO340m1 (Build:501)]".
Linux only?

What's your result with my sample?
Comment 2 Rainer Bielefeld Retired 2012-01-06 08:30:32 UTC
DUP of or related to "Bug 40780 - Sound fails to play on custom animation"?
Comment 3 Joshua O'Leary 2012-01-08 04:29:06 UTC
I have re-tested both mine and your test-cases under libreoffice dev 3.5.0beta2, and both test cases fail to play custom animation sound. However, sounds and videos imported using Insert>Movie and Sound work perfectly and the sound is played back as it should. It appears that custom animation sound is not properly implemented under Linux. However, I do get these errors when trying a presentation with custom animation sound:

(soffice:2078): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /opt/lodev3.5/program/../ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libdirac_encoder.so.0)
Comment 4 sasha.libreoffice 2012-03-30 06:34:33 UTC
reproduced in 3.5.1 on Fedora 64 bit. all as in comment 3. But from Gallery sound works.
Comment 5 Christopher M. Penalver 2012-05-05 07:30:35 UTC

*** This bug has been marked as a duplicate of bug 40780 ***