Download it now!
Bug 44116 - 'com::sun::star::uno::RuntimeException' with Writer
Summary: 'com::sun::star::uno::RuntimeException' with Writer
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: x86 (IA32) Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-24 01:50 UTC by Elie Roux
Modified: 2013-12-15 23:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (3.43 KB, application/x-bzip2)
2012-01-04 10:32 UTC, Elie Roux
Details
strace log (362.38 KB, application/x-bzip)
2012-01-05 05:37 UTC, Elie Roux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elie Roux 2011-12-24 01:50:29 UTC
Hello,

I'm trying to install LO-3.5-beta2 to update the bug reports I've filed. I've installed the official deb files. I can launch the panel with the command lodev3.5, but when I select "Text document" (it's ok with the others), the writer starts almot until the end, but after that it crashes and the terminal writes "terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'".

Thank you
Comment 1 Petr Mladek 2012-01-04 08:46:53 UTC
Elie, could you please attach backtrace from the crash? See hints at http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29
Comment 2 Elie Roux 2012-01-04 10:32:43 UTC
Created attachment 55126 [details]
backtrace

Hello,

here is the backtrace, but it doesn't seem to have debugging symbols. Where can I find the "libreoffice*-debuginfo packages" as told in http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29?

Thank you,
-- 
Elie
Comment 3 Petr Mladek 2012-01-05 02:35:10 UTC
It is pity but we do not have debuginfo packages available for the official TDF builds. They are often available for distro-specific builds, though.

Anyway, it fails in:
#14 0xae4ec872 in SmartTagMgr::LoadLibraries() () from /opt/lodev3.5/program/../program/libsvxlo.so

Could you please provide also strace log? It might show what library can't be loaded. See hints at http://wiki.documentfoundation.org/BugReport#How_to_get_strace_log_.28on_Linux.29

BTW: What distribution are you using? I am not able to reproduce this on SLED10-i586 or SLED11-SP1-x86_64.
Comment 4 Elie Roux 2012-01-05 05:37:00 UTC
Created attachment 55169 [details]
strace log

Here is the backtrace. I see quite a lot of "file not found" in it.

My distro is a debian stable (squeeze), I made the installation with the .deb packages available on the website, but I noticed that they make a totally different file structure in /opt/lodev3.5 : I have all the libs in /opt/lodev3.5/program, when there is no lib in /opt/libreoffice3.4/program... is it normal?

Thank you,
-- 
Elie
Comment 5 Petr Mladek 2012-01-05 07:52:01 UTC
I have found three interesting things in the strace log:

1. It did not find libnss_db.so.2. I wonder what this library is for and who requires it. I do not see it here on my SLED11-SP1 system. Could you please try to install it? It might be in a package called nss-db or so.


2. It aborts close after looking for com/sun/star/beans/PropertyState.class. It might be somehow related to the java stuff.

It aborts inside SmartTagMgr::Init during the SmartTagMgr::LoadLibraries. The Init method does something with beans as well.

Please, try to install the package lodevbasis3.5-extension-beanshell~cript-provider if you do not have it yet.


3. I see that you have installed the extension ReadabilityReport.oxt. It is written in java and it might be related.

   Does it help you to uninstall it?

--------

If nothing helps, could you please try to run the application with the default user configuration? You could do something like:

    1. quit LO
    2. save the old configuration:
       mv $HOME/.config/lodev/3 /home/eroux/.config/lodev/3.old1
    3. run LO again
Comment 6 Elie Roux 2012-01-06 01:06:39 UTC
Hello,

I've tried the following things:
 - installing the package libnss-db: nothing changed
 - reinstalling the package lodevbasis3.5-extension-beanshell-script-provider_3.5.0-2_i386.deb : nothing changes (it was already installed)
 - removing the (already disabled) Readability_Report extention, and also the ChangePicture extention (anyways, it would be good to have the functionnality in a standard LO): nothing changed
 - moving .config/lodev/3 to .config/lodev/3old: it works now!

How can I track the bug more precisely? Do you want my old config directory (it's 21MB bzip2ed)?

Thank you!
-- 
Elie
Comment 7 Petr Mladek 2012-01-06 01:24:57 UTC
Let's start with diff :-) Please do the following:

   cd .config/lodev
   diff -purN 3old 3 >lodev-3-config.diff
   bzip2 lodev-3-config.diff

and attach the lodev-3-config.diff.bz2 file here.
Comment 8 Petr Mladek 2012-01-06 07:42:36 UTC
Ellie sent me link to the problematic configuration. It used ReadabilityReport.oxt, version 2.0.0-beta1. I installed it and got exactly the same crash (same lines in strace log).

It helped me to remove the extension using the command:
/opt/lodev3.5/program/unopkg remove surrey.ReadabilityReport

I checked the provided configuration and the extension was registered there => 
the attempt to disable/remove it probably failed.


There exists a never version 2.0.4 of this extension, see http://extensions.services.openoffice.org/en/node/2659/releases. It works well with LO-3.5.0-beta2. The download page has the text:

--- cut ---
Now works with Open Office 3.3 and LibreOffice 3.3.
--- cut ---

It means that the older version was somehow broken.


Hmm, it would be great if LO does not crash because of broken 3rd party extensions. On the other hand, I am not sure if it is possible at all. So, I close this as NOTOURBUG.
Comment 9 Elie Roux 2012-01-07 01:50:08 UTC
Hello,

Thank you very much for the fix, it works fine now. Maybe it would be worth documenting this bug on the wiki?

Thank you,
-- 
Elie
Comment 10 Petr Mladek 2012-01-09 02:36:15 UTC
I have mentioned it at http://wiki.documentfoundation.org/ReleaseNotes/3.5#Most_annoying_bugs_in_3.5.0
Comment 11 Roman Eisele 2012-05-04 03:12:38 UTC
This is a Writer issue (or looks like one, cf. comment #8), therefore changed the 'Component' field appropriately.