Bug 44157 - FILEOPEN: Loading RTF file very slow (7x in comparison witl LibO 3.4.4), no progress bar displayed
Summary: FILEOPEN: Loading RTF file very slow (7x in comparison witl LibO 3.4.4), no p...
Status: CLOSED DUPLICATE of bug 38057
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
3.5.0 Beta1
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
Whiteboard: BSA
Keywords: regression
Depends on:
Reported: 2011-12-26 12:00 UTC by s-joyemusequna
Modified: 2012-03-20 13:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description s-joyemusequna 2011-12-26 12:00:32 UTC
Problem description: Loading RTF files is very slow in comparison with LibO 3.4.4 (approx. factor 7), no progress bar is displayed, the interface is frozen 
(problem visible in LibO 3.5.0 Beta1 and Beta2)

Steps to reproduce:
1. load a large RTF file
2. do the same with LibO 3.4.4

Current behavior: loading is very slow, the interface is irresponsive (frozen), PC seems to hang with large files

Expected behavior: at least the progress bar is displayed, if possible the old loading speed is restored

Platform (if different from the browser): Windows Vista 64, Windows XP (32 bit), both with latest service packs
Browser: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0
Comment 1 Miklos Vajna 2012-01-11 12:16:54 UTC
Assign to me.
Comment 2 Miklos Vajna 2012-01-11 12:19:47 UTC

I implemented the progressbar yesterday for bug 38057. I'm closing this bug, however in case you have a testcase reproducing the slowdown, it may help to identify which part of the import process is the bottleneck. (So we can try to optimize that part.)


*** This bug has been marked as a duplicate of bug 38057 ***
Comment 3 s-joyemusequna 2012-01-12 10:23:26 UTC

thank you very much for the progressbar.

I have created a new bug report (Bug 44736) considering the slowdown in loading some RTF files with a testcase.
Comment 4 Jean-Baptiste Faure 2012-03-20 13:42:44 UTC