Bug 44167 - failing subsequenttests in ScDatabaseRangeObj
Summary: failing subsequenttests in ScDatabaseRangeObj
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.6.0
Keywords:
Depends on:
Blocks: subsequenttest-failures
  Show dependency treegraph
 
Reported: 2011-12-26 22:46 UTC by Markus Mohrhard
Modified: 2017-09-29 08:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Mohrhard 2011-12-26 22:46:49 UTC
The following tests fail at the moment:

sc.ScDatabaseRangeObj::com::sun::star::sheet::XDatabaseRange
sc.ScDatabaseRangeObj::com::sun::star::util::XRefreshable
Comment 1 Markus Mohrhard 2011-12-26 22:55:51 UTC
These are probably no regressions but errors in the tests related to our change of unnamed db data handling. Will look into them soon.
Comment 2 Not Assigned 2012-02-19 14:57:34 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d9653ee2f3bc1f77a31df6978e9d4ed4e74dbfb0

add testRefresh to ScDatabaseRangeObj, related fdo#44167
Comment 3 retired 2014-01-08 09:23:19 UTC
Markus did your patch fix this bug? Can we adjust status?

This bug hasn't seen any action. Freeing this bug and switching ASSIGNED to NEW, please update to fixed if your commit indeed fixes this bug.
Comment 4 Alex Thurgood 2015-01-03 17:38:40 UTC Comment hidden (no-value)
Comment 5 QA Administrators 2016-01-17 20:03:11 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2016-09-26 11:38:50 UTC
Hello Markus,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 7 Markus Mohrhard 2016-09-26 11:39:55 UTC
(In reply to Xisco Faulí from comment #6)
> Hello Markus,
> Is this bug fixed?
> If so, could you please close it as RESOLVED FIXED?

If I did not close the bug they are not fixed. Otherwise I would have closed the bug.
Comment 8 Xisco Faulí 2017-09-29 08:50:02 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.4.1 or 5.3.6  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20170929