Download it now!
Bug 44230 - BUGZILLAASSISTANT: nested scrollable areas difficult to use
Summary: BUGZILLAASSISTANT: nested scrollable areas difficult to use
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 41639 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-28 10:23 UTC by Ed
Modified: 2015-04-21 15:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed 2011-12-28 10:23:46 UTC
The bug reporting page at https://www.libreoffice.org/get-help/bug/ has a scrollable area within the page, that can become very long once it is populated with the titles of the bug reports that match the user's selections for component, subcomponent and version.  The page is itself scrollable, which means we have a long scrollable area nested within a shorter one.  

This is a bit of a no-no for user interface design: if the inner scrollable area is scrolled to the bottom and the page is also scrolled to the bottom, the user cannot scroll the inner area back to the top without also having to scroll the page back to the top, and vice versa for starting at the top and moving to the bottom.  

As far as I can tell there is no good reason to have an inner scrollable area within the page.  I would suggest that its scrollability be dispensed with, that the whole of this area be displayed on the page, so the length of this area could simply be handled by scrolling the entire page.
Comment 1 Rainer Bielefeld Retired 2012-06-01 22:56:13 UTC
Yes, we already discussed that, thank you for submitting the bug.
Comment 2 Rob Snelders 2012-08-17 14:54:30 UTC
*** Bug 41639 has been marked as a duplicate of this bug. ***
Comment 3 Buovjaga 2015-04-21 15:29:56 UTC
Closing as WONTFIX. BSA has gone away and in the (hopefully near) future we will be using BZ's improved guided entry template: http://bugzilla.readthedocs.org/en/latest/integrating/templates.html#particular-templates