Download it now!
Bug 44254 - "Restore Windows" dialog that does not go away
Summary: "Restore Windows" dialog that does not go away
Status: RESOLVED DUPLICATE of bug 39007
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-28 20:24 UTC by Fred Tischler
Modified: 2012-06-18 06:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Restore Windows Error (21.45 KB, image/png)
2011-12-28 20:24 UTC, Fred Tischler
Details
problematic ~/Library/Saved Application State/org.libreoffice.script.savedState (6.29 KB, application/zip)
2012-06-14 06:14 UTC, Stephan Bergmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fred Tischler 2011-12-28 20:24:45 UTC
Created attachment 54930 [details]
Restore Windows Error

Installed LibreOffice on MAC Lion and it ran perfectly for about a week, then when I loaded a Power point file the computer froze up.  Had to re-boot and Libre will open with the following error window:

Restore Windows

The application "LibreOffice" unexpectedly quit while trying to restore its windows.  Do you want to try to restore its windows again?  and it gives me the option th restore or not restore.

in this condition any of its applications will come up, however it will not allow me to open a file.  Files are not available to choose from.  If I go to Finder and click on a file, Libre opens but no file opens.  The only way to get rid of the error window is to "Force Quit" Libre. 

I've un-installed and re-installed and exactly the same situation happens.

Is there an Deinstaller for the Lbre suite so I'm sure all files are deleted before I re-install?

Fred Tischler
Comment 1 sasha.libreoffice 2012-05-03 05:45:27 UTC
Thanks for bugreport
Try to move LibreOffice user profile to another place
Comment 2 Joel Madero 2012-06-07 21:51:40 UTC
Marking as NEEDINFO as a solution was proposed and no follow up has been done. If this is still a problem please open the bug back up as UNCONFIRMED
Comment 3 Stephan Bergmann 2012-06-14 06:10:52 UTC
I happened to run into this problem now, too, with the LibO-Dev_3.6.0beta1_MacOS_x86_install_en-US.dmg currently available at <http://www.libreoffice.org/download/pre-releases/> on a Mac OS 10.7.4 machine that runs many different LO versions (so already had an existing ~/Library/Saved Application State/org.libreoffice.script.savedState (attached).  The backtrace is as below.  Searching the web for "promptToIgnorePersistentState" shows similar scenarios for other applications, too, but gave no clue whether this is an application problem or an OS one.  Searching developer.apple.com for "promptToIgnorePersistentState" or "NSPersistentUIManager" gives no results.

A workaround is to remove the ~/Library/Saved Application State/org.libreoffice.script.savedState directory.

#0  0x99fb4c22 in mach_msg_trap ()
#1  0x99fb41f6 in mach_msg ()
#2  0x962d99da in __CFRunLoopServiceMachPort ()
#3  0x962e2b04 in __CFRunLoopRun ()
#4  0x962e21dc in CFRunLoopRunSpecific ()
#5  0x962e2088 in CFRunLoopRunInMode ()
#6  0x9ab72723 in RunCurrentEventLoopInMode ()
#7  0x9ab79a8b in ReceiveNextEventCommon ()
#8  0x9ab798fa in BlockUntilNextEventMatchingListInMode ()
#9  0x942680d8 in _DPSNextEvent ()
#10 0x94267942 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] ()
#11 0x01acebbf in AquaSalInstance::Yield ()
#12 0x017e50e0 in Application::Yield ()
#13 0x017e51cc in Application::Execute ()
#14 0x00078a44 in desktop::Desktop::Main ()
#15 0x017ee6d2 in ImplSVMain ()
#16 0x01acdf8b in AquaSalInstance::handleAppDefinedEvent ()
#17 0x01b1720b in -[VCL_NSApplication sendEvent:] ()
#18 0x9453977e in -[NSApplication _modalSession:sendEvent:] ()
#19 0x94539348 in -[NSApplication _realDoModalLoop:peek:] ()
#20 0x9453459d in -[NSApplication _doModalLoop:peek:] ()
#21 0x94539024 in -[NSApplication runModalForWindow:] ()
#22 0x94529433 in -[NSAlert runModal] ()
#23 0x9429ab5a in __-[NSPersistentUIManager promptToIgnorePersistentState]_block_invoke_1 ()
#24 0x94539af4 in -[NSApplication _suppressFinishLaunchingFromEventHandlersWhilePerformingBlock:] ()
#25 0x9429a81a in -[NSPersistentUIManager promptToIgnorePersistentState] ()
#26 0x9426b776 in -[NSApplication _reopenWindowsAsNecessaryIncludingRestorableState:registeringAsReady:completionHandler:] ()
#27 0x9426b6bb in -[NSApplication(NSAppleEventHandling) _reopenWindowsIfNecessaryWithAppleEvent:completionHandler:] ()
#28 0x9426b59e in -[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:] ()
#29 0x9426b2c6 in -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] ()
#30 0x963451c8 in -[NSObject performSelector:withObject:withObject:] ()
#31 0x9a2d80c2 in __-[NSAppleEventManager setEventHandler:andSelector:forEventClass:andEventID:]_block_invoke_1 ()
#32 0x9a2d6e75 in -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] ()
#33 0x9a2d6c49 in _NSAppleEventManagerGenericHandler ()
#34 0x9c7ee045 in aeDispatchAppleEvent ()
#35 0x9c7d7b67 in dispatchEventAndSendReply ()
#36 0x9c7d7a54 in aeProcessAppleEvent ()
#37 0x9ab81c66 in AEProcessAppleEvent ()
#38 0x94268347 in _DPSNextEvent ()
#39 0x94267942 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] ()
#40 0x94263cb1 in -[NSApplication run] ()
#41 0x944f4bd9 in NSApplicationMain ()
#42 0x01acf547 in ImplSVMainHook ()
#43 0x017ee761 in SVMain ()
#44 0x000a4e56 in soffice_main ()
#45 0x00001f0e in main ()
#46 0x00001872 in _start ()
#47 0x00001799 in start ()
Comment 4 Stephan Bergmann 2012-06-14 06:14:17 UTC
Created attachment 63022 [details]
problematic ~/Library/Saved Application State/org.libreoffice.script.savedState
Comment 5 manj_k 2012-06-18 02:40:38 UTC
Already reported (and Assigned) as 'Bug 39007 - Persistent "Restore Windows"
dialog won't disappear, disables key functionality' (Blocks MAB 37361).

@Stephan Bergmann
Should be marked as a duplicate of bug 39007.
Please make a decision.
Comment 6 Stephan Bergmann 2012-06-18 06:09:36 UTC
(In reply to comment #5)
> Should be marked as a duplicate of bug 39007.

That was the one I had been looking for in vain...

*** This bug has been marked as a duplicate of bug 39007 ***