Bug Hunting Session
Bug 44366 - FORMATTING: select arbitrary color with a HEX color picker
Summary: FORMATTING: select arbitrary color with a HEX color picker
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86 (IA32) Linux (All)
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0
Keywords:
: 50734 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-01 07:52 UTC by Pierre Abbat
Modified: 2014-10-14 23:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Abbat 2012-01-01 07:52:35 UTC
Someone sent me a file in docx format in which different characters in a dialog are colored different colors. I'm supposed to add more dialog. Some of the characters I'm adding lines for are the same as the characters she sent me lines of. So I have to use the same color she did. I click on the text and do Format|Character and find that it's in color "User". With KRuler I can tell that it's color #0070c0, but I see no way to enter a new color numerically. I can copy the color with the paintbrush, but I'd like to see a way to enter a new color into the list of colors that can be applied to text.
Comment 1 sasha.libreoffice 2012-05-03 07:35:13 UTC
Thanks for bugreport
Use KColorChooser instead of KRuler to pick color, see RGB values
in LibO use Tools->Options->LibreOffice->Colors, enter RGB values, add color
Comment 2 Joel Madero 2012-07-03 10:49:56 UTC
I think adding hex color is possible and might be useful for users. I'm going to mark as NEW and make it a low priority. Thanks for the suggestion
Comment 3 ign_christian 2013-07-26 14:43:05 UTC
*** Bug 50734 has been marked as a duplicate of this bug. ***
Comment 4 Fabian Alexander Wilms 2014-01-26 11:25:42 UTC
Here's a mockup shwing how this could work: https://wiki.documentfoundation.org/File:Color_picker_tentative_v2.png
Comment 5 Adolfo Jayme 2014-10-14 23:19:16 UTC
Fixed in 4.4.