Download it now!
Bug 44389 - UI: Certain cursor move and range selection keyboard shortcuts do not work when entering formulae
Summary: UI: Certain cursor move and range selection keyboard shortcuts do not work wh...
Status: RESOLVED DUPLICATE of bug 37230
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-02 09:50 UTC by Ed
Modified: 2013-07-31 23:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed 2012-01-02 09:50:17 UTC
LibO on Windows XP.  

You can use the keyboard shortcuts Ctrl+Arrow to move in any of the four arrow directions to the end of the current data range, and Ctrl+Shift+Arrow to select from the current cell to the end of the data range.  You would expect this to work when entering a formula: the formula-editing process allows you to move to and select cells whose references are then inserted into the formula.  

However, when entering a formula, none of Ctrl+Down Arrow, Ctrl+Up Arrow, Ctrl+Shift+Down Arrow and Ctrl+Shift+Up Arrow work correctly: they move to or select to the edge of the spreadsheet, not the end of the data range.  

Strangely, all of Ctrl+Left Arrow, Ctrl+Right Arrow, Ctrl+Shift+Left Arrow and Ctrl+Shift+Right Arrow do all work correctly: they move to or select to the end of the data range.
Comment 1 sasha.libreoffice 2012-05-03 08:04:52 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
Comment 2 Joel Madero 2012-10-03 19:13:15 UTC
I am marking this as WORKSFORME as everything I tried seemed to work flawlessly with LibO 3.6.2.1. If this is still a problem for you can you reopen as UNCONFIRMED and provide your LibO version. 

Thanks in advance
Comment 3 crxssi 2013-07-31 23:42:51 UTC

*** This bug has been marked as a duplicate of bug 37230 ***