Download it now!
Bug 44445 - VIEWING UI screen jump to other position when zooming in/out
Summary: VIEWING UI screen jump to other position when zooming in/out
Status: RESOLVED DUPLICATE of bug 40465
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-04 02:27 UTC by Winfried Donkers
Modified: 2013-02-01 08:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
document to demonstrate behaviour (10.29 KB, application/vnd.oasis.opendocument.text)
2012-01-10 00:41 UTC, Winfried Donkers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Donkers 2012-01-04 02:27:06 UTC
Any writer document with 2 pages or more:
-place the cursor somewhere on page 2;
-zoom to 500% (or whatever large value);
-zoom back to 100%: the screen does not show what was originally visible, it may even have switched to page 1.

Possibly this is the same as bug 33750   but to be on the safe side I have not reopened it.
Comment 1 Rainer Bielefeld Retired 2012-01-09 23:45:05 UTC
NOT 3eproducible with "LibreOffice 3.4.5 RC2  - WIN7 Home Premium (64bit) German UI [Build ID: OOO340m1 (Build:502)]" or any other of my mversions.

I created a 52 pages Lorem Ipsum document, marked the first word of a paragraph in the middle of page 19 with yellow background, zoomed with menu 'View -> Zoom' to 500 % and back to 100%, word was still visible.

Nevertheless, I am pretty sure that I sometimes suffer from the reported problem, but it seems that there are additional circumstances necessary to see the effect. Or only 3.4.4?

@Winfried:
Please attach a sample document and contribute a more detailed description how to reproduce the problem.
Comment 2 Winfried Donkers 2012-01-10 00:41:39 UTC
Created attachment 55368 [details]
document to demonstrate behaviour

Used version: 3.4.4 release, Windows XP
-open document (zoom factor 100%)
-set cursor on page 2, say in "L229"
-zoom to 500%; cursor is no longer visible
-zoom to less than 90%; text on page 2 is no longer visible
-zoom to 30%; all 4 pages are visible in one row
-zoom to 100%; page 1 is visible, but cursor is not
-with Up/down/left or right button, cursor becomes visible again

Used version: master (git update yesterday), openSUSE 11.4
-same behaviour, expect that I don't hav eto zoom up to 500% (120% is sufficient) to lose sight of the cursor.
Comment 3 sasha.libreoffice 2012-03-14 08:27:00 UTC
Reproduced in 3.5.1.2 on Fedora 64 bit
Steps to reproduce:
0. Open attachment
1. Place cursor in first line on second page
2. in righthand bottom corner of screen find page display settings and set middle variant (to display several pages of document on screen at once
3. in righthand bottom corner of screen double click by mouse number (with Viev->zoom not reproducible)
4. change to 60% (or something else for 2 pages in horizontal row appears)
5. change to 600%
6. change to 60%
Expected: beginning of page 2 on screen
Actually: end of last page on screen
Comment 4 Rainer Bielefeld Retired 2012-03-14 10:14:22 UTC
"zoom to 500%" is reproducible with "LibreOffice 3.5.1.2 German UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit), problems of other steps only more or less and if Multipages - column - book look frills are active, but not with single page view. But there is no doubt, this can be improved, focus normally should stay on cursor (IMHO).

I can't see significant differences compared to 3.3.0 and Oo 3.1.1, do you agree with Version 3.3.0Beta2 - OOo heritage?
Comment 5 Winfried Donkers 2012-03-15 00:03:57 UTC
(In reply to comment #4)
>... 
> I can't see significant differences compared to 3.3.0 and Oo 3.1.1, do you
> agree with Version 3.3.0Beta2 - OOo heritage?

Not sure if you (Rainer) mean me with 'you' in previous comment, but I agree - haven't changed the version, nor set the status to confirmed, I leave that to you (Rainer).
Comment 6 Rainer Bielefeld Retired 2012-03-15 00:11:34 UTC
> Not sure if you (Rainer) mean me with 'you' 

You all ;-)

Modify Version due to latest results and comments

@Cédric:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 7 Winfried Donkers 2012-03-19 04:46:16 UTC
This bug may be related to bug 40465 (or even one is a duplicate of the other)
Comment 8 Winfried Donkers 2013-02-01 08:25:07 UTC

*** This bug has been marked as a duplicate of bug 40465 ***