Bug 44468 - FORMATTING: LO crashes when using conversion with Change Case
Summary: FORMATTING: LO crashes when using conversion with Change Case
Status: RESOLVED DUPLICATE of bug 37044
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86 (IA32) Mac OS X (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-04 15:41 UTC by dr_tak
Modified: 2012-04-10 00:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
crash log (65.38 KB, text/plain)
2012-01-25 15:59 UTC, Fabio Bugnon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dr_tak 2012-01-04 15:41:01 UTC
Problem description: 

Steps to reproduce:
1. Open MS Word 2003 or Unicode-encoded text file
2. Select text
3. Choose Format/Change Case/UPPERCASE for example

Current behavior: Crash

Expected behavior: transforms selected text to upper case

Also crashes with lower case, capitalize and sentence

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; en-us) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1
Comment 1 namelesshorror 2012-01-19 15:07:35 UTC
I can confirm the exact same problem in 3.4.5 FINAL for Mac (OSX 10.7.2).

Working with an .fodt file in this case:

Highlight text to change case.

Format > Change Case > any option

Results in crash to desktop, every time.
Comment 2 Dont Bother 2012-01-19 18:29:42 UTC
I can confirm the same behaviour in 3.5 beta 3, OS X 10.6.8.

Just create a new document, write something, choose any change case menu entry and get a crash.

I'm using the Spanish language version.
Comment 3 Fabio Bugnon 2012-01-25 15:59:12 UTC
Created attachment 56163 [details]
crash log

Crash log automatically provided by Mac OS "Problem Report"
Comment 4 Fabio Bugnon 2012-01-25 16:05:25 UTC
I can confirm this with 3.5 RC 1 under Mac OS 10.6.8.

This bug was also present under 3.3, but not on 3.4, so I'll risk saying it's a regression.

The crash will occur with no matter what document type (I've tried odt, doc and docx) and with no matter what option of "change case", accessed by the menu Format > Change Case or simply by the right-click menu.

(Apparently this bug is an old-duplicate https://bugs.freedesktop.org/show_bug.cgi?id=37044)
Comment 5 Dont Bother 2012-02-14 10:28:29 UTC
Confirmed in 3.5 final

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735

I confirm everything Fabio Bignon says.
Comment 6 Florian Reisinger 2012-04-10 00:21:05 UTC
Marked as a duplicate, I am going to write a longer message @ the other bug report

*** This bug has been marked as a duplicate of bug 37044 ***