Bug Hunting Session
Bug 44492 - in Arabian text blank squares instead of letters
Summary: in Arabian text blank squares instead of letters
Status: CLOSED DUPLICATE of bug 44078
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 Beta1
Hardware: All Linux (All)
: medium critical
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-05 03:44 UTC by sasha.libreoffice
Modified: 2012-02-08 03:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
copy-pasted from site on Arabian (9.66 KB, application/vnd.oasis.opendocument.text)
2012-01-05 03:44 UTC, sasha.libreoffice
Details
I have selected all text and changed to Lohit Kannada (93.95 KB, image/png)
2012-01-06 01:48 UTC, sasha.libreoffice
Details
fc-list -v result (366.82 KB, text/plain)
2012-01-06 03:56 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-01-05 03:44:50 UTC
Created attachment 55167 [details]
copy-pasted from site on Arabian

I have copy-pasted part of site on arabian into Writer. And see blank squares instead of letters. IMHO it it regression, because in LibO 3.3.4 on the same comp it looks correctly.
reproduced on LibO 3.5.0 beta 1 on Fedora 64 bit
Comment 1 Lior Kaplan 2012-01-05 03:50:23 UTC
File looks fine in LibO 3.5.0 beta2 on Ubuntu.
Comment 2 Petr Mladek 2012-01-05 05:13:12 UTC
Looks fine with LO-3.5.0-beta2 on SLED11-SP1.

Sasha, could you please provide output from the following command?

    fc-match Mangal

I do not have the "Mangal" font installed here. Also, the fallback is not defined in VCL.xcu, see http://cgit.freedesktop.org/libreoffice/core/tree/officecfg/registry/data/org/openoffice/VCL.xcu?h=libreoffice-3-5
=> I guess that the fallback font is suggested by fontconfig. It evidently provides good fallback here.
Comment 3 sasha.libreoffice 2012-01-05 22:19:48 UTC
[s@t2 program]$ fc-match Mangal
DejaVuSans.ttf: "DejaVu Sans" "Book"

>I do not have the "Mangal"
Change font to Lohit Kannada, or another Lohit. On my comp in LibO 3.3.4 displays correctly with Lohit. But in LibO 3.5.0 only squares.
Comment 4 Petr Mladek 2012-01-06 01:41:36 UTC
It is really strange. I am not able to reproduce it. It displays here fine even with "Dejavu Sans" font. I use 3.5.0-beta2-x86_64 on SLED11-SP1-x86_64.

Just to be sure. I understand that you did the following steps:

1. open on-arabian.odt
2. select the first line: بسم الله الرحمن الرحيم
3. select the font "Lohit Kanada" in the toolbar

Result with LO-3.3.4: shows correctly
Result with LO-3.5.0-beta1: squares instead of the Arabic letters
Expected result: shows Arabic letters even in LO-.3.5.0

Am I right?

Also, could you please attach a screenshot that shows the squares?
Comment 5 sasha.libreoffice 2012-01-06 01:48:30 UTC
Created attachment 55199 [details]
I have selected all text and changed to Lohit Kannada
Comment 6 Petr Mladek 2012-01-06 03:38:53 UTC
It is really strange. It looks fine with the Lohit Canada font here.

Caolan, I think that you worked on the font stuff. Do you have any idea what is going on the Sasha's Fedora system?
Comment 7 Caolán McNamara 2012-01-06 03:41:10 UTC
works fine for me as well, sounds a bit like bug 44078, but I can't reproduce that one either, and Lior says this one works for him. I suspect some similar problem, perhaps triggered by the upgraded internal DejaVu fonts.

I wonder if closing LibreOffice, rm -rf /opt/lodev3.5/share/fonts/truetype/DejaVu*, and then restart LibreOffice makes a difference ?
Comment 8 Caolán McNamara 2012-01-06 03:47:27 UTC
caolanm->sasha:
a) what version of fedora is this ?
b) what desktop environment, gnome2, gnome3, kde, xfce ?
c) can you attach the output of...
fc-list -v > /tmp/big.font.list.txt
to this bug, that might allow me to match my installed fonts to your ones
Comment 9 sasha.libreoffice 2012-01-06 03:52:55 UTC
when I deleted /opt/lodev3.5/share/fonts/truetype, all becomes fine.
Thanks!
a) IMHO Fedora 15,upgraded until now
b) KDE 4.6.5
Comment 10 sasha.libreoffice 2012-01-06 03:56:13 UTC
Created attachment 55205 [details]
fc-list -v result
Comment 11 Caolán McNamara 2012-01-06 04:03:01 UTC
great, and last piece of information that might help, output of...
locale
Comment 12 sasha.libreoffice 2012-01-06 04:46:20 UTC
[s@t2 ~]$ locale
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=
[s@t2 ~]$
Comment 13 Caolán McNamara 2012-01-06 06:19:03 UTC
thanks sasha. I can reproduce this now.
Comment 14 Caolán McNamara 2012-01-11 06:21:08 UTC
This commit http://cgit.freedesktop.org/libreoffice/core/commit/?id=6c06dd347ca2e8a5dc42884344ed8c7c4c5f18b9 and a pile of others fixes this for master, need to cook up something less invasive for 3.5
Comment 15 Caolán McNamara 2012-01-11 09:07:33 UTC

*** This bug has been marked as a duplicate of bug 44078 ***