Bug 44528 - FILESAVE: Cannot save a spreadsheet when copying a sheet
Summary: FILESAVE: Cannot save a spreadsheet when copying a sheet
Status: RESOLVED DUPLICATE of bug 41054
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-06 05:39 UTC by Carsten Niehaus
Modified: 2012-01-11 01:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The file which cannot be saved when you copy the second table. (32.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-01-06 05:39 UTC, Carsten Niehaus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carsten Niehaus 2012-01-06 05:39:00 UTC
Created attachment 55212 [details]
The file which cannot be saved when you copy the second table.

Problem description: 
When I copy a table (duplication of table 'K1') I can no longer save the file unless I remove the table 'Seriendruck'...

Steps to reproduce:
1. Copy sheet K1 so that you have K1 and K2 (for example)
2. Try to save the file
3. Error

Current behavior:
You cannot save the file. The only way to save the file is to remove table "Seriendruck". That is of course not what I want.

Expected behavior:
One should be able to save the file

              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.75 Safari/535.7
Comment 1 GerardF 2012-01-06 13:52:17 UTC
With LibreOffice 3.4.4

I've made few test with your file :

Copy sheet K1 (with new name K2)in 1st or last position (before "Kursübersicht" or after "Seriendruck") : I can save the file.

Copy sheet K1 (with new name K2)just before or after K1 : error
*unless* i removed the comment in cell AS1.
Without comment, i can save.

With LibreOffice 3.5.0 beta2, i cannot reproduce.

Can you confirm my tests with 3.4.4 and/or have a try with 3.5.0 beta2 ?
Comment 2 Rainer Bielefeld Retired 2012-01-08 10:34:27 UTC
NOT reproducible with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta2- WIN7 Home Premium (64bit) German UI [Build-ID : 8589e48-760cc4d-f39cf3d-1b2857e-60db978] 
NOT reproducible with "LibreOffice 3.4.5 RC1  - WIN7 Home Premium (64bit) German UI [Build ID: OOO340m1 (Build:501)]"
Comment 3 Carsten Niehaus 2012-01-08 23:38:21 UTC
@GerardF 

I can confirm that I can safe the file when K2 is behind "Seriendruck" (in last position).

I cannot confirm that the removal of the command fixes the issue...



I think I read that one new feature in LO 3.5.x will be that ranges can be local (that is, the same name can be used in two or more sheets). I am used names for cells. Perhaps this is the cause of the issue???
Comment 4 Markus Mohrhard 2012-01-09 10:43:21 UTC
> I think I read that one new feature in LO 3.5.x will be that ranges can be
> local (that is, the same name can be used in two or more sheets). I am used
> names for cells. Perhaps this is the cause of the issue???

No this feature has been added to 3.4 already.

I think this is a duplicate of all the other bugs mentioning similar problems but no dev was yetr able to reproduce this problem.
Comment 5 Cor Nouws 2012-01-11 01:11:00 UTC

*** This bug has been marked as a duplicate of bug 41054 ***
Comment 6 Petr Mladek 2012-01-11 01:16:59 UTC
I have just reproduced the problem with the original test document. The important thing is to put the copied sheet K1 before the sheet "Seriendruck".

Steps to reproduce:

1. open libreoffice_calc_bug.ods
2. press right mouse button on the sheet "K1" and select "Move/Copy Sheet"
3. select "Action": "Copy"
4. select "Insert before": "Seriendruck"
5. try to save the document

Result: Error saving the document; Write Error; The file could not be written

Expected Result: the file is saved

Observation: I am unable to reproduce this when I do not put the sheet before the sheet "Seriendruck"