Download it now!
Bug 44550 - FILEOPEN: particular cell double borders are invisible
Summary: FILEOPEN: particular cell double borders are invisible
Status: RESOLVED DUPLICATE of bug 38595
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-07 03:48 UTC by lml
Modified: 2012-01-08 03:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
A screen capture of the two cells with double-border, at zoom level 115% (51.79 KB, image/png)
2012-01-07 03:48 UTC, lml
Details
Sample document (8.72 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-01-07 10:59 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lml 2012-01-07 03:48:10 UTC
Created attachment 55244 [details]
A screen capture of the two cells with double-border, at zoom level 115%

Problem description: 
Cell borders with double lines are lost after saving and reopening the document.
The problem is reproducible also in Libreoffice 3.4.4 (Ubuntu)

Steps to reproduce:
1. Start a new speadsheet
2. Select a cell (e.g. B2), write some text in it (to easily find later in content.xml) 
3. Select Format, Cells in menu and Borders tab
4. Set the properties exactly in this order (*):
   Line arrangement: Set all four borders,
   Line: Width=1,0pt
   Line: Style: select the 2nd double line (6th entry in the combo box)
5. Press OK
6. Save the file in ods format (test.ods)
7. Close the file
8. Check the content.xml:
   (copy the test.ods to test.zip, open the zip file, find content.xml in test.zip)
   In content.xml: everything seems OK. The automatic style declaration exists: 
   <style:style style:name="ce1" style:family="table-cell" style:parent-style-name="Default">
      <style:table-cell-properties fo:border="0.99pt double #000000" style:border-line-width="0.026cm 0.035cm 0.035cm"/>
   </style:style>

   and the cell (in <office:body>)  refers the style:
   <table:table-cell table:style-name="ce1" office:value-type="string"> 

   So, I think that not the saving but the loading has a bug.

9. Open the file: the cell borders do no exist.
10. Select File, Save As and save into a new file (test2.ods)
11. Check the content.xml in the new file:
   (copy the test2.ods to test2.zip, open the zip file, find content.xml in test2.zip)
    You will notice there are no border declarations:
    <style:style style:name="ce1" style:family="table-cell" style:parent-style-name="Default">
      <style:table-cell-properties fo:border="none"/>
      <style:text-properties style:text-position=""/>
    </style:style>


(*) Maybe it is a different problem (but connected to this). If you Set the properties in this order (in step 4):
   Line arrangement Set all four borders,
   Line: Style: select the 2nd double line (6th entry in the combo box)
   Line: Width=1,0pt
You will notice that with 115% zoom you will see a single-lined border (with more zoom you will see it's double border - maybe cannot displayed correctly) but if you save and reopen the file the formatting will remain the same (single line border) in the content.xml.

See attached image:
Borders of C4 created this way (set style then set width), but C7 created like Step 4 (set width then set style).
After save, close, reopen the formatting is lost only for C7.


Current behavior:
1. Setting cell border's to the same parameters in different order get different results (fist line style, then width or first line width then line style)
2. In the reopened file there is no double border around the cell (if you have set like in step 4.)

Expected behavior:
1. Setting cell border's to the same parameters should give the same result
2. After reopening all formatting should be the same as when it was saved.


Platform (if different from the browser): 
Linux x86_64 (Ubuntu 11.10) + LO3.5.0beta2;
also tested on Windows 7 (hun) + LO3.5.0beta2
Comment 1 Rainer Bielefeld Retired 2012-01-07 10:58:37 UTC
[Reproducible] with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta2- WIN7 Home Premium (64bit) German UI [Build-ID : 8589e48-760cc4d-f39cf3d-1b2857e-60db978] and also a 3.4.1RC

The problem is reproducible under more or less all circumstances, but only for exactly "second from top double line" border, some others I checked did not disappear.

Attached Sample document created with 350Beta2 has cell borders around B12 ... B30 in every second line. 
"LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]" shows all expected borders, 3.4.? until 3.5.0Beta2 do not show the border around B14

This one might be related to or DUP of "Bug 38595 - FILEOPEN: thin double line cell borders invisible"
Comment 2 Rainer Bielefeld Retired 2012-01-07 10:59:45 UTC
Created attachment 55269 [details]
Sample document

See Comment 1
Comment 3 Rainer Bielefeld Retired 2012-01-08 03:05:40 UTC

*** This bug has been marked as a duplicate of bug 38595 ***