Bug Hunting Session
Bug 44553 - libvisio: line caps are square rather than round
Summary: libvisio: line caps are square rather than round
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 53455 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-07 05:06 UTC by Bruno Girin
Modified: 2015-12-13 20:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Visio file that shows dashed lines at different weights (37.00 KB, application/vnd.visio)
2012-01-07 05:06 UTC, Bruno Girin
Details
PNG output from Visio showing what the diagram should look like (21.91 KB, image/png)
2012-01-07 05:06 UTC, Bruno Girin
Details
PNG output from LibreOffice showing what LO imports (44.12 KB, image/png)
2012-01-07 05:07 UTC, Bruno Girin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Girin 2012-01-07 05:06:29 UTC
Created attachment 55259 [details]
Visio file that shows dashed lines at different weights

Visio defaults to round line caps, which in turn means that dashes and dots in a line style are also rounded. When LibreOffice imports a Visio diagram, lines are created with a square cap. See attached file for an example.
Comment 1 Bruno Girin 2012-01-07 05:06:59 UTC
Created attachment 55260 [details]
PNG output from Visio showing what the diagram should look like
Comment 2 Bruno Girin 2012-01-07 05:07:35 UTC
Created attachment 55261 [details]
PNG output from LibreOffice showing what LO imports
Comment 3 Fridrich Strba 2012-01-11 02:43:09 UTC
This bug is actually LibreOffice internals' bug. The svg:stroke-linecap property is properly fed to LO, but it is ignored. Regina Henschel is working on this problem. But it will most probably not be part of 3.5
Comment 4 Fridrich Strba 2012-01-11 02:43:40 UTC
Assigned to Regina, since it will be solved once her implementation is out there.
Comment 5 Regina Henschel 2012-01-11 13:13:25 UTC
The line-cap feature is nearly finished. But part of the solution is written by Armin Le Grand and therefore with an Apache license. So integration in LibreOffice has to wait until it is allowed to use this license, hopefully with LO3.6.
Comment 6 Hashem Masoud 2012-10-11 07:45:13 UTC
*** Bug 53455 has been marked as a duplicate of this bug. ***
Comment 7 Samuel Mehrbrodt (CIB) 2013-02-07 21:12:05 UTC
Round Caps have been implemented in 4.0, but this bug is still there.
Comment 8 Regina Henschel 2015-11-23 20:05:24 UTC
I do not work on Visio import.
Comment 9 Fridrich Strba 2015-12-13 20:34:15 UTC
I see this bug fixed in LO 5.0.3