Download it now!
Bug 44556 - EDITING: Undesired Behavior Change in 3.5b2 when Extending a Selection in Calc
Summary: EDITING: Undesired Behavior Change in 3.5b2 when Extending a Selection in Calc
Status: RESOLVED DUPLICATE of bug 37230
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-07 06:04 UTC by Nino
Modified: 2013-07-31 23:48 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nino 2012-01-07 06:04:39 UTC
Before 3.5, it was easiliy possible to select all cells of an inserted (empty) column (between data containing columns) by 
1) selecting the first cell of the empty column, 
2) extending selection to a neigbouring cell (containing data) by pressing SHIFT+ArrowLeft 
3) pressing CTRL+SHIFT+ArrowDown to extend selection until bottom of data range and finally 
4) reducing selection to the empty column with SHIFT+ArrowRight

This could be effectively done with only four keystrokes:
1) Hold down SHIFT
2) press ArrowLeft once (and keep holding SHIFT key)
3) press CTRL+ArrowDown once (but still keep holding SHIFT)
4) while SHIFT is still held, press ArrowRight

Now, at least in 3.5beta2, extending selection does not more stop at the end of the data range in step 3 but encompasses the whole (empty) column. 

Seems like extending a selection takes the origin of the extension as starting point instead of the actual cell.

Platform: Linux/RPM i686

Note: Possibly Bug#42535 describes a related phenomenon
Comment 1 Nino 2012-01-07 07:44:09 UTC
Ok, meanwhile I've learned to fill empty columns by double clicking on the fill handle, so for me the changed behavior isn't necessary any more. Therefore I'm closing the bug as "WORKSFORME" :-/

However, people might miss the old behavior for filling rows as the fill handle does not seem to support horizontal auto filling.
Comment 2 crxssi 2013-07-31 23:48:00 UTC

*** This bug has been marked as a duplicate of bug 37230 ***