Bug 44585 - TDF Site: "Download" button should auto-detect OS and language and initiate download of the latest release version
Summary: TDF Site: "Download" button should auto-detect OS and language and initiate d...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Florian Effenberger
URL: http://www.libreoffice.org/
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-08 11:13 UTC by Andreas Nilsson
Modified: 2012-06-26 02:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Quick and dirty mockup (276.69 KB, image/png)
2012-01-12 11:58 UTC, Andreas Nilsson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Nilsson 2012-01-08 11:13:27 UTC
My dad called me today and asked for help with getting a document writing application so I could write a letter to the court.
I pointed him to libreoffice.org, but it was very hard to navigate him to the right to download it on the page.

The download button on the front page seems to go to a separate download page with lots of text on it instead of starting the download directly.
There is a lot of text to go through before finding the actual download links.
(I have no idea what the difference between 3.4.4 and 3.3.4 is btw)

A way to fix this is to start downloading when you hit the download button on the front page (both Firefox and OpenOffice does this) with the links for release notes and other systems / languages on the front page.

It would also be possible to optimize the download page by only displaying one version at a time and killing or moving some text about system requirements and release notes.
Comment 1 Rainer Bielefeld Retired 2012-01-08 22:07:33 UTC
I agree, that page is not inviting, behavior of some elements is different from well known standards.

I bewlieve it's not really complicated, but some behavior is "non-standard", and at many places explication is missing

1. A Hyperlink in a text is blue and becomes underlined for mouseover. Itz is not useful to do it in an other way, our text hyperlinks should have blue color

2. The green check button explains nothing for someone who is here the first time, especially when all are green. Start Texts
 for 3.4.4: "Current stable version, suitabl for most users users. Before 
              downloading, please ..."
 for 3.3.5: "Stable version for conservative users, focus on reliable function
 of old documents and proven templates. Before downloading, please ..." 
So every user can see the difference.

3. An explication for what the helppack is needed is missing on the download page

4. "Other way to download LibreOffice, the productivity suite" should be replaced
by something like "Custom selection of LibreOffice components for download)

5. "....multi.exe" needs explicaton! Multiwhat?
6. "BrOffice" needs explication
7. Difference between "_all_lang.exe" and "_install_multi.exe" needs explication.
Comment 2 Andreas Nilsson 2012-01-12 11:37:06 UTC
(In reply to comment #1)

> I bewlieve it's not really complicated, but some behavior is "non-standard",
> and at many places explication is missing

It is over the phone. :)


> 2. The green check button explains nothing for someone who is here the first
> time, especially when all are green. Start Texts
>  for 3.4.4: "Current stable version, suitabl for most users users. Before 
>               downloading, please ..."
>  for 3.3.5: "Stable version for conservative users, focus on reliable function
>  of old documents and proven templates. Before downloading, please ..." 
> So every user can see the difference.


Yes, the round check icons needs to go, they serve no purpose.
I think part of the problem here is that the two versions are offered as equal, when most users are better of with 3.4.4, I would optimize for this and have it say something along the lines of "go here for other versions..."


> 3. An explication for what the helppack is needed is missing on the download
> page

If more text is added, some other text needs to be killed, because it's already too much text already on the page.


> 7. Difference between "_all_lang.exe" and "_install_multi.exe" needs
> explication.

Yes! We should not show then filenames here, but rather a descriptive name of what it is.
Comment 3 Andreas Nilsson 2012-01-12 11:58:32 UTC
Created attachment 55522 [details]
Quick and dirty mockup

This is how a frontpage download button could work. I think I got most of the stuff in it.
Comment 4 Asa Dotzler 2012-02-18 17:55:18 UTC
Andreas is right. Not only are you providing a difficult user experience, you're also very likely losing a majority of your possible downloads thanks to this broken flow. 

http://www.libreoffice.org/ should detect the user's operating system and language and dynamically generate the proper download link for the big green button.  If you need help with this, perhaps viewing the source of the Firefox download page might help. http://www.mozilla.org/firefox

The download button should include the product name, version, OS, and language and it should have a link underneath it for other OSes and languages. Just copy Firefox here. We've been tuning this thing for years and you're not going to do better. (I would not include the file size as Andreas has in his mock; it's just too big a number and will scare off people who would otherwise be willing to wait.)

When a user clicks the download button, the site should load in a new page that will be the background behind the browser's download dialogs. This page should explain the download process --  where to locate the downloaded file and how to start the installer. Optionally, this page could have "getting started" information.

I realize that you all are putting in a huge effort in making the code better, but if you don not put in the relatively smaller effort of making the download experience not suck, you're missing a huge opportunity to get actual human beings on major operating systems using your software.
Comment 5 Rainer Bielefeld Retired 2012-02-18 23:17:39 UTC
@Asa Dotzler
a) The OS and language will be recognized (At least I will get "German - WIN" suggested after I clicked the download button. Do you have different experience?

b) There is no "THE current Version" for Libo, LibO intendedly offers different versions for different user needs.

So I disagree with the modified Subject line.

But I agree, the explications on the page you reach after you have clicked are not so succinct and understandable as they should be.
Comment 6 Rainer Bielefeld Retired 2012-02-19 01:26:12 UTC
@Hi Florian:
<http://weblogs.mozillazine.org/asa/archives/2012/02/libreoffice_youre_do.html>
is worth reading ...
Comment 7 Emil Stenström 2012-02-19 04:24:11 UTC
@Rainer Bielefeld: 

a) If you know what version the user will want, why not just give him the file directly, instead of requiring an intermediate click?

b) If there are two very different use cases for LibreOffice, that's really not obvious from the download page. I see "the latest version" and "previous version", which really isn't two different use-cases.
Comment 8 Andreas Nilsson 2012-02-19 07:01:44 UTC
> b) There is no "THE current Version" for Libo, LibO intendedly offers different versions for different user needs.

Out of these two, what version would you identify to be relevant to the largest number of people?
Is the latest version bleeding edge/unstable and the old one the one you would recommend to most people, or is the old one only for very conservative users and the latest one you would recommend to most people?
Comment 9 Björn Michaelsen 2012-02-19 09:01:02 UTC
Seems to be solved for me with the download page that is online now.

@website-team: please pick up and assign/close with proper kudos to the hero implementing it!
Comment 10 Marc Pare 2012-06-26 02:23:32 UTC
Download page has been updated. Thanks to all those who worked on developing the code and the look of the page. 

Marc