Bug 44597 - FORMATTING: Margin notes (similar to footnotes, but vertically linked to content) should be enabled
Summary: FORMATTING: Margin notes (similar to footnotes, but vertically linked to cont...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: lowest enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-09 07:16 UTC by dohnp5a1
Modified: 2019-09-02 06:20 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Simulation of margin-note in LibreOffice (81.93 KB, image/png)
2012-03-15 01:52 UTC, dohnp5a1
Details
Margin-notes in use (9.83 KB, image/png)
2012-03-15 03:47 UTC, dohnp5a1
Details
Margin-notes in use (161.73 KB, image/jpeg)
2012-03-15 03:47 UTC, dohnp5a1
Details
Example of a margin note in LibreOffice (23.41 KB, application/vnd.oasis.opendocument.text)
2012-06-29 09:58 UTC, Anthony DeRobertis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dohnp5a1 2012-01-09 07:16:04 UTC
Margin notes (such as in LaTeX) should be enabled in Writer, in addition to present footnotes.
Comment 1 sasha.libreoffice 2012-03-14 22:02:20 UTC
Thanks for bugreport with new idea
Please, attach screenshot to demonstrate how it should be
Comment 2 dohnp5a1 2012-03-15 01:52:48 UTC
Created attachment 58477 [details]
Simulation of margin-note in LibreOffice
Comment 3 sasha.libreoffice 2012-03-15 03:29:33 UTC
Thanks for attachment. And how margin notes differs from comments?
Comment 4 dohnp5a1 2012-03-15 03:42:40 UTC
(In reply to comment #3)
> Thanks for attachment. And how margin notes differs from comments?

As I can see, comments are not visible on the page (they are just for internal use during editing in LO, not adjustable, printable, exportable to PDF etc.).
Comment 5 dohnp5a1 2012-03-15 03:47:06 UTC
Created attachment 58487 [details]
Margin-notes in use
Comment 6 dohnp5a1 2012-03-15 03:47:31 UTC
Created attachment 58488 [details]
Margin-notes in use
Comment 7 sasha.libreoffice 2012-03-15 04:28:24 UTC
Thanks for additional explanations and screenshots

Comments export to PDF as icons, if place mouse cursor on it, content of comment appears as tooltip.
Comments now not printable properly, but I hope that such functionality will implemented in near future.

What about Margin notes: may be such functionality already implemented somewhere among extensions for OpenOffice or LibreOffice. Please, search for such functionality among extensions.

And thanks for new idea!
Comment 8 Anthony DeRobertis 2012-06-29 09:58:42 UTC
Created attachment 63616 [details]
Example of a margin note in LibreOffice
Comment 9 Anthony DeRobertis 2012-06-29 10:00:42 UTC
LibreOffice already has margin notes, though it calls them "frames". Use Insert->Frame to add a margin note. See attachment 63616 [details] for an example.
Comment 10 dohnp5a1 2012-07-03 07:41:39 UTC
(In reply to comment #9)
> LibreOffice already has margin notes, though it calls them "frames". Use
> Insert->Frame to add a margin note. See attachment 63616 [details] for an example.

Frames are not margin notes – there is no automatic placing, numbering, moving to another page if the text linked moves etc.
Comment 11 Anthony DeRobertis 2012-07-03 09:07:04 UTC
> Frames are not margin notes – there is no automatic placing, numbering, moving
> to another page if the text linked moves etc.

Look at attachment 63616 [details], those follow the text around. If you hit enter a bunch of times to push the 2nd paragraph down (or insert a page break, etc.) the notes follow the (or particular character) paragraph, even to the next page.

The placing of those is basically automatic, you put the anchor icon on the paragraph (or character, depending on which option you pick in the dialog) that you want it anchored to. They don't handle overlap prevention, that's it.

If you want numbering (which your two examples do not show, and LaTeX \marginpar doesn't do), you can use Insert -> Fields -> Other -> Number Range to get a counter. (You can type a custom counter name into the "Name" field at the bottom-left of the dialog)
Comment 12 Joel Madero 2014-11-06 20:54:47 UTC
Looking for additional feedback on this - moving to UNCONFIRMED as REOPENED is not the appropriate status. Thanks all.
Comment 13 sophie 2014-12-18 15:23:03 UTC
I think this is a valid request because comments don't behave as special areas like page footer. However I think the usage of such notes margin is quiet low so lowering the importance. Set as New - Sophie
Comment 14 Zenaan Harkness 2016-08-29 11:29:36 UTC
> Frames are not margin notes – there is no automatic placing, numbering, moving
> to another page if the text linked moves etc.

This has been solved, works for me, at least in latest stable LO5.2.0:

These "marginalia" frames, require a frame style, where you choose (in the frame properties "Type" tab:
Position -> Horizontal -> "to" choose one of "left page border" or "right page border"
and, make sure that when you insert a new frame and apply your correctly designed "frame style", make sure you anchor it to the required paragraph.

That's it.

See my example documents with marginalia attached to bug #101753 - make sure you open the "corrected" ODT file in LO5.2 (perhaps 5.0+, I don't know sorry).
Comment 15 V Stuart Foote 2016-08-29 12:54:00 UTC
Yes this works.

Note that an appropriate Frame Style (with horizontal positioning set on the Type tab) must be defined and then applied to each Text Frame holding a comment/annotation individually.

Ability to select multiple existing frames and then apply a style would be a nice addition.
Comment 16 Cor Nouws 2016-08-29 12:59:11 UTC
It always has been possible as described > WOrksForMe
Comment 17 Emma 2019-09-02 06:20:01 UTC Comment hidden (spam)