Bug Hunting Session
Bug 44628 - unopkg.exe does not find VC runtime during install (extension registration)
Summary: unopkg.exe does not find VC runtime during install (extension registration)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Andras Timar
URL:
Whiteboard: target:3.6.1
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-01-10 03:46 UTC by Jesus Corrius
Modified: 2012-08-17 22:48 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
MSI log file (389.37 KB, application/x-zip-compressed)
2012-01-10 03:53 UTC, Jesus Corrius
Details
SxSTrace (4.47 KB, text/plain)
2012-04-25 08:33 UTC, Nathan Gautrey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesus Corrius 2012-01-10 03:46:56 UTC
Machine:

Windows 2008 R2 64 bits.

Steps to reproduce:

1. Install LibO-Dev_3.5.0beta2_Win_x86_install_multi.exe

Results:

1. During the installation you get a message box saying: "ERROR: An error occurred during the registration of extensions!"

2. The installation rolls back.
Comment 1 Jesus Corrius 2012-01-10 03:53:42 UTC
Created attachment 55378 [details]
MSI log file
Comment 2 Jesus Corrius 2012-01-10 03:54:25 UTC
I just noticed the MSI log file is partly in Catalan language, sorry for that :)
Comment 3 Andras Timar 2012-01-27 02:40:19 UTC
Acció 12:43:08: RegisterExtensions.
CustomAction RegisterExtensions returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Acció acabada 12:47:03: InstallFinalize. Valor de retorn 3.
Acció 12:47:04: Rollback. S'està desfent l'acció:

This is the only info that is relevant...

I don't know what went wrong for you. I installed a clean Windows 2008 R2 64 bits in a VM, and I could install both beta2 and rc2 without any problem.

Let me close this one, unless you have new info.
Comment 4 Dan Tisone 2012-02-21 09:35:59 UTC
I have confirmed the same error on a clean installation of W2K8R2 SP1 x64.  The installation rolls back
Comment 5 andreas.kirmair 2012-02-24 01:16:49 UTC
I have the same error, but:

System: WinXP/Win7
We have installed version 3.4.5 with Helppack
If I try to install 3.5 I get the same error and the installation does a rollback.

It doesn't matter if I uninstall 3.4.5 or install directly 3.5 without uninstall.

Here a part of my logfile:
MSI (s) (C0:F8) [16:52:34:293]: Executing op: ActionStart(Name=RegisterExtensions,,)
MSI (s) (C0:F8) [16:52:34:294]: Executing op: CustomActionSchedule(Action=RegisterExtensions,ActionType=1025,Source=BinaryData,Target=RegisterExtensions,CustomActionData=C:\Program Files\LibreOffice 3.5\)
MSI (s) (C0:F8) [16:52:34:304]: Creating MSIHANDLE (45) of type 790536 for thread 8184
MSI (s) (C0:AC) [16:52:34:304]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI61F5.tmp, Entrypoint: RegisterExtensions
MSI (s) (C0:AC) [16:52:41:309]: Closing MSIHANDLE (45) of type 790536 for thread 8184
CustomAction RegisterExtensions returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (C0:F8) [16:52:41:425]: User policy value 'DisableRollback' is 0
MSI (s) (C0:F8) [16:52:41:425]: Machine policy value 'DisableRollback' is 0
Aktion endet : InstallFinalize. Rückgabewert 3.
Comment 6 andreas.kirmair 2012-02-27 06:04:42 UTC
My error is solved.

We installed LibreOffice 3.4.5 with a Transform (without the vcredist.exe within the setup-file).

After the installation of the vcredist.exe from LibreOffice 3.4.5, the installation of LibreOffice 3.5 works without errors.

But why doesn't the installer of LibreOffice 3.5 install vcredist also?
Comment 7 andreas.kirmair 2012-03-01 05:26:00 UTC
(In reply to comment #6)
> My error is solved.
> 
> We installed LibreOffice 3.4.5 with a Transform (without the vcredist.exe
> within the setup-file).
> 
> After the installation of the vcredist.exe from LibreOffice 3.4.5, the
> installation of LibreOffice 3.5 works without errors.
> 
> But why doesn't the installer of LibreOffice 3.5 install vcredist also?

Sorry, but the error persists. This solution worked only for 1 pc.

I have downloaded 3.5.1 RC1 but I get the same error during the installation:
"ERROR: An error occurred during the registration of extensions!"
Comment 8 robert 2012-03-06 14:00:24 UTC
Same problem here, W7-64 Pro on AMD FX8150. All VC redistributables are up-to-date.

This is not a "medium" important problem, it's a complete show-stopper, as in 

"Highest" + "Blocker"
Comment 9 domi 2012-03-10 14:28:41 UTC
it is not only a matter of 64 bit

i've got the same error with XP pro SP3
"ERROR:an error occured during registration of extensions"

3.5 works install fine on 2 pc
but ever roll back on the third pc

le third PC is ok with 3.4.5 but unable to install 3.5.0
Comment 10 robert 2012-03-15 05:27:17 UTC
LO 3.5.1 gives exactly the same uninformative message and rolls back...
Comment 11 Jan Holesovsky 2012-03-16 03:57:03 UTC
So, the error comes from unopkg.exe.  Anybody of you who is able to see this error, can you please start the installation, and when you get the message box with "ERROR: An error occured during registration of extensions!", do not close it; instead open command line, change directory to the installation directory where the LO is being installed (the "program" subdirectory of that), and try:

unopkg.exe sync

and copy here everything it writes.

Thank you!
Comment 12 Jesus Corrius 2012-03-16 04:53:18 UTC
"Activation context generation failed for "C:\Program Files (x86)\LOdev 3.5\program\unopkg.exe". Dependent Assembly Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8" could not be found. Please use sxstrace.exe for detailed diagnosis."
Comment 13 Jesus Corrius 2012-03-16 04:55:29 UTC
So probably the steps to reproduce are:

1. Uninstall Visual C++ 9.0 runtimes (Visual Studio 2008).
2. Install LibreOffice 3.5.1

This problem is more often reproduced in 64 bits systems because they don't have the 32 bits one installed by default (the ones needed by LibreOffice).
Comment 14 Jesus Corrius 2012-03-16 05:20:37 UTC
CONFIRMED:

It works if you:

1. Install "Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)"

http://www.microsoft.com/download/en/details.aspx?id=5582

2. And then install LibreOffice 3.5.1.
Comment 15 Andras Timar 2012-03-16 12:44:42 UTC
I still cannot reproduce the bug using the steps in comment #13. In the install sequence, installing of msvcrt files comes before RegisterExtensions custom action (this afternoon I thought that might be the root of the bug - it wasn't).
Comment 16 domi 2012-03-18 15:16:32 UTC
unopkg.exe sync  wrote nothing to me

C:\Program Files\LibreOffice 3.5\program>unopkg list ==>
All deployed user extensions:
<none>


but in \windows\installer i found
"An application has made an attempt to load the C runtime library incorrectly.
"

i had got several versions of Microsoft Visual C++
from 2005 to 2008 with various patch numbers
i unistall all but same error about extensions


?? one interresting thing
after rollback if try erasing program files/libre office 3.5
the file tmp in C:\Program Files\LibreOffice 3.5\program\shlxthdl\
stay locked
maybe the problem is linked to the shlxthdl.dll
Comment 17 Glenn 2012-03-18 18:14:39 UTC
(In reply to comment #14)
> CONFIRMED:
> 
> It works if you:
> 
> 1. Install "Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)"
> 
> http://www.microsoft.com/download/en/details.aspx?id=5582
> 
> 2. And then install LibreOffice 3.5.1.

This worked for me, thanks! Been looking for a fix for a bit.

I'm running win7 64bit. Things that a diff about my stsem include the fact I previously installed then removed MS Studio and a bunch of related things, and also more recently removed ie9. Before originally attempting to install LO I removed OO.
Comment 18 andreas.kirmair 2012-03-20 07:13:02 UTC
unopkg.exe sync  wrote nothing to me, too

C:\Programme\LibreOffice 3.5\program>unopkg list

ERROR: [context="shared"] caught unexpected exception!

unopkg failed.



And this:

> CONFIRMED:
> 
> It works if you:
> 
> 1. Install "Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)"
> 
> http://www.microsoft.com/download/en/details.aspx?id=5582
> 
> 2. And then install LibreOffice 3.5.1.

Doesn't work for me...
Comment 19 Petr Mladek 2012-03-20 08:11:32 UTC
Put back higher priority. Well, this problem is quite hard to reproduce, so it can't block the release.
Comment 20 pesco 2012-03-21 04:15:29 UTC
I have the same error on Windows7 with SP1 x86. I used LO 3.4.5 which I am able to install without a problem but when I try to install 3.5.0 or 3.5.1 the following error occurs:
"ERROR:An error occured during registration of extensions!". In msi log file there are the same error messages as Jesus Corrius wrote.

"unopkg sync" returns nothing, with "--verbose":
"Synchronising repository for bundled extensions.
unopkg done."

I tried installing different versions of Microsoft Visual C++, disabling Antivirus software, closing all apps before installing LO. Nothing helps.
Comment 21 jan 2012-03-21 05:26:30 UTC
Log Name:      Application
Source:        SideBySide
Date:          3/21/2012 1:07:46 PM
Event ID:      33
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      WIN-45R5U0KELM5
Description:
Activation context generation failed for "C:\Program Files (x86)\LibreOffice 3.5\program\unopkg.exe". Dependent Assembly Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8" could not be found. Please use sxstrace.exe for detailed diagnosis.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="SideBySide" />
    <EventID Qualifiers="49409">33</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2012-03-21T12:07:46.000000000Z" />
    <EventRecordID>685</EventRecordID>
    <Channel>Application</Channel>
    <Computer>WIN-45R5U0KELM5</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8"</Data>
    <Data>
    </Data>
    <Data>C:\Program Files (x86)\LibreOffice 3.5\program\unopkg.exe</Data>
    <Data>
    </Data>
  </EventData>
</Event>
Comment 22 jan 2012-03-21 05:40:36 UTC
I managed to install - by letting the error window to remain open, and select restart and then FORCE
Comment 23 andreas.kirmair 2012-03-21 08:59:34 UTC
(In reply to comment #22)
> I managed to install - by letting the error window to remain open, and select
> restart and then FORCE

This works, but it's no solution for me. Because we've got around 120 computers with LibreOffice 3.4.5 installed, and I don't want to restart every computer by myself
Comment 24 Andras Timar 2012-03-21 09:50:47 UTC
(In reply to comment #23)
Andreas,  please do not change severity and version, it is not helpful.
Comment 25 Andras Timar 2012-03-21 11:28:09 UTC
unopkg.exe tried to load Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8". We install a later version of this assembly, version 9.0.30729.6161. It should not be a problem, redirecting should work. We need to find out, why it does not work in some cases. Google search suggests that maybe culture="neutral" in assemblyIdentity tag would make it work.

Question: did anybody of you experince the problem under en-US locale?
Comment 26 pesco 2012-03-22 03:55:04 UTC
(In reply to comment #25)
> (...)
> Question: did anybody of you experince the problem under en-US locale?

it is pl_PL in my case
Comment 27 Andras Timar 2012-03-22 05:45:19 UTC
Things to try:
#define _BIND_TO_CURRENT_VCLIBS_VERSION 1

deploy vc runtime as private assemblies

http://helgeklein.com/blog/2010/03/deploying-visual-c-runtime-files-as-private-assemblies/
Comment 28 Florian Effenberger 2012-04-06 11:47:49 UTC
Rumors have it, 3.5.2 has the same issue (I couldn't verify myself being on a different OS at the moment).
Comment 29 heterea 2012-04-06 14:58:58 UTC
(In reply to comment #28)
> Rumors have it, 3.5.2 has the same issue (I couldn't verify myself being on a
> different OS at the moment).

I Confirm (Windows 7 x64)
Comment 30 andreas.kirmair 2012-04-17 00:34:49 UTC
(In reply to comment #29)
> (In reply to comment #28)
> > Rumors have it, 3.5.2 has the same issue (I couldn't verify myself being on a
> > different OS at the moment).
> 
> I Confirm (Windows 7 x64)

I have the same issue with Windows XP and Windows 7 x86 and LibO 3.5.2
Comment 31 Nathan Gautrey 2012-04-25 06:52:03 UTC
Just tried LibO_3.5.2_Win_x86_install_multi on Server 2008 R2 + SP1 and I get the same problem, installing it for RDS.

Activation context generation failed for "C:\Program Files (x86)\LibreOffice 3.5\program\unopkg.exe". Dependent Assembly Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8" could not be found. Please use sxstrace.exe for detailed diagnosis.
Comment 32 Andras Timar 2012-04-25 07:24:03 UTC
We've got many confirmations, but the bug is still not reproducible by me. Please comment only when you have more details, patch, or idea.

@Jesus: you promised to send me a VM on the other day, what about that?
Comment 33 Nathan Gautrey 2012-04-25 08:33:08 UTC
Created attachment 60580 [details]
SxSTrace

This is the output from running the following commands while running the install process.

>SxsTrace Trace -logfile:SxsTrace.etl
>sxstrace Parse -logfile:SxSTrace.etl -outfile:SxSTrace.txt
Comment 34 Nathan Gautrey 2012-04-25 08:45:11 UTC
Well for me a manual install of "Microsoft Visual C++ 2008 Redistributable Package (x86)" resolved the problem.  You can download it from here:  http://www.microsoft.com/download/en/details.aspx?id=29
Comment 35 heterea 2012-05-01 14:07:11 UTC
(In reply to comment #34)
> Well for me a manual install of "Microsoft Visual C++ 2008 Redistributable
> Package (x86)" resolved the problem.  You can download it from here: 
> http://www.microsoft.com/download/en/details.aspx?id=29

Don't work for me :(

I've the same error also with LibreOffice 3.5.3 RC2
Comment 36 Not Assigned 2012-05-06 03:34:22 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b3d63df541ff6b2bf9c77699c8c076ebcde2d6cf

fdo#44628 run unopkg.exe after InstallFinalize
Comment 37 Andras Timar 2012-05-06 03:41:28 UTC
Finally I found a good description of the problem on Aaron Stebner's blog. See more at: http://blogs.msdn.com/b/astebner/archive/2007/01/09/problems-with-custom-actions-that-depend-on-the-visual-c-8-0-runtime-files-on-windows-vista.aspx 
To cut the long story short:

On Windows Vista and later, the VC 9.0 runtime files are installed to the WinSxS cache as global assemblies. In Windows Installer, it is not possible to use global assemblies until the installation transaction has been commited.  This means that only commit custom actions or custom actions sequenced to run after InstallFinalize will be able to use global assemblies that are being installed as part of the same MSI.

Possible workarounds:
1) Run RegisterExtensions custom action after InstallFinalize
2) Link VC runtime statically to unopkg.exe and unopkg.bin
3) Instal private copy of msvc90.dll next to unopkg.exe.

I chose option 1.
Comment 38 Not Assigned 2012-05-08 01:54:19 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a9dbdd81ed2d2cfb7154316e5cc3580172d31618&g=libreoffice-3-5

fdo#44628 run unopkg.exe after InstallFinalize


It will be available in LibreOffice 3.5.4.
Comment 39 domi 2012-05-09 00:40:24 UTC
thanks andras

the new installer works fine with 3.6 alpha (XP sp3)
http://dev-builds.libreoffice.org/daily/Win-x86@6-fast/master/current/
Comment 40 heterea 2012-05-09 05:20:11 UTC
(In reply to comment #38)
> Andras Timar committed a patch related to this issue.
> It has been pushed to "libreoffice-3-5":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/?id=a9dbdd81ed2d2cfb7154316e5cc3580172d31618&g=libreoffice-3-5
> 
> fdo#44628 run unopkg.exe after InstallFinalize
> 
> 
> It will be available in LibreOffice 3.5.4.

Thank you very much!!! :)
Comment 41 pesco 2012-05-31 01:52:36 UTC
I have just installed the latest LibreOffice 3.5.4 without any problems.
Thanks!
Comment 42 Michael Meeks 2012-05-31 04:17:54 UTC
lovely - nice work Jesus & Andras :-)
Comment 43 domi 2012-07-13 14:08:10 UTC
(In reply to comment #38)
> Andras Timar committed a patch related to this issue.
> It has been pushed to "libreoffice-3-5":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/?id=a9dbdd81ed2d2cfb7154316e5cc3580172d31618&g=libreoffice-3-5
> 
> fdo#44628 run unopkg.exe after InstallFinalize
> 
> 
> It will be available in LibreOffice 3.5.4.

it was fine with 3.5.4.2

but REGRESSION with 3.5.5

3.5.5 installer fails with the same extension error msg
under XP sp3
Comment 44 Andras Timar 2012-07-13 15:22:47 UTC
(In reply to comment #43)
> it was fine with 3.5.4.2
> 
> but REGRESSION with 3.5.5
> 
> 3.5.5 installer fails with the same extension error msg
> under XP sp3

Could you please be a bit more verbose? This bug has 44 comments, I'm getting lost. What was the error message you saw in 3.5.5 installer?
Comment 45 domi 2012-07-14 15:32:31 UTC
sadly the same error
"ERROR: An error occurred during the registration of extensions!"
then rollback and failed install, the same as with 3.5.3

i try unselecting all extensions (dico, scripts...)
but with the same error msg

maybe a strange thing, this error comes AFTER a message like
"deleting tmp installation files" 
when you could think that all had run fine
but not
in the very last end come the extension error msg

reinstalling 3.5.4 works fine  and 3.5.4 is useable


by the way, if it could be a link
the "update option" in the 3.5.4 [help menu/check update] is off (install button is greyed, unusable) i can only select de full download button

i have to try with the 3.6 beta to check, sorry i missed that test
Comment 46 domi 2012-07-15 12:35:25 UTC
same error with 3.6 rc1

the error came when the installer show the screen "deleting save file"
Comment 47 Andras Timar 2012-07-20 10:18:22 UTC
I could not reproduce - this time I used Virtualbox with clean OS, where MSVC runtime is not present. Moreover, workaround exists, users can install MSVC runtime manually. Many users already have it. Not critical.
Comment 48 dellaqui 2012-07-21 21:39:40 UTC
3.5.5 doesn't install on Windows XP 64bit SP2 ENG.

ERROR: an error occured during registration of extensions!

Tried more and more times. After this error it rollbacks.

If I launch (before pressing OK in the error dialog) "unopkg.exe sync" or "unopkg.exe sync --verbose" I get nothing

I also tried "msiexec /i LibO_3.5.5_Win_x86_install_multi.msi VC_REDIST=0", no luck

This error is blocking.
Comment 49 dellaqui 2012-07-21 23:41:32 UTC
Just tried installing http://www.microsoft.com/download/en/details.aspx?id=29, same error. I confirm this error is blocking.
Comment 50 dellaqui 2012-07-22 02:26:14 UTC
I confirm 3.5.4 install without errors.
Comment 51 Michael Meeks 2012-07-23 13:32:29 UTC
Presumably this affects 3.6.x too (?) - it'd be great to check that.

Do we -really- call unopkg.exe during the install of our MSI ? it seems extremely odd with the move to passively registered components etc.
Comment 52 heterea 2012-07-23 18:06:01 UTC
same error with 3.6 rc2 (Win7 x64)

moreover the installation rollback delete previous installed libreoffice relase (LO 3.5.4) :#
Comment 53 heterea 2012-07-31 09:45:20 UTC
(In reply to comment #52)
> same error with 3.6 rc2 (Win7 x64)
> 
> moreover the installation rollback delete previous installed libreoffice relase
> (LO 3.5.4) :#

same error with LO 3.6 rc4
Comment 54 Michael Meeks 2012-08-01 10:25:16 UTC
Stephan - Andras is on vacation for another week I think; thoughts on this much appreciated :-) AFAICS it is rather pleasant if we never run any unofoo.exe during MSI install, but try to do that work at first-start (?) - I wonder what if anything we're still doing of that kind in 3.6.0 ? is there a way to avoid / defer it all ?
Comment 55 Stephan Bergmann 2012-08-01 10:50:03 UTC
(In reply to comment #54)
> Stephan - Andras is on vacation for another week I think; thoughts on this much
> appreciated :-) AFAICS it is rather pleasant if we never run any unofoo.exe
> during MSI install, but try to do that work at first-start (?) - I wonder what
> if anything we're still doing of that kind in 3.6.0 ? is there a way to avoid /
> defer it all ?

With the band aid fix for bug 51252 (no longer use any data from an installation-wide share/prereg/bundled/ tree) gone into LO 3.6.0 RC4, it is no longer necessary to generate that share/prereg/bundled/ tree (which appears to be done during installation on Windows, and accounts for those calls to "unopkg sync") in the first place.  I am currently preparing a respective changeset for LO master, but am not 100% confident yet this is the best way to go anyway, with problems like bug 53009 coming up, so would not want to rush anything there.

That said, a follow-up band aid fix for LO 3.6.0 RC4 might be to remove the calls to "unopkg sync" from the Windows install scripts.
Comment 56 heterea 2012-08-10 10:27:03 UTC
(In reply to comment #53)
> (In reply to comment #52)
> > same error with 3.6 rc2 (Win7 x64)
> > 
> > moreover the installation rollback delete previous installed libreoffice relase
> > (LO 3.5.4) :#
> 
> same error with LO 3.6 rc4

same error with LO 3.6.0

why this bug it's not in the "complete list of open most annoying bugs"???

https://bugs.freedesktop.org/buglist.cgi?type0-1-0=notsubstring&field0-1-0=status_whiteboard&field0-0-0=blocked&resolution=---&resolution=FIXED&resolution=WORKSFORME&query_format=advanced&value0-1-0=target%3A3.6.0&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&type0-0-0=anywordssubstr&value0-0-0=44446&product=LibreOffice&list_id=104440
Comment 57 Andras Timar 2012-08-13 16:24:12 UTC
Finally this bug has been fixed by removing unopkg sync call during installation. If someone encounters this in 3.5.x, the workaround is in Comment 14.
Comment 58 heterea 2012-08-17 22:48:03 UTC
(In reply to comment #57)
> Finally this bug has been fixed by removing unopkg sync call during
> installation. If someone encounters this in 3.5.x, the workaround is in Comment
> 14.

LO 3.6.1 RC1 works :D

Thank you very much!!! :D


P.S. the workaround in Comment 14 doesn't work for me.