Download it now!
Bug 44691 - FORMULAEDITOR: Logarithms have no configurable base
Summary: FORMULAEDITOR: Logarithms have no configurable base
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 127407 (view as bug list)
Depends on:
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2012-01-11 09:47 UTC by Cthulhux
Modified: 2019-09-07 16:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cthulhux 2012-01-11 09:47:16 UTC
Problem description: For preparation of my university's exams I wanted to write down some formulas including logarithms to base 2. However, I found out that LibO's formula editor does not actually support different bases. I would like to propose adding this functionality.
Comment 1 tester8 2012-01-20 13:54:58 UTC
Type in Math window
log_2(N)

Is it what you want?
Comment 2 Cthulhux 2012-01-20 13:57:02 UTC
Well, half-yes, half-no. While this function (I did not know indeed, maybe a second button would do) lets me use log on base 2, what about the other bases?
Comment 3 tester8 2012-01-20 14:38:56 UTC
size*3 {log_{any base you want}(N);`lg(N);`ln(N)}

You should read help about formula format.
Comment 4 Cthulhux 2012-01-20 14:59:39 UTC
Whoops... thanks. You are right.
Comment 5 V Stuart Foote 2019-09-07 16:31:57 UTC
*** Bug 127407 has been marked as a duplicate of this bug. ***