Download it now!
Bug 44708 - FILEOPEN old document: Paragraph border FORMATTING lost
Summary: FILEOPEN old document: Paragraph border FORMATTING lost
Status: CLOSED DUPLICATE of bug 38542
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Cédric Bosdonnat
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks: 44768
  Show dependency treegraph
 
Reported: 2012-01-11 22:27 UTC by samething4030
Modified: 2012-05-23 03:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT file created in OOo 2.0.4. It contains a single pagraph with a double border. When this file is opened in LibreOffice 3.4, the paragraph border is lost. (7.47 KB, application/vnd.oasis.opendocument.text)
2012-01-11 22:27 UTC, samething4030
Details

Note You need to log in before you can comment on or make changes to this bug.
Description samething4030 2012-01-11 22:27:06 UTC
Created attachment 55476 [details]
ODT file created in OOo 2.0.4.  It contains a single pagraph with a double border.  When this file is opened in LibreOffice 3.4, the paragraph border is lost.

Problem description: 

In earlier versions and in OOo, you could create double borders for paragraphs where the two lines of the border were not the same width.  In content.xml, it would be set as something like this:

border-line-width="0.0008in 0.0346in 0.0138in"  

When a file with this kind of formatting is opened in LibreOffice 3.4, the border is not displayed, and if the file is saved again, the border data is lost.

It is not just that the border is not displayed properly.  It is that the border data is completely lost when the file is saved again.

Steps to reproduce:
1. Use an earlier version of OOo or LibreOffice to create a document with a paragraph with a double border for which the two border lines are different in width.  (See attachment.)
2. Open that document in LibreOffice 3.4 and save the document under a new file name.
3. Looking at content.xml or opening the new document in an older version shows that the border has been lost.


A simpler way to reproduce the problem:
1. Open a new document in LibreOffice 3.4.
2. Type "***" (without the quotes) and press enter.  The asterisks will be auto-replaced with a double horizontal line (actually an empty paragraph with a double bottom border).  For this double border, the lines are of different width.
3.  Save the document and close it.
4.  Open the document you saved, and the horizontal lines will be gone.

Current behavior:  Paragraphs lose border when the document is opened.

Expected behavior:  Borders are preserved.

Platform (if different from the browser): Linux (LibreOffice 3.4.3) and Windows 7 (LibreOffice 3.4.4)
              
Browser: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.16) Gecko/20111108 Iceweasel/3.5.16 (like Firefox/3.5.16)
Comment 1 Rainer Bielefeld Retired 2012-01-14 00:47:52 UTC
Also observe the problem with an 3.4.1 daily, so I believe this is one of the border compatibility issues we got with the improved border capabilities. 
Borders are shown correctly with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]" 

@Cédric:
I wonder whether this really is a WRITER problem or a more general one, I also see similar compatibility problems with CALC Cell borders.

Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 2 Michael Stahl (CIB) 2012-05-23 03:40:23 UTC
failure to import these is duplicate of bug 38542,
failure to paint the thin lines properly is duplicate of bug 48647,
works fine in LO 3.5.4 now.

*** This bug has been marked as a duplicate of bug 38542 ***