Bug Hunting Session
Bug 44823 - EDITING: CRASH opening query with Join in particular document
Summary: EDITING: CRASH opening query with Join in particular document
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other Windows (All)
: medium critical
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:3.4.6
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-16 03:09 UTC by Rainer Bielefeld Retired
Modified: 2012-02-09 01:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-01-16 03:09:29 UTC
Steps how to reproduce with Sample from "Bug 44813 - UI: Scrolling in queries with join ends with only one empty row" and "LibreOffice 3.4.5 RC2  - WIN7 Home Premium (64bit) German UI [Build ID: OOO340m1 (Build:502)]"

1. Start LibO from WIN program start center
2. Open sample document
   <https://bugs.freedesktop.org/attachment.cgi?id=55610>
3. Click "Queries"
4. double click query "With_Join"
   Expected: Table with query result will appear
   Actual: Crash, LibO stops responding

Works fine with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta3- WIN7 Home Premium (64bit) German UI [Build-ID: e40af8c-10029e3-615e522-88673a2-727f724]
Comment 1 Julien Nabet 2012-01-22 13:50:36 UTC
I don't reproduce this bug neither on 3.5 branch nor on master (both updated today) although I got several lines like this one :

warn:legacy.osl:2550:1:/home/julien/compile-libreoffice/libo/dbaccess/source/core/api/RowSetBase.cxx:1131: Old position is not equal to new postion
warn:legacy.osl:2550:1:/home/julien/compile-libreoffice/libo/svtools/source/brwbox/brwbox2.cxx:955: BrowseBox::ImplPaintData: SeekRow gescheitert

Since I'm on pc Debian x86-64, either it's Windows specific or it's fixed in 3.5 (but perhaps not on 3.5.0 rc1).

Rainer: could you try to reproduce it on 3.5.0 rc1 ?
Comment 2 Lionel Elie Mamane 2012-01-22 14:07:01 UTC
(In reply to comment #1)
> I don't reproduce this bug neither on 3.5 branch nor on master (both updated
> today) although I got several lines like this one :

> warn:legacy.osl:2550:1:/home/julien/compile-libreoffice/libo/dbaccess/source/core/api/RowSetBase.cxx:1131:
> Old position is not equal to new postion
> warn:legacy.osl:2550:1:/home/julien/compile-libreoffice/libo/svtools/source
/brwbox/brwbox2.cxx:955:
> BrowseBox::ImplPaintData: SeekRow gescheitert

These messages show a real problem and have to go away. If you get them on 3.5 branch, then I'm worried. On master branch, make sure you have commit

b026e5a4a17babd43cac266b06ad49e12f9aa225
author	Lionel Elie Mamane <lionel@mamane.lu>	2012-01-22 00:35:58 (GMT)
committer	Lionel Elie Mamane <lionel@mamane.lu>	2012-01-22 00:37:08 (GMT)

ORowSetCache::fillMatrix(): correct off-by-one error
Symptom: segfault. Thanks to Julien Nabet for precise pointer to problematic code.
Comment 3 Lionel Elie Mamane 2012-01-22 14:32:36 UTC
(In reply to comment #2)
> (In reply to comment #1)
>> I don't reproduce this bug neither on 3.5 branch nor on master (both updated
>> today) although I got several lines like this one :
 
>> warn:legacy.osl:2550:1:/home/julien/compile-libreoffice/libo/dbaccess/source/core/api/RowSetBase.cxx:1131:
>> Old position is not equal to new postion
>> warn:legacy.osl:2550:1:/home/julien/compile-libreoffice/libo/svtools/source
> /brwbox/brwbox2.cxx:955:
>> BrowseBox::ImplPaintData: SeekRow gescheitert

> These messages show a real problem and have to go away.

I could reproduce them on master, if I add more rows to adressen table. Working on it.
Comment 4 Lionel Elie Mamane 2012-01-23 01:28:15 UTC
(In reply to comment #3)
> (In reply to comment #2)
>> (In reply to comment #1)

>>> I don't reproduce this bug neither on 3.5 branch nor on master (both updated
>>> today)

This bug is about a crash in 3.4.x, not in 3.5 or 3.6.

> although I got several lines like this one :

>>> warn:legacy.osl:2550:1:/home/julien/compile-libreoffice/libo/dbaccess/source/core/api/RowSetBase.cxx:1131:
>>> Old position is not equal to new postion
>>> warn:legacy.osl:2550:1:/home/julien/compile-libreoffice/libo/svtools/source/brwbox/brwbox2.cxx:955:
>>> BrowseBox::ImplPaintData: SeekRow gescheitert

>> These messages show a real problem and have to go away.

I fixed at least one occurrence in master just now: http://cgit.freedesktop.org/libreoffice/core/commit/?id=520b8118f4a2d54e4849929d94091f29a6434346

If you still get them on master after this commit, or at all with libreoffice-3-5, please file a separate bug and assign it to me.
Comment 5 Lionel Elie Mamane 2012-01-23 01:30:03 UTC
Could reproduce.
Comment 6 Lionel Elie Mamane 2012-02-08 09:21:21 UTC
Underlying reason is same as bug 44813 and same patches solve it.  Asking for review on mailing list.
Comment 7 Lionel Elie Mamane 2012-02-08 09:32:27 UTC
Setting to critical since is a crash.
Comment 8 Lionel Elie Mamane 2012-02-09 01:45:48 UTC
Fixed in libreoffice-3-4. Please test to confirm resolution.