Download it now!
Bug 44831 - FILEOPEN Excel.xls shows #NAME instead of calculation result or formula
Summary: FILEOPEN Excel.xls shows #NAME instead of calculation result or formula
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: x86 (IA32) All
: medium critical
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.5
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-01-16 07:03 UTC by Vladislav
Modified: 2012-01-20 21:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
test file (256.50 KB, application/vnd.ms-excel)
2012-01-16 07:03 UTC, Vladislav
Details
screenshot, expected results (OOo) (278.12 KB, image/png)
2012-01-16 07:15 UTC, Vladislav
Details
screenshot, showing bug (LibreOffice 3.4.4) (136.97 KB, image/png)
2012-01-16 07:17 UTC, Vladislav
Details
lshw (18.94 KB, text/plain)
2012-01-17 00:24 UTC, Vladislav
Details
somewhat reduced test document that can still reproduce the problem. (44.00 KB, application/excel)
2012-01-20 19:22 UTC, Kohei Yoshida
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladislav 2012-01-16 07:03:00 UTC
Created attachment 55639 [details]
test file

LibreOffice 3.3.4 to current git fails to import attached file correctly.
1. Cell border thickness does not match to Excel 2003/OpenOffice 3.3.0
2. Formulas get broken. Excel 2003/OpenOffice 3.3.0 - formulas does not get broken.
3. After import application crashes (may be not reproducable)
Comment 1 Vladislav 2012-01-16 07:15:51 UTC
Created attachment 55640 [details]
screenshot, expected results (OOo)
Comment 2 Vladislav 2012-01-16 07:17:57 UTC
Created attachment 55641 [details]
screenshot, showing bug (LibreOffice 3.4.4)
Comment 3 Rainer Bielefeld Retired 2012-01-16 23:00:49 UTC
Cell border style is a DUP of several other bugs, we will ignore that here

Concerning calculation problem:

For example, second sheet Cell "I13" has "#NAME" as cell contents, not only as a shown result of an unknown function in the cell. That reminds me to "Bug 44817 - na() on summation of more than 30 items in xls format".
Worked fine with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]", so regression

I see that with a 3.4.1 RC, so Version 3.4.1 for now

@Kohei:
with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]" 


@Vladislav:
Only 1 problem per report,
 <http://wiki.documentfoundation.org/BugReport#General_information> item 4!
What is your version? Picker shows "Master", report 3.3.4!

May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> carefully before you do new reports or comments
Then please:
- Write a meaningful Summary describing exactly what the problem is
- Attach screenshots WITH COMMENTS if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (and if possible how to created a 
  sample document from the scratch)
- add information 
  -- what EXACTLY is unexpected (not only "unexpected, worong, strange")
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC 
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO version and localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read linked texts
Comment 4 Vladislav 2012-01-17 00:24:29 UTC
Created attachment 55660 [details]
lshw
Comment 5 Vladislav 2012-01-17 00:25:44 UTC
> What is your version? Picker shows "Master", report 3.3.4!
All versions 3.3.4 to yesterday git contain this bug. Bugzilla allows to select only one version, not range.

> - Write a meaningful Summary describing exactly what the problem is
OK. That's my fault to try to report two different bugs at once. Now description correctly describes the problem.
> - Contribute a step by step instruction containing every key press and every 
>   mouse click how to reproduce your problem (and if possible how to created a 
>   sample document from the scratch)
I do not know exact steps how to create sample document from scratch. Everyting I know is that attached sample document was initially created with OpenOffice.org 3.1, then edited with Microsoft Excel (unknown version, maybe 2003).
Steps to reproduce:
1. Open attached file.
What expected:
Cells shold contain formulas instead of #NAME.

>   -- concerning your PC 
lshw attached
I see same problem on several other linux desktops. So I think it is not hardware related problem.
>   -- concerning your OS (Version, Distribution, Language)
uname -a
Linux admin 2.6.35-28-generic #50~lucid1-Ubuntu SMP Fri Mar 18 19:40:19 UTC 2011 i686 GNU/Linux
cat /etc/issue
Ubuntu 10.04.3 LTS \n \l
>   -- concerning your LibO version and localization (UI language, Locale
> setting)
LibreOffice versions tested and showing the bug:
LibreOffice 3.4.5 Final (2012-01-16)
LibreOffice 3.3.4 Final (2011-08-17)
Yesterday git
LibreOffice versions tested and not showing the bug:
LibreOffice 3.3.2-1ubuntu4 (Ubuntu Natty)
OpenOffice versions tested and not showing the bug:
All tested versions open attached file correctly.
Comment 6 Rainer Bielefeld Retired 2012-01-17 00:59:15 UTC
@Vladislav: Interesting is the first version where it happened. That seems to be 3.3.4
Comment 7 Kohei Yoshida 2012-01-20 17:53:17 UTC
This one is horrible.
Comment 8 Kohei Yoshida 2012-01-20 19:22:05 UTC
Created attachment 55884 [details]
somewhat reduced test document that can still reproduce the problem.

This is for easier debugging.

The problem is probably related to how we import Excel's shared formula records.
Comment 9 Kohei Yoshida 2012-01-20 21:13:39 UTC
Fixed in 3.5 RC2.

BTW, you can remove those SHARED_FORMULA_* names from Insert -> Names -> Manage menu.  Those names weren't supposed to be visible there, and I have no idea how they ended up visible like that.