Bug Hunting Session
Bug 44842 - EDITING soffice.bin crashed with SIGSEGV in unlink_nodes()
Summary: EDITING soffice.bin crashed with SIGSEGV in unlink_nodes()
Status: RESOLVED DUPLICATE of bug 40261
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All Linux (All)
: low critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-16 13:12 UTC by Christopher M. Penalver
Modified: 2012-02-09 12:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
XMLform-1-Text-Field.odt (9.16 KB, application/vnd.oasis.opendocument.text)
2012-01-16 13:12 UTC, Christopher M. Penalver
Details
Bt with symbols on master (8.99 KB, text/plain)
2012-02-04 03:57 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2012-01-16 13:12:47 UTC
Created attachment 55653 [details]
XMLform-1-Text-Field.odt

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/917342

1) lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.0~beta2-2ubuntu3
  Candidate: 1:3.5.0~beta2-2ubuntu3
  Version table:
 *** 1:3.5.0~beta2-2ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/917262/+attachment/2677806/+files/XMLform-1-Text-Field.odt && lowriter -nologo XMLform-1-Text-Field.odt

highlight the object -> turn on Design mode -> double click the object and the menu comes up.

4) What happens instead is Writer crashes. A screenshot of Writer as it is crashing may be found at: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/917262/+attachment/2677583/+files/Screenshot%20at%202012-01-16%2010%3A41%3A44.png .

First reported against LO 3.4.4, Version -> 3.4.4
Comment 1 Julien Nabet 2012-02-04 03:57:23 UTC
Created attachment 56595 [details]
Bt with symbols on master

I reproduced this problem with master (updated today) on pc Debian x86-64.
I checked the size of m_aOrderedLines and m_aLines, they both equal to 36.
Comment 2 Julien Nabet 2012-02-04 03:58:02 UTC
I changed version since I reproduce it also on master.
Comment 3 Christopher M. Penalver 2012-02-04 04:05:15 UTC
Julien Nabet, please do not toggle the version. For more on this please see:
http://wiki.documentfoundation.org/BugReport_Details#Version
Comment 4 Alex Thurgood 2012-02-09 12:48:16 UTC

*** This bug has been marked as a duplicate of bug 40261 ***