Download it now!
Bug 44915 - MSI does not read localized storage transform for many languages
Summary: MSI does not read localized storage transform for many languages
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.0 Beta3
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-01-18 14:24 UTC by Pedro
Modified: 2020-02-11 16:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Select language dialog in the Abiword installer (4.48 KB, image/png)
2012-01-19 03:53 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2012-01-18 14:24:29 UTC
The installer briefly displays the text in the OS language and switches to English without any user intervention.
This has been registered for pt-PT by myself and for pt-BR by Olivier Hallot
Comment 1 Olivier Hallot 2012-01-18 17:21:10 UTC
confirmed with winXP and W7, both under VirtualBox 4,1,8
Comment 2 Andras Timar 2012-01-19 03:41:33 UTC
It happens to about 50% of the available languages, for example Russian and Chinese, while for example German, French, Italian are OK.

It does not depend on script. We have Belorussian and Kazakh, but not Russian. We have Korean and Japanese, but not Chinese. We have Catalan, but not Spanish.

It does not depend on the order of storage transforms in MSI database. While languages at the end of the list are usually available, and the first half is usually not available, there are exceptions, for example Kazakh, which works and which was in the first half of the list. 

Log files (msiexec /L*v) are not very informative. In case of Calalan, which worked, I see the following lines in the log:

MSI (c) (30:C4) [12:10:44:923]: Looking for storage transform: 1027
MSI (c) (30:C4) [12:10:44:923]: Validating transform '1027' with validation bits 0
MSI (c) (30:C4) [12:10:44:939]: Transform '1027' is valid.

These lines are missing in case of pt-BR. But when I start installation with the explicit command: msiexec /i LibO<...>.msi TRANSFORMS=:1046, then I see pt-BR localized interface and similar lines in the log:

MSI (c) (1C:E4) [12:24:26:501]: Looking for storage transform: 1046
MSI (c) (1C:E4) [12:24:26:501]: Validating transform '1046' with validation bits 0
MSI (c) (1C:E4) [12:24:26:501]: Transform '1046' is valid.

I'm afraid it is a bug in MSI engine, maybe there are too many transforms.
Comment 3 Pedro 2012-01-19 03:53:23 UTC
Created attachment 55771 [details]
Select language dialog in the Abiword installer

> I'm afraid it is a bug in MSI engine, maybe there are too many transforms.

What about pt-PT?

In any case, maybe the best (and more elegant) solution is to have a first installer screen (like the one in the attached image from Abiword) where the installation language is suggested based on locale but the user can select manually.

Does this help with the problem of "too many transforms"?
Comment 4 Andras Timar 2012-01-19 04:14:22 UTC
(In reply to comment #3)
> What about pt-PT?

Same as the rest of the failing languages.

> Does this help with the problem of "too many transforms"?

No. Abiword's installer is not MSI.
Comment 5 Pedro 2012-01-19 04:31:25 UTC
> > Does this help with the problem of "too many transforms"?
> 
> No. Abiword's installer is not MSI.

I'm aware of that. I meant if deliberately selecting a language first could prevent the switching that occurs for some odd reason (the installer does start in Portuguese).

The language switch happens during the "Preparing to install..." stage. Even before the "Computing space requirements" dialog
Comment 6 Andras Timar 2012-01-19 06:58:05 UTC
In MSI the Summary Information -> Language field was truncated at 254 characters. It is possible that it cannot be longer than 254 characters, or the tools cannot add a longer string. It still needs to be investigated. We have 107 languages now and almost each has a 4 chars long LCID, plus the separating comma, so in this scheme we can support only 51 languages.
Comment 7 Pedro 2012-01-19 09:02:21 UTC
I have no idea if this applies to LO, but seems to be a solution to a similar problem
http://www.geektieguy.com/2010/03/13/create-a-multi-lingual-multi-language-msi-using-wix-and-custom-build-scripts/
Comment 8 Andras Timar 2012-01-19 14:26:02 UTC
fixed in master (-> 3.6)
review pending for 3.5
Comment 9 Olivier Hallot 2012-01-29 02:23:37 UTC
On RC2, after a fress install, the dialogs are in pt-BR,

However, on a customized installation where I removed tons of useless dictionaries, the UI is in english and not in pt-BR.

This is a serious issue.
Comment 10 autoinsuranceclick 2019-08-07 08:23:06 UTC Comment hidden (spam)
Comment 11 earnmoneynetwork 2019-08-07 08:38:07 UTC Comment hidden (spam)