Bug Hunting Session
Bug 44937 - Fonts rendered incorrectly in presentation SLIDESHOW mode REGRESSION
Summary: Fonts rendered incorrectly in presentation SLIDESHOW mode REGRESSION
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-19 06:30 UTC by Vossman
Modified: 2014-03-03 16:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test case odp file (12.75 KB, application/vnd.oasis.opendocument.presentation)
2012-01-19 06:30 UTC, Vossman
Details
v3.5.0rc1 editor window screenshot (99.82 KB, image/png)
2012-01-19 06:32 UTC, Vossman
Details
v3.5.0rc1 presentation mode screenshot (41.73 KB, image/png)
2012-01-19 06:33 UTC, Vossman
Details
v3.4.5 editor window screenshot (101.92 KB, image/png)
2012-01-19 06:33 UTC, Vossman
Details
v3.4.5 presentation mode screenshot (42.29 KB, image/png)
2012-01-19 06:34 UTC, Vossman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vossman 2012-01-19 06:30:56 UTC
Created attachment 55783 [details]
test case odp file

I just noticed in 3.5.0beta3 that the fonts are different in the editor versus the presentation mode (see attachments). I do not like how it looks in presentation mode.
Comment 1 Vossman 2012-01-19 06:32:50 UTC
Created attachment 55784 [details]
v3.5.0rc1 editor window screenshot
Comment 2 Vossman 2012-01-19 06:33:20 UTC
Created attachment 55786 [details]
v3.5.0rc1 presentation mode screenshot
Comment 3 Vossman 2012-01-19 06:33:47 UTC
Created attachment 55787 [details]
v3.4.5 editor window screenshot
Comment 4 Vossman 2012-01-19 06:34:29 UTC
Created attachment 55788 [details]
v3.4.5 presentation mode screenshot
Comment 5 Vossman 2012-01-19 06:49:15 UTC
This bug seems to be related to bug #43009 (Launchpad: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/779366 ) 

but I get the error with Liberation Sans in SLIDESHOW. I tried updating font from 1.06 to 1.07.1 and I still get the error.
Comment 6 fabien.michel 2012-01-25 03:56:24 UTC
I reproduce this bug

LibreOffice 3.5.0rc1 
Version ID : b6c8ba5-8c0b455-0b5e650-d7f0dd3-b100c87

MacOS 10.5 leopard - Intel


This occur with all fonts i've tried : Arial, Times New Roman, Helvetica
Comment 7 Cristián Rojas 2012-01-29 11:40:35 UTC
I've seen the same behavior in 3.4.4 for Ubuntu Oneiric.
Comment 8 Vossman 2012-02-27 06:40:43 UTC
I just downloaded 3.5.1rc1 from the pre-release section and the fonts are working properly, I would like to wait until the full 3.5.1 comes out before closing bug.

What are others seeing?
Comment 9 Petr Mladek 2012-02-27 06:58:02 UTC
It seems to be fixed in 3.5.1-rc1 => it does not need immediate attention => let's leave it out of the most annoying bugs.

Feel free to put it into most annoying bugs if you still see it with 3.5.1-rc1 or never.
Comment 10 kghose 2012-03-08 06:05:02 UTC
The bug is not present in LibreOffice 3.5.1.1 on Mac OS X 10.7.3 (though it exists in 3.5.1rc3)
Comment 11 Vossman 2012-03-08 10:58:07 UTC
Just downloaded 3.5.1rc2 from the pre-release folder and I have no problems, just like 3.5.1rc1.

kghose: Since 3.5.1rc3 has not even been tagged yet, reading your message is very confusing.
Comment 12 Cor Nouws 2012-04-09 11:37:26 UTC
(In reply to comment #11)
> Just downloaded 3.5.1rc2 from the pre-release folder and I have no problems,
> just like 3.5.1rc1.
> 
> kghose: Since 3.5.1rc3 has not even been tagged yet, reading your message is
> very confusing.

@vossman: I cannot check on Mac, but according to your report I set this to fixed.
thanks for reporting & updating!
Cor
Comment 13 Vossman 2012-04-09 12:05:12 UTC
Still no problems in 3.5.2, so hopefully this one is gone for good.
Comment 14 Cor Nouws 2012-04-15 03:09:36 UTC
(In reply to comment #13)
> Still no problems in 3.5.2, so hopefully this one is gone for good.

AH yes, that sounds logic, of course if the fix is correct. So I close this now.
& please jump in here or in a different issue if needed :-)