Bug Hunting Session
Bug 44959 - MAILMERGE: crash when printing the Master Document including "Mail merge fields" of Database Fields
Summary: MAILMERGE: crash when printing the Master Document including "Mail merge fiel...
Status: RESOLVED DUPLICATE of bug 100275
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-19 18:36 UTC by sanada
Modified: 2017-02-16 15:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
dialogs that is displayed when it crashed. (11.66 KB, image/png)
2012-01-19 18:36 UTC, sanada
Details
OpenJDK error log (131.28 KB, text/x-log)
2013-06-25 17:42 UTC, Thomas Hackert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sanada 2012-01-19 18:36:56 UTC
Created attachment 55816 [details]
dialogs that is displayed when it crashed.

- Master Document (*.odm)
- Calc Document (*.ods)

CONFIRMATION PROCEDURE

1. open the Calc.
2. input to "name" for A1 cell and "value" for A2 cell at first, following save  Calc-document to any place and close Calc.
3. open the Master Document from menu-bar; 'File' - 'New' - 'Master Document'.
4. insert a Field on the Master Document:
4-1. open a Fields dialog from shortcut key on 'Ctrl + F2' and display a 'Database' tab.
4-2. select a ods file that created in PROCEDURE 2; use to 'Add database file', 'Browse...' button.
4-3. choose to following;Type = 'Mail merge fields', Database selection = most deep part of database that added PROCEDURE 4-2. click 'Insert'.
5. print in the state that DB field was inserted on a master-document.
5-1. click 'Yes' on displayed 'Mail merge' operation daialog.
**** If versions prior to 3.5.0 (including OpenOffice.org), after that without to advancing, it can behave like nothing happened.
5-2. click 'OK' on displayed 'Mail merge' dialog.
5-3. it crashes at this point in time, and it is shown a Master document is targeted for recovery on the next time by dialog.
5-3-1. 'Print monitor' dialog is displayed when I change foreground indication window before clicking the 'OK' button on dialog.
5-3-2. LibO completely shutdown when click a "OK".

SUPPLEMENT
The file to use in PROCEDURE 2 and 4-2 is the situation that is similar in *.csv as well as *.ods.

SPECULATION
not Master document, 'Mail merge' is completed without problem in the normal Writer document.

OS
WinXP x64 SP2
Comment 1 sanada 2012-01-19 18:38:33 UTC
for JAPANESE:

マスタードキュメントに「データベースフィールド」の「差し込み印刷フィールド」を含めて印刷した場合、クラッシュする。
--------------

・マスタードキュメント(*.odm)
・DB用calcドキュメント(*.ods)

確認手順
1. Calcを開く
2. A1セルに「name」、A2セルに「value」と入力し、任意の場所に保存し、閉じる
3. メニューバーより「ファイル|新規作成|マスタードキュメント」を開く
4. マスタードキュメント上にフィールドを埋め込む:
4-1. ショートカットキー「Ctrl+F2」よりフィールドダイアログを開き、「データベース」タブ画面を表示
4-2. 「データベースファイルを追加」(「検索」ボタン)にて、手順2.で作成したodsファイルを選択
4-3. フィールドタイプ=「差し込み印刷フィールド」、データベースの選択=手順4-2.で追加したデータベースの最深部を選択し、「挿入」ボタン押す
5. 文書上にDBフィールドが埋設された状態で、印刷を実行
5-1. 差し込み印刷の実行確認メッセージが表示される;「はい」ボタンを押す
**** 3.5.0以前のバージョンでは(OpenOfficeも含む)、この先には進まず、何事もなかったかのうように振舞われる
5-2. 「差し込み印刷」ダイアログが表示されるので「OK」ボタンを押す
5-3. この時点でクラッシュし、マスタードキュメントが次回回復対象となっている旨がダイアログに表示される。
5-3-1. ダイアログの「OK」ボタンを押す前に、最前面表示ウィンドウを切り替えると、「メモリモニター」ダイアログが表示されている。
5-3-2. 「OK」ボタンを押すと、LibOが完全にシャットダウンする

補足
手順2.および手順4-2.で使用するファイルは*.ods以外にも、*.csvでも同様の状況

考察
マスタードキュメントでなく、通常のWriter文書では、問題なく差し込み印刷が完了する
Comment 2 sanada 2012-01-30 17:59:33 UTC
LibO 3.5.0 RC-2 isn't improved, too.
Comment 3 Brennan Vincent 2012-08-20 21:30:29 UTC
Hi sanada,

I can't understand what you mean in Step 5. Perhaps you could rephrase it, or we could wait for someone who understands Japanese to read this bug.
Comment 4 Thomas Hackert 2013-06-25 17:41:35 UTC
Hello Sanada, *,
I can confirm your bug with LO Version: 4.1.0.1 Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 with installed Germanophone lang- as well as helppack under Debian Testing AMD64 ... :( When I press print at the end, LO crashes and OpenJDK 6.0.27-b27 spits an error to me ... :( I will attach the hs_err log afterward ... ;)
Sorry for the inconvenience
Thomas.
Comment 5 Thomas Hackert 2013-06-25 17:42:14 UTC
Created attachment 81423 [details]
OpenJDK error log
Comment 6 Alex Thurgood 2015-01-03 17:39:47 UTC Comment hidden (no-value)
Comment 7 Julien Nabet 2015-11-10 21:43:51 UTC
Like Brennan, I don't understand step 5 too.

Any update with last stable version 5.0.3?
If yes, would it be possible to provide a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace)
Comment 8 Caolán McNamara 2016-06-02 20:14:09 UTC
I think 5 is just to use file->print and then you get the "you have form field, do you want to print a form letter dialog", but there is no crash for me
Comment 9 Caolán McNamara 2016-06-10 13:55:09 UTC
I can't be sure, but I guess its likely this is the same problem a 100275 which is also a crash on printing a mail merged document with a very similar procedure in its how to

*** This bug has been marked as a duplicate of bug 100275 ***