Download it now!
Bug 44983 - FILEOPEN RTF import of \paperh has no effect without \pghsxn
Summary: FILEOPEN RTF import of \paperh has no effect without \pghsxn
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4 Daily
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 04:40 UTC by jtownsend
Modified: 2013-11-27 22:33 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
RTF document containing tables (108.67 KB, application/rtf)
2012-01-20 04:40 UTC, jtownsend
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jtownsend 2012-01-20 04:40:55 UTC
Created attachment 55828 [details]
RTF document containing tables

Using Adobe InDesign, I created a small RTF file containing 6 small tables. LibreOffice Writer will not import them correctly, where as both OpenOffice writer and TextMaker imported the file as per the original.
Comment 1 s-joyemusequna 2012-01-20 10:54:26 UTC
Confirmed for LibO 3.4. The page is a mess if opened with LibO 3.4.4.

But if we open the page with LibO 3.5 Beta3 it looks much much better, all tables are displayed correctly, all fonts are correct even if it looks slightly different compared with Word 2007.

The original document has a paper format "Statement" (13,97 cm x 21,57 cm). LibO 3.4 Beta3 uses A4 format instead because the format "Statement" is not defined. Thus the values must be manually set.
Comment 2 Miklos Vajna 2012-01-20 15:49:18 UTC
Assign to me, ignoring the paper size is a bug.
Comment 3 Miklos Vajna 2012-01-20 16:03:12 UTC
Fixed in master: http://cgit.freedesktop.org/libreoffice/core/commit/?id=c39e891d4dc963d2cac9843b426494e4dc490278

Will request a backport to -3-5 as well.
Comment 5 jtownsend 2012-01-23 11:05:35 UTC
Should I re-compile with LibO 3.5 Beta3??

On 1/20/2012 12:54 PM, bugzilla-daemon@freedesktop.org wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=44983
>
> s-joyemusequna@vf.uni-konstanz.de changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>               Status|UNCONFIRMED                 |NEW
>       Ever Confirmed|0                           |1
>
> --- Comment #1 from s-joyemusequna@vf.uni-konstanz.de 2012-01-20 10:54:26 PST ---
> Confirmed for LibO 3.4. The page is a mess if opened with LibO 3.4.4.
>
> But if we open the page with LibO 3.5 Beta3 it looks much much better, all
> tables are displayed correctly, all fonts are correct even if it looks slightly
> different compared with Word 2007.
>
> The original document has a paper format "Statement" (13,97 cm x 21,57 cm).
> LibO 3.4 Beta3 uses A4 format instead because the format "Statement" is not
> defined. Thus the values must be manually set.
>
Comment 6 Miklos Vajna 2012-01-23 11:19:39 UTC
Just build the master or libreoffice-3-5 branch. Or wait till 3.5rc2 is released in a few days.