Bug Hunting Session
Bug 45006 - Contextual font menu ends after 100 entries
Summary: Contextual font menu ends after 100 entries
Status: RESOLVED DUPLICATE of bug 34085
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 13:09 UTC by Emir Sarı
Modified: 2013-11-08 03:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
font menu (204.25 KB, image/png)
2012-01-20 13:09 UTC, Emir Sarı
Details
example document (8.33 KB, application/vnd.oasis.opendocument.text)
2012-01-21 12:11 UTC, Emir Sarı
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı 2012-01-20 13:09:15 UTC
Created attachment 55870 [details]
font menu

Greetings,

When I want to select the font of selected text, I see that contextual font menu ends at letter D.
Comment 1 Rainer Bielefeld Retired 2012-01-21 01:29:41 UTC
NOT reproducible with "LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit) 
NOT reproducible with "LibreOffice 3.5.0 RC1 German UI/Locale [Build-ID: b6c8ba5-8c0b455-0b5e650-d7f0dd3-b100c87] on German WIN7 Home Premium (64bit)  

The main problem seems to be that the scroll down arrow at the bottom is missing.
I wonder whether there are other menus working the same way.

@reporter:
May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> carefully?
Then please:
- Attach a sample document (not only screenshot)
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem 
- add information 
  -- What's with scrolling using mouse wheel or arrow keys? Does that work?
  -- Scroll up arrow also missing?
  -- what EXACTLY is unexpected  (In what situation do you see that?)
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO VERSION and localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  -- everything else crossing your mind after you read linked texts
Comment 2 Emir Sarı 2012-01-21 12:11:19 UTC
Created attachment 55926 [details]
example document
Comment 3 Emir Sarı 2012-01-21 12:18:18 UTC
Hello,

-I open up a blank document.
-Type something.
-Select the text.
-Right click on the text,
-Go to font menu,
-Take cursor downwards, so that the fonts begin scrolling,
-Menu ends at font Didot.

-Scrolling does not work either way - with arrows or mouse.
-Scroll up is present. 
-It happens at every document.
-Mac OS X 10.7.2 Turkish loc.
-Libreoffice 3.4.5 Turkish Loc. Reproducible with English loc.
-I open documents either with clicking on them or the open menu. 
-My settings are generally default settings. 


-I believe it is a bug of Libreoffice Mac version.
Comment 4 Emir Sarı 2012-02-15 04:47:25 UTC
Issue persists on 3.5.0.
Comment 5 Rainer Bielefeld Retired 2012-02-15 05:46:39 UTC
@emir_sari@msn.com:
More interesting would be where the problem started
Comment 6 Emir Sarı 2012-02-15 11:59:53 UTC
Well, I cannot tell where this's started; I've just noticed that it does not scroll down beyond letter D; specifically after the font named: "Didot"
Comment 7 Emir Sarı 2012-02-17 10:02:52 UTC
Can't anyone confirm this on a Mac?
Comment 8 Roman Eisele 2012-08-29 09:03:32 UTC
REPRODUCIBLE with LibreOffice 3.6.1.2 (Build ID: e29a214), German langpack installed, on MacOS X 10.6.8 (Intel).

In my case the font list ends at letter H ("Helvetica"). So I think that this is neither a problem with the scrolling of contextual menus (scrolling the menu up and down works fine) nor with fonts beginning with "D", but
* either just with the count of fonts installed on the machine --
  the contextual menu then only displays a limited count of entries;
  this seems probable to me --,
* or a special issue with some font which comes after the last displayed font.
  But I can't confirm this (2nd) possibility, because the next font after
  Helvetica is Helvetica CY, which should work (there is no problem with
  Geneva CY earlier in the contextual menu).

So most probably just a problem with the count of fonts installed?!
In any case, REPRODUCIBLE.
(I have just never noticed this problem before because I never use the contextual menu to select a font face, sorry.)
Comment 9 Roman Eisele 2012-08-29 09:08:02 UTC
In reply to comment #8)
> So most probably just a problem with the count of fonts installed?!

Seems so -- if I de-install two fonts which are in the (alphabetical) list before "Helvetica", two more fonts after "Helvetica" are displayed. Probably really a very stupid bug about entry count in contextual menues.


And:
Already REPRODUCIBLE with LibreOffice 3.3.0, results identical.
-> Changed Version accordingly.
Comment 10 Roman Eisele 2012-08-29 09:16:41 UTC
(In reply to comment #9)
> Probably really a very stupid bug about entry count in contextual menues.

Yes, and even very obvious -- if I didn’t make a mistake while counting, the contextual font menu has got exactly 100 entries, all fonts after the 100th are just missing. -> Adapted summary.
Comment 11 justflythere 2013-11-08 03:22:53 UTC

*** This bug has been marked as a duplicate of bug 34085 ***