Download it now!
Bug 45042 - The Document Converter wizard is crashing on Windows OSs
Summary: The Document Converter wizard is crashing on Windows OSs
Status: RESOLVED DUPLICATE of bug 43644
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.5.0 Beta0
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-21 08:48 UTC by William Gathoye
Modified: 2012-02-07 07:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The displayed error in the converter macro (345.03 KB, image/jpeg)
2012-01-21 08:48 UTC, William Gathoye
Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Gathoye 2012-01-21 08:48:50 UTC
Created attachment 55918 [details]
The displayed error in the converter macro

The Document Converter is crashing when I try to open it.
I get a BASIC error (see screenshot I submitted) at this line:

oBinFilterComp = createUnoService( "com.sun.star.comp.office.BF_MigrateFilter" )


I reproduced this bug only on Windows OS (tested on Windows 7 x64 with LibO 3.5b0 to 3.5rc1).

Not reproducible on Linux OS:
- Tested with 3.5rc1 
- Tested with the latest version I compiled from git
Comment 1 Pedro 2012-01-21 08:58:25 UTC
I can confirm this bug under Win XP Pro x86 SP3.

The BASIC error reports that it can't load library bf_migratefilterlo.dll

Checking the "program" folder, I can confirm that the dll is not there and in fact NONE of the bf*.dll that were included previously are there.
Comment 2 Jean-Baptiste Faure 2012-01-22 03:04:45 UTC
Perhaps LO need legacy filters to do the conversion. And they are not installed by default under MS-Windows. Did you install them ?

That said LO should not crash but it should display an error message.

Best regards. JBF
Comment 3 William Gathoye 2012-01-22 04:10:08 UTC
Jean-Baptiste Faure,


LO doesn't crash but display this error message : library bf_migratefilterlo.dll not found, as Pedro confirmed.

I don't know why all the bf*.dll files have been removed from the program folder.

This macro worked fine with LO 3.4.X.

I haven't installed additional filters. All the default components were selected during the installation : any checkboxs have been unchecked.
Comment 4 Petr Mladek 2012-01-26 07:42:15 UTC
It helped me to install the optional component "Legacy filters".

One solution is to install them by default.
Another possibility is to hack the converter to use these filters only when available.

Workaround is easy => can't block the 3.5.0 release => reducing severity a bit.
Comment 5 Petr Mladek 2012-01-26 07:57:03 UTC
The interesting thing is that it works in LO-3.4.5 even when "Legacy filters" are not installed. I wonder what has changed since there.
Comment 6 khagaroth 2012-02-07 07:32:50 UTC
This is a dupe of bug 43644.

*** This bug has been marked as a duplicate of bug 43644 ***