Bug 45067 - PIVOTTABLE: Pivot Table convert dates fields in text fields with date format ('), and don't lets grouping by date fields
Summary: PIVOTTABLE: Pivot Table convert dates fields in text fields with date format ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: Other Windows (All)
: high critical
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.5
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-01-21 20:34 UTC by m.a.riosv
Modified: 2016-05-01 15:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
small sample (11.22 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-01-23 10:06 UTC, GerardF
Details
example of formatting breking pivot table grouping (14.08 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-03-04 14:53 UTC, ktos.obcy+freedesktop
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2012-01-21 20:34:55 UTC
The data from a dates field are converted in text dates, not in calc dates, and i guess for this it can't be grouped.

This occurs with a file created from scratch with a few rows data.
Comment 1 GerardF 2012-01-23 10:06:08 UTC
Created attachment 56049 [details]
small sample

It is a regression.
Comment 2 Kohei Yoshida 2012-01-23 14:10:37 UTC
I'll keep it for now.
Comment 3 Kohei Yoshida 2012-01-23 14:46:11 UTC
This is already broken in 3.4 for me.  Did it work for you in 3.4?
Comment 4 Kohei Yoshida 2012-01-23 14:54:04 UTC
Ah nevermind it works in 3.4.
Comment 5 Kohei Yoshida 2012-01-23 14:54:27 UTC
I'll look into it.
Comment 6 Kohei Yoshida 2012-01-23 19:39:11 UTC
Fixed on master.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c659e692a17cc10d364a2304bead9403fc6bdde

I'll ask for a review for backporting this to 3.5.

Note that even with this fix applied, you'll still need to delete and re-create the pivot table output that has this problem.  Simply refreshing the table won't fix it.
Comment 7 GerardF 2012-01-24 01:53:58 UTC
See https://bugs.freedesktop.org/show_bug.cgi?id=45164

It is also broken in 3.4.5.
I'm pretty sure it works with 3.4.4 and previous.

Is it possible to backport this fix for 3.4.6 ?
Comment 8 Kohei Yoshida 2012-01-24 07:18:32 UTC
(In reply to comment #7)
> See https://bugs.freedesktop.org/show_bug.cgi?id=45164
> 
> It is also broken in 3.4.5.
> I'm pretty sure it works with 3.4.4 and previous.
> 
> Is it possible to backport this fix for 3.4.6 ?

Nope.  Sorry.  We may not be able to backport to 3.5 either.  3.4 is out of the question.
Comment 9 m.a.riosv 2012-01-24 11:59:48 UTC
First of all, thanks for your so good work and efforts.

Understanding the difficulties to fix the bug in time, seems to me that the regression bugs, like this, many times invisibles to the user in a first instance, are the worst and carry to a very bad impression on the software, because they make to fall the confidence in the product. You can't be thinking about if the things that worked before, works now.

IMHO it's much better delay the release, when regression are there, specially with those what can interfere in the work without notice.

The 3.5 can be a very good and best release if was reachable to eliminate the regression bugs.
Comment 10 Kohei Yoshida 2012-01-24 12:08:41 UTC
Delay is not happening on a time-based release. Period.
Comment 11 Kohei Yoshida 2012-01-24 14:07:37 UTC
Ok. At least I've come up with a non-invasive fix for this.  Let's see if we can get this piece included in 3.5.0.  If not, I hope it to be at least in 3.5.1.
Comment 12 m.a.riosv 2012-01-24 15:02:28 UTC
Nice to see a solution for this bug.
Thanks.
Comment 13 Petr Mladek 2012-01-25 08:38:01 UTC
The fix works => pushed into 3-5 branch for 3.5.1, see
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=6cc0bf1394ef9d6941d38a55a6155688a6f9bd43

Two more approvals are needed to get it into 3-5-0 branch for 3.5.0-rc3
Comment 14 Markus Mohrhard 2012-01-25 13:21:42 UTC
Pushed to 3-5-0. Will be fixed in 3.5.0RC3
Comment 15 Jean-Baptiste Faure 2012-01-25 21:29:28 UTC
Indeed, works well with this patch. Tested in LO 3.5.0 rc2+ under Ubuntu 11.10.

Thank you Kohei and all others who make possible to get it in 3.5.0 :-)

Best regards. JBF
Comment 16 ktos.obcy+freedesktop 2013-03-04 14:50:48 UTC
Just stumbled against same issue in 4.0.0.3 - in the attached example trying to use groupping (F12) causes adding extra column. 

Also (I'll add another example) - if the cell formatting for date contains any text string (i.e. DD" / "MMM" / "YYYY) then pivot table based on that formatting is converted to text thus resulting in lack of grouping.
Comment 17 ktos.obcy+freedesktop 2013-03-04 14:53:37 UTC
Created attachment 75899 [details]
example of formatting breking pivot table grouping
Comment 18 Kohei Yoshida 2013-03-05 02:51:17 UTC
Please file a new bug.  It's not a good practice to reopen a very old bug which was filed against a very old version.
Comment 19 Jean-Baptiste Faure 2016-05-01 15:57:30 UTC
regression keyword set from comment #1 and comment #4.