Bug Hunting Session
Bug 45076 - FORMCONTROLS: Form controls don't retain their position and size
Summary: FORMCONTROLS: Form controls don't retain their position and size
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:3.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-22 05:16 UTC by Zarko Zivanov
Modified: 2012-01-26 13:00 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Gradual changes of control's position and size (1.20 MB, image/png)
2012-01-22 05:16 UTC, Zarko Zivanov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zarko Zivanov 2012-01-22 05:16:42 UTC
Created attachment 55955 [details]
Gradual changes of control's position and size

Problem description: 
After saving the document, and opening it again, form controls (buttons, drop-down lists) aren't at the position they were at before saving, and their size is changed. After repeating the proces several times, the position and size are changed dramatically. This can be seen in screenshots attached, where first image is document before closing and opening it again, and last one is after 4-th saving/opening (I entered 1 in one cell, and erase it, just to make the change).

Text on butons after 4-th opening/saving is almost unreadable. This makes my document almost unusable.

Steps to reproduce:
1. Make a document, put some controls on it
2. Save document and close it
3. Open document -> control positions and size is changed

Current behavior:
Controls change their position and size after saving and opening again

Expected behavior:
Controls should be at the exact same position where I left them, and at the same size as I left them.

Platform (if different from the browser): 
Ubuntu 11.10 32-bit, LibreOffice 3.4.5 from official PPA
              
Browser: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Comment 1 Zarko Zivanov 2012-01-22 06:22:51 UTC
After about 10 save/open cycles, most of my controls are reduced to a 1 pixel line. Same thing happens with 3.4.4 version (Ubuntu's recommended updates), and 3.4.3 (Ubuntu's standard repository). I also tried 3.3.3 version on Mint Debian, that one works as expected.
Comment 2 Zarko Zivanov 2012-01-22 08:15:23 UTC
I just tested LO 3.5.0rc1 (as part of QA/BugHunting Session 3.5.0.-2) and this version retains controls position and size.
Comment 3 tester8 2012-01-26 13:00:25 UTC
Resolved - Fixed
Due to reporters comments.